]> git.pld-linux.org Git - packages/celestia.git/blame - celestia.spec
- include celestia_constellations.mo files
[packages/celestia.git] / celestia.spec
CommitLineData
efaf8d4e 1
2%bcond_without kde # KDE UI as the default one
3%bcond_with gtk # use gtk2 UI instead
4%bcond_with gnome # use libgnome2 UI instead
5%bcond_with glut # use glut UI instead
6
7%if %{with gtk} || %{with gnome} || %{with glut}
8%undefine with_kde
9%endif
10
ff9c6890 11Summary: A real-time visual space simulation
57396fd6 12Summary(pl.UTF-8): Symulacja przestrzeni kosmicznej w czasie rzeczywistym
ff9c6890 13Name: celestia
84e273a4 14Version: 1.5.1
52c7f06c 15Release: 0.2
ff9c6890 16License: GPL
0e5662ec 17Group: X11/Applications/Science
f0c406a2 18Source0: http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
84e273a4
KK
19# Source0-md5: df6854a2cf62d2e96612398c13b68fd2
20Patch0: %{name}-as-needed.patch
21Patch1: %{name}-gcc43.patch
22Patch2: %{name}-extras.patch
23Patch3: %{name}-desktop.patch
ff9c6890 24URL: http://www.shatters.net/celestia/
89ee6494 25BuildRequires: OpenGL-devel
1a2dda0a
JB
26BuildRequires: autoconf
27BuildRequires: automake
efaf8d4e 28%{?with_glut:BuildRequires: glut-devel >= 3.7}
29%if %{with gtk} || %{with gnome}
30BuildRequires: cairo-devel
31BuildRequires: gtk+2-devel >= 2.6
32BuildRequires: gtkglext-devel
33%endif
34%{?with_kde:BuildRequires: kdelibs-devel}
35%{?with_gnome:BuildRequires: libgnomeui-devel}
a684a621 36BuildRequires: libjpeg-devel
37BuildRequires: libpng-devel
38BuildRequires: libstdc++-devel
0490466f 39BuildRequires: libtool
d267ffc3 40BuildRequires: lua50-devel
4322beb0 41BuildRequires: pkgconfig
efaf8d4e 42BuildRequires: sed >= 4.0
45cdd808 43Requires: OpenGL
efaf8d4e 44# celestia < 1.4 original packages
45Obsoletes: celestia-extrasolar
46Obsoletes: celestia-generator
47Obsoletes: celestia-stars
48Obsoletes: celestia-task-default
49# texture replacement addons, virtual provides
50Obsoletes: celestia-textures-earth
51Obsoletes: celestia-textures-earth-clouds
52Obsoletes: celestia-textures-earth-night
53Obsoletes: celestia-textures-galileanmoons
54Obsoletes: celestia-textures-mars
55Obsoletes: celestia-textures-mars-bumpmap
56Obsoletes: celestia-textures-mercury
57Obsoletes: celestia-textures-mercury-bumpmap
58Obsoletes: celestia-textures-moon
59Obsoletes: celestia-textures-moon-bumpmap
60# celestia addons
61Obsoletes: celestia-blackhole
62Obsoletes: celestia-galaxies_extended
63Obsoletes: celestia-galaxy_clusters
64Obsoletes: celestia-globular_clusters
65Obsoletes: celestia-im-starwars
66Obsoletes: celestia-pathfinder
67Obsoletes: celestia-voyager
ff9c6890 68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
a684a621 70%define _noautoreqdep libGL.so.1 libGLU.so.1 libGLcore.so.1
1a2dda0a 71
ff9c6890 72%description
73Celestia is a free real-time space simulation that lets you experience
74our universe in three dimensions. Unlike most planetarium software,
75Celestia doesn't confine you to the surface of the Earth. You can
76travel throughout the solar system, to any of over 100,000 stars, or
77even beyond the galaxy. All travel in Celestia is seamless; the
78exponential zoom feature lets you explore space across a huge range of
79scales, from galaxy clusters down to spacecraft only a few meters
80across. A 'point-and-goto' interface makes it simple to navigate
81through the universe to the object you want to visit.
82
4107a3bb 83%description -l pl.UTF-8
ff9c6890 84Celestia to wolny symulator przestrzeni komicznej w czasie
4107a3bb
JR
85rzeczywistym, który pozwala doświadczać naszego Wszechświata w trzech
86wymiarach. W odróżnieniu od innych programów planetarnych Celestia nie
87przywiązuje Cię do powierzchni ziemi. Możesz podróżować przez Układ
88Słoneczny do ponad 100,000 gwiazd lub nawet poza galaktykę. Wszystkie
89podróże w Celestii są niezauważalne; funkcja wykładniczego
90przybliżenia pozwala Ci odkrywać Kosmos w różnych skalach - od
91spojrzenia na galaktyki do widoku kilkumetrowych statków kosmicznych.
92Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
ff9c6890 93
94%prep
f0c406a2 95%setup -q
84e273a4 96%patch0
d267ffc3 97%patch1 -p1
f0c406a2 98%patch2 -p1
99%patch3 -p1
724d8895 100
efaf8d4e 101# ugly hack not to require GConf2-devel if we're not building gnome version
102%{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
36f18dc6 103
efaf8d4e 104%build
105cp -f /usr/share/automake/config.sub admin
106%{__make} -f admin/Makefile.common
36f18dc6 107
0490466f 108%configure \
efaf8d4e 109 %{?with_kde:--with-kde} \
110 %{?with_gtk:--with-gtk} \
111 %{?with_gnome:--with-gnome} \
112 %{?with_glut:--with-glut} \
0490466f 113 --disable-rpath \
d267ffc3 114 --with-lua \
8cb97c25 115 --with-xinerama \
116 --with-qt-dir=%{_libdir}
36f18dc6 117
efaf8d4e 118%{__make}
ff9c6890 119
120%install
121rm -rf $RPM_BUILD_ROOT
2560aac7 122
123%{__make} install \
36f18dc6 124 DESTDIR=$RPM_BUILD_ROOT \
efaf8d4e 125 kde_htmldir=%{_kdedocdir} \
52c7f06c 126 kde_libs_htmldir=%{_kdedocdir} \
efaf8d4e 127 appsdir=%{_desktopdir}/kde
2560aac7 128
129# desktop/icon
f0c406a2 130install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
efaf8d4e 131%{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
132install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
36f18dc6 133
52c7f06c 134%find_lang %{name} --all-name --with-kde
89ee6494 135
ff9c6890 136%clean
137rm -rf $RPM_BUILD_ROOT
138
efaf8d4e 139%if %{with gnome}
140%post
141%gconf_schema_install celestia.schemas
142
143%preun
144%gconf_schema_uninstall celestia.schemas
145%endif
146
f0c406a2 147%files -f %{name}.lang
ff9c6890 148%defattr(644,root,root,755)
efaf8d4e 149%doc README AUTHORS TODO controls.txt ChangeLog
ff9c6890 150%attr(755,root,root) %{_bindir}/*
f0c406a2 151%{_datadir}/celestia
2560aac7 152%{_pixmapsdir}/*
efaf8d4e 153%if %{with kde}
f0c406a2 154%{_datadir}/apps/celestia
89ee6494 155%{_datadir}/config/*
2560aac7 156%{_datadir}/mimelnk/application/*
157%{_datadir}/services/*
efaf8d4e 158%{_iconsdir}/*/*/apps/%{name}.png
e812d11b 159%{_desktopdir}/kde/*.desktop
efaf8d4e 160%else
e812d11b 161%{_desktopdir}/*.desktop
efaf8d4e 162%endif
163%{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.122631 seconds and 4 git commands to generate.