]> git.pld-linux.org Git - packages/cdk.git/blobdiff - cdk.spec
- rel 3
[packages/cdk.git] / cdk.spec
index f851cd469a8721ae29a1f1308185afe2e796ff25..6675f516eb3533badc3ffea476a24936ff3abc34 100644 (file)
--- a/cdk.spec
+++ b/cdk.spec
@@ -1,16 +1,21 @@
-%define         ver_ver     4.9.10
-%define         ver_release 20010106
+%define                ver_ver         5.0
+%define                ver_release     20050424
 
 Summary:       Curses Development Kit
 Summary(pl):   Zestaw programistyczny do Curses
 Name:          cdk
 Version:       %{ver_ver}_td%{ver_release}
-Release:       2
+Release:       3
 License:       BSD
 Group:         Libraries
-URL:           http://dickey.his.com/cdk/cdk.html
 Source0:       ftp://dickey.his.com/cdk/%{name}-%{ver_ver}-%{ver_release}.tgz
-Patch0:                %{name}-includes.patch
+# Source0-md5: 0e2cbebf5c8a7b5ad29008a3c245def3
+Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
+# Source1-md5: ae2a6fea526cc1c4407e547bda537a08
+Patch0:                %{name}-man_remove_dupl.patch
+Patch1:                %{name}-ncurses.patch
+URL:           http://dickey.his.com/cdk/cdk.html
+BuildRequires: ncurses-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -20,7 +25,7 @@ scrolling list, a selection list, a alphalist, pull-down menu, radio
 list, viewer widget, dialog box, and many more.
 
 This version of CDK is maintained by Thomas Dickey and is not the same
-as that at http://www.vexus.ca/CDK.html.
+as that at <http://www.vexus.ca/CDK.html>.
 
 %description -l pl
 CDK to zestaw widgetów zbudowanych na podstawie biblioteki curses.
@@ -30,48 +35,51 @@ alfabetyczna, menu rozwijane, lista przycisk
 dialogowe i wiele innych.
 
 Ta wersja CDK jest prowadzona przez Thomasa Dickeya i nie jest tym
-samym, co znajduje siê pod adresem http://www.vexus.ca/CDK.html.
+samym, co znajduje siê pod adresem <http://www.vexus.ca/CDK.html>.
 
 %package devel
 Summary:       Header files and development documentation for CDK library
 Summary(pl):   Pliki nag³ówkowe i dokumentacja do CDK
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      ncurses-devel
 
 %description devel
 Header files and development documentation for CDK library. This
 version is maintained by Thomas Dickey and is not the same as that at
-http://www.vexus.ca/CDK.html.
+<http://www.vexus.ca/CDK.html>.
 
 %description devel -l pl
 Pliki nag³ówkowe i dokumentacja programisty do biblioteki CDK. Ta
 wersja jest prowadzona przez Thomasa Dickeya i nie jest tym samym, co
-znajduje siê pod adresem http://www.vexus.ca/CDK.html.
+znajduje siê pod adresem <http://www.vexus.ca/CDK.html>.
 
 %package static
 Summary:       Static version of CDK library
 Summary(pl):   Statyczna wersja biblioteki CDK
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of CDK library. This version is maintained by Thomas
-Dickey and is not the same as that at http://www.vexus.ca/CDK.html.
+Dickey and is not the same as that at <http://www.vexus.ca/CDK.html>.
 
 %description static -l pl
 Statyczna wersja biblioteki CDK. Ta wersja jest prowadzona przez
 Thomasa Dickeya i nie jest tym samym, co znajduje siê pod adresem
-http://www.vexus.ca/CDK.html.
+<http://www.vexus.ca/CDK.html>.
 
 %prep
 %setup -q -n %{name}-%{ver_ver}-%{ver_release}
 %patch0 -p1
-mkdir include/cdk
-mv -f include/*.* include/cdk
+%patch1 -p1
+
+ln -sf . include/cdk
 
 %build
 # -funsigned-char gives valid 8bit display
 CFLAGS="%{rpmcflags} -funsigned-char"
+CPPFLAGS="-I/usr/include/ncurses"
 %configure2_13 \
        --disable-x \
        --with-ncurses
@@ -80,21 +88,23 @@ CFLAGS="%{rpmcflags} -funsigned-char"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} installCDKSHLibrary installCDKLibrary \
-       DESTDIR="$RPM_BUILD_ROOT"
+       DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} installCDKHeaderFiles installCDKManPages \
-       DESTDIR="$RPM_BUILD_ROOT"
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf BUGS CHANGES EXPANDING NOTES README TODO
+bzcat %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
 for d in demos examples; do
-   rm -f $d/Makefile.in
-   mkf=$d/Makefile
-   sed 's|\-I%{_prefix}/X11R6/include|\-I%{_includedir}/cdk/|' <$mkf >$mkf.fix
-   mv -f $mkf.fix $mkf
+       rm -f $d/Makefile.in
+       mkf=$d/Makefile
+       sed 's|\-I\.\..*/include |\-I%{_includedir}/cdk |' <$mkf >$mkf.fix
+       mv -f $mkf.fix $mkf
 done
+cp -rf demos examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -108,10 +118,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc *gz examples demos
+%doc CHANGES COPYING EXPANDING NOTES README TODO
 %attr(755,root,root) %{_libdir}/lib*.so
-%{_includedir}/*
+%{_includedir}/cdk
 %{_mandir}/man3/*
+%{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
This page took 0.077693 seconds and 4 git commands to generate.