]> git.pld-linux.org Git - packages/cdflib.git/commitdiff
- added no-common patch (fixes build with -fno-common, gcc 10 default) master auto/th/cdflib-3.7.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 12 Nov 2020 19:06:17 +0000 (20:06 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 12 Nov 2020 19:06:17 +0000 (20:06 +0100)
cdflib-no-common.patch [new file with mode: 0644]
cdflib-opt.patch
cdflib-soname.patch [new file with mode: 0644]
cdflib.spec

diff --git a/cdflib-no-common.patch b/cdflib-no-common.patch
new file mode 100644 (file)
index 0000000..e638f05
--- /dev/null
@@ -0,0 +1,40 @@
+--- cdf37_1-dist/src/include/cdfedit.h.orig    2019-01-24 20:17:20.000000000 +0100
++++ cdf37_1-dist/src/include/cdfedit.h 2020-11-12 19:56:15.464712277 +0100
+@@ -260,6 +260,7 @@
+ Logical browseOnly;             /* TRUE if the CDF is being browsed. */
+ Logical compressed;             /* TRUE if the currently open CDF is
+                                  compressed. */
++Logical ziso8601;
+ #else
+ extern Logical report[3];
+ extern Logical dumpStatistics;
+@@ -269,8 +270,8 @@
+ extern char olhFile[];
+ extern Logical browseOnly;
+ extern Logical compressed;
++extern Logical ziso8601;
+ #endif
+-Logical ziso8601;
+ /******************************************************************************
+ * Function prototypes.
+--- cdf37_1-dist/src/include/cdfstats.h.orig   2019-01-24 18:58:21.000000000 +0100
++++ cdf37_1-dist/src/include/cdfstats.h        2020-11-12 20:00:34.328044604 +0100
+@@ -102,6 +102,7 @@
+ long fillvalAttrN;
+ long formatAttrN;
+ long majority;
++Logical ziso8601;
+ #else
+ extern Logical updateValids;
+ extern Logical updateScales;
+@@ -116,8 +117,8 @@
+ extern long fillvalAttrN;
+ extern long formatAttrN;
+ extern long majority;
++extern Logical ziso8601;
+ #endif
+-Logical ziso8601;
+ /******************************************************************************
+ * VarStruct.
+ ******************************************************************************/
index 6969d89cf2f8df54fba4f457d7ca14ec19d8536a..7f7947b74cbb63eb545eeead0cde088a60770bca 100644 (file)
@@ -1,15 +1,15 @@
---- cdf35_0-dist/Makefile.orig 2013-09-09 18:31:16.000000000 +0200
-+++ cdf35_0-dist/Makefile      2014-03-08 17:36:13.311830189 +0100
-@@ -781,7 +781,7 @@
-       @cd $(TOOLSsrcDIR); $(MAKE) \
+--- cdf36_4-dist/Makefile.orig 2017-03-20 21:09:02.000000000 +0100
++++ cdf36_4-dist/Makefile      2018-05-16 19:17:48.324239219 +0200
+@@ -824,7 +824,7 @@
  "CURSES=$(AND.$(CURSES).$(CURSES_$(OS)_$(ENV)))" \
  "CCx=$(CC_$(OS)_$(ENV))" \
+ "MAKE=$(MAKE)" \
 -"COPTIONS=$(COPTIONS_$(OS)_$(ENV))" \
 +"COPTIONS=$(UCOPTIONS) $(COPTIONS_$(OS)_$(ENV))" \
  "COPTIONSld=$(COPTIONSld_$(OS)_$(ENV))" \
  "SYSLIBS=$(SYSLIBSexe_$(OS)_$(ENV))" \
  "CURSESLIB=$(CURSESLIB_$(OS)_$(ENV))" \
-@@ -793,7 +793,7 @@
+@@ -837,7 +837,7 @@
  "SHARED=$(AND.$(SHARED).$(SHARED_$(OS)))" \
  "FOPTIONS=$(FOPTIONS_$(OS)) $(FOPTIONS_$(OS)_$(ENV))" \
  "FOPTIONSld=$(FOPTIONSld_$(OS)) $(FOPTIONSld_$(OS)_$(ENV))" \
diff --git a/cdflib-soname.patch b/cdflib-soname.patch
new file mode 100644 (file)
index 0000000..fb2d552
--- /dev/null
@@ -0,0 +1,27 @@
+--- cdf36_4-dist/src/lib/Makefile.orig 2017-01-04 21:58:09.000000000 +0100
++++ cdf36_4-dist/src/lib/Makefile      2018-05-16 19:29:54.154230934 +0200
+@@ -125,8 +125,8 @@
+ libcdf.dll \
+ libcdf.sl: $(OBJs)
+       @if [ -f $@ ] ; then rm $@ ; else $(NULL) ; fi
+-      @echo $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS)
+-            $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS)
++      @echo $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS) -Wl,-soname,libcdf.so.3
++            $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS) -Wl,-soname,libcdf.so.3
+       @if [ $(MACVERSION) -gt 0 ]; then \
+         rm -f $(MACLIB)/$@; \
+         cp $@ $(MACLIB)/libcdf.$(VERSION).dylib; \
+--- cdf36_4-dist/Makefile.orig 2018-05-16 19:31:40.914229713 +0200
++++ cdf36_4-dist/Makefile      2018-05-16 19:31:55.137562887 +0200
+@@ -994,9 +994,9 @@
+ copy.lib.so:
+       @echo cp $(LIBsrcDIR)/libcdf.so $(INSTALLDIR)/lib
+-            cp $(LIBsrcDIR)/libcdf.so $(INSTALLDIR)/lib/libcdf.$(VERSION).so
++            cp $(LIBsrcDIR)/libcdf.so $(INSTALLDIR)/lib/libcdf.so.$(VERSION)
+             rm -f $(INSTALLDIR)/lib/libcdf.so
+-            cd $(INSTALLDIR)/lib && ln -s libcdf.$(VERSION).so libcdf.so
++            cd $(INSTALLDIR)/lib && ln -s libcdf.so.$(VERSION) libcdf.so.3 && ln -s libcdf.so.$(VERSION) libcdf.so
+ copy.lib.sl:
+       @echo cp $(LIBsrcDIR)/libcdf.sl $(INSTALLDIR)/lib
index 22a111a11c1f3b3541a92deecf31e2d9899c9215..1d7083f3abe9c0414e47c9f540c07b4b173ab76a 100644 (file)
@@ -1,15 +1,17 @@
 Summary:       CDF (Common Data Format) software
 Summary(pl.UTF-8):     Oprogramowanie obsługujące CDF (Common Data Format)
 Name:          cdflib
-Version:       3.5.0.1
-Release:       2
+Version:       3.7.1
+Release:       1
 License:       freely usable, non-commercially distributable
 Group:         Libraries
-# see http://cdf.gsfc.nasa.gov/html/sw_and_docs.html
-Source0:       http://cdaweb.gsfc.nasa.gov/pub/software/cdf/dist/cdf35_0/linux/cdf35_0-dist-all.tar.gz
-# Source0-md5: 61dcabe51427e03f83b8a6dcf9d4dfd4
+# see https://cdf.gsfc.nasa.gov/html/sw_and_docs.html
+Source0:       https://cdaweb.gsfc.nasa.gov/pub/software/cdf/dist/cdf37_1/linux/cdf37_1-dist-all.tar.gz
+# Source0-md5: 0f434ffbb7f6ffe39b2bb20c5a940aee
 Patch0:                %{name}-opt.patch
-URL:           http://cdf.gsfc.nasa.gov/cdf_home.html
+Patch1:                %{name}-soname.patch
+Patch2:                %{name}-no-common.patch
+URL:           https://cdf.gsfc.nasa.gov/cdf_home.html
 BuildRequires: gcc-fortran >= 6:4.4.2
 BuildRequires: ncurses-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -58,8 +60,10 @@ Java API for CDF library.
 API Javy do biblioteki CDF.
 
 %prep
-%setup -q -n cdf35_0-dist
+%setup -q -n cdf37_1-dist
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 # note: included zlib (src/lib/zlib) is modified (at last public symbol names)
 
@@ -97,18 +101,23 @@ cp -p cdfjava/classes/cdfjava.jar $RPM_BUILD_ROOT%{_javadir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc CDF_copyright.txt CHANGES.txt README_cdf_tools.txt Release.notes Welcome.txt
 %attr(755,root,root) %{_bindir}/cdf*
 %attr(755,root,root) %{_bindir}/skeletoncdf
 %attr(755,root,root) %{_bindir}/skeletontable
-%attr(755,root,root) %{_libdir}/libcdf.so
+%attr(755,root,root) %{_libdir}/libcdf.so.%{version}
+%attr(755,root,root) %ghost %{_libdir}/libcdf.so.3
 %{_libdir}/cdf
 %{_datadir}/cdf
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libcdf.so
 %dir %{_includedir}/cdf
 # C
 %{_includedir}/cdf/cdf.h
This page took 0.081373 seconds and 4 git commands to generate.