]> git.pld-linux.org Git - packages/ccrtp.git/blob - ccrtp.spec
- rel 5; use gcrypt until openssl 1.1 is supported
[packages/ccrtp.git] / ccrtp.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
4
5 Summary:        Common C++ class framework for RTP packets
6 Summary(pl.UTF-8):      Szkielet klas C++ dla pakietów RTP
7 Name:           ccrtp
8 Version:        2.1.2
9 Release:        3
10 License:        GPL v2+ with runtime exception
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
13 # Source0-md5:  e6792cbd8b705901c205a509bd7f812f
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-openssl.patch
16 Patch2:         %{name}-am.patch
17 URL:            http://www.gnu.org/software/ccrtp/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  doxygen >= 1.8.0
21 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.2.3}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 %{!?with_gcrypt:BuildRequires:  openssl-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  ucommon-devel >= 6.2.2
27 Requires:       ucommon >= 6.2.2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ccRTP is a generic, extensible and efficient C++ framework for
32 developing applications based on the Real-Time Transport Protocol
33 (RTP) from the IETF. It is based on Common C++ and provides a full
34 RTP/RTCP stack for sending and receiving of realtime data by the use
35 of send and receive packet queues. ccRTP supports unicast,
36 multi-unicast and multicast, manages multiple sources, handles RTCP
37 automatically, supports different threading models and is generic as
38 for underlying network and transport protocols.
39
40 %description -l pl.UTF-8
41 ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
42 rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
43 (RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
44 wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
45 wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
46 multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
47 automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
48 podstawowych sieci i protokołów transportowych.
49
50 %package devel
51 Summary:        Header files for ccrtp library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ccrtp
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.2.3}
56 Requires:       libstdc++-devel
57 %{!?with_gcrypt:Requires:       openssl-devel}
58 Requires:       ucommon-devel >= 6.2.2
59
60 %description devel
61 Header files for ccrtp library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki ccrtp.
65
66 %package static
67 Summary:        Static ccrtp library
68 Summary(pl.UTF-8):      Statyczna biblioteka ccrtp
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static ccrtp library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ccrtp.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 # LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
91 %configure \
92         %{!?with_gcrypt:LIBGCRYPT_CONFIG=/nonexisting}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %post   devel -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %postun devel -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
116 %attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libccrtp.so.3
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc doc/html/*.{css,html,js,png}
122 %attr(755,root,root) %{_libdir}/libccrtp.so
123 %{_libdir}/libccrtp.la
124 %{_includedir}/ccrtp
125 %{_pkgconfigdir}/libccrtp.pc
126 %{_infodir}/ccrtp.info*
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libccrtp.a
This page took 0.075393 seconds and 3 git commands to generate.