]> git.pld-linux.org Git - packages/ccrtp.git/blame - ccrtp.spec
- rel 5; use gcrypt until openssl 1.1 is supported
[packages/ccrtp.git] / ccrtp.spec
CommitLineData
69d0628f
JB
1#
2# Conditional build:
e78ec447 3%bcond_without gcrypt # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
8a7ce00c 4
69d0628f
JB
5Summary: Common C++ class framework for RTP packets
6Summary(pl.UTF-8): Szkielet klas C++ dla pakietów RTP
23152de5 7Name: ccrtp
7be3ecc1 8Version: 2.1.2
e78ec447 9Release: 5
69d0628f 10License: GPL v2+ with runtime exception
23152de5 11Group: Libraries
8a4ce148 12Source0: http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
7be3ecc1 13# Source0-md5: e6792cbd8b705901c205a509bd7f812f
69d0628f
JB
14Patch0: %{name}-info.patch
15Patch1: %{name}-openssl.patch
30b0987c 16Patch2: %{name}-am.patch
e101e907 17URL: http://www.gnu.org/software/ccrtp/
69d0628f 18BuildRequires: autoconf >= 2.50
695e1afd 19BuildRequires: automake
b749edf7 20BuildRequires: doxygen >= 1.8.0
69d0628f
JB
21%{?with_gcrypt:BuildRequires: libgcrypt-devel >= 1.2.3}
22BuildRequires: libstdc++-devel
23BuildRequires: libtool >= 2:1.5
24%{!?with_gcrypt:BuildRequires: openssl-devel}
25BuildRequires: pkgconfig
1a54ca0d 26BuildRequires: ucommon-devel >= 6.2.2
7be3ecc1 27Requires: ucommon >= 6.2.2
23152de5 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31ccRTP is a generic, extensible and efficient C++ framework for
32developing applications based on the Real-Time Transport Protocol
33(RTP) from the IETF. It is based on Common C++ and provides a full
34RTP/RTCP stack for sending and receiving of realtime data by the use
35of send and receive packet queues. ccRTP supports unicast,
36multi-unicast and multicast, manages multiple sources, handles RTCP
37automatically, supports different threading models and is generic as
38for underlying network and transport protocols.
39
0c6db567
JR
40%description -l pl.UTF-8
41ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
42rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
43(RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
44wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
45wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
46multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
47automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
48podstawowych sieci i protokołów transportowych.
382d8e6d 49
23152de5 50%package devel
51Summary: Header files for ccrtp library
152d52c0 52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ccrtp
23152de5 53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
69d0628f
JB
55%{?with_gcrypt:Requires: libgcrypt-devel >= 1.2.3}
56Requires: libstdc++-devel
57%{!?with_gcrypt:Requires: openssl-devel}
1a54ca0d 58Requires: ucommon-devel >= 6.2.2
23152de5 59
60%description devel
61Header files for ccrtp library.
62
0c6db567
JR
63%description devel -l pl.UTF-8
64Pliki nagłówkowe biblioteki ccrtp.
23152de5 65
66%package static
67Summary: Static ccrtp library
152d52c0 68Summary(pl.UTF-8): Statyczna biblioteka ccrtp
23152de5 69Group: Development/Libraries
70Requires: %{name}-devel = %{version}-%{release}
71
72%description static
73Static ccrtp library.
74
0c6db567 75%description static -l pl.UTF-8
23152de5 76Statyczna biblioteka ccrtp.
77
78%prep
79%setup -q
6716a349 80%patch0 -p1
5eac4eea 81%patch1 -p1
30b0987c 82%patch2 -p1
23152de5 83
84%build
695e1afd 85%{__libtoolize}
86%{__aclocal} -I m4
87%{__autoconf}
88%{__autoheader}
89%{__automake}
69d0628f
JB
90# LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
91%configure \
1db38f71 92 %{!?with_gcrypt:LIBGCRYPT_CONFIG=/nonexisting}
23152de5 93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} install \
99 DESTDIR=$RPM_BUILD_ROOT
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post -p /sbin/ldconfig
105%postun -p /sbin/ldconfig
106
8a7ce00c
ER
107%post devel -p /sbin/postshell
108-/usr/sbin/fix-info-dir -c %{_infodir}
109
110%postun devel -p /sbin/postshell
111-/usr/sbin/fix-info-dir -c %{_infodir}
112
23152de5 113%files
114%defattr(644,root,root,755)
69d0628f
JB
115%doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
116%attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
1a54ca0d 117%attr(755,root,root) %ghost %{_libdir}/libccrtp.so.3
23152de5 118
119%files devel
120%defattr(644,root,root,755)
69d0628f
JB
121%doc doc/html/*.{css,html,js,png}
122%attr(755,root,root) %{_libdir}/libccrtp.so
123%{_libdir}/libccrtp.la
23152de5 124%{_includedir}/ccrtp
69d0628f
JB
125%{_pkgconfigdir}/libccrtp.pc
126%{_infodir}/ccrtp.info*
23152de5 127
128%files static
129%defattr(644,root,root,755)
69d0628f 130%{_libdir}/libccrtp.a
This page took 0.053722 seconds and 4 git commands to generate.