]> git.pld-linux.org Git - packages/ccache.git/blob - ccache.spec
- updated to 3.1.10
[packages/ccache.git] / ccache.spec
1 Summary:        Compiler cache
2 Summary(pl.UTF-8):      Przyspieszacz kompilowania
3 Summary(pt_BR.UTF-8):   Cache para compiladores C/C++
4 Name:           ccache
5 Version:        3.1.10
6 Release:        1
7 License:        GPL v3
8 Group:          Development/Tools
9 Source0:        http://www.samba.org/ftp/ccache/%{name}-%{version}.tar.xz
10 # Source0-md5:  20cd43818f84e3208fb4859e9679060e
11 Patch0:         %{name}-nohash_size_mtime.patch
12 URL:            http://ccache.samba.org/
13 BuildRequires:  automake
14 BuildRequires:  tar >= 1:1.22
15 BuildRequires:  xz
16 BuildRequires:  zlib-devel >= 1.2.3
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _libdir         %{_prefix}/%{_lib}/%{name}
20
21 %description
22 ccache is a compiler cache. It acts as a caching pre-processor to
23 C/C++ compilers, using the -E compiler switch and a hash to detect
24 when a compilation can be satisfied from cache. This often results in
25 a 5 to 10 times speedup in common compilations.
26
27 %description -l pl.UTF-8
28 ccache działa jako cachujący preprocesor dla kompilatorów C/C++. Przy
29 użyciu opcji kompilatora -E oraz tablicy haszującej do wykrywania, czy
30 do kompilacji wystarczy zawartość cache. Daje to zazwyczaj
31 przyspieszenie kompilacji 5 do 10 razy.
32
33 %description -l pt_BR.UTF-8
34 ccache é um cache para compiladores. Ele funciona mantendo um cache de
35 pré-processamento para compiladores C/C++ utilizando-se do parâmetro
36 - -E e de um hash para detectar quando uma compilação pode ser
37   reaproveitada de um cache armazenado em disco. O ganho de tempo em
38   compilações comuns pode chegar a uma escala de até 10 vezes em relação
39   ao tempo normal.
40
41 %package wrapper
42 Summary:        Symlinks for c++/cc/g++/gcc
43 Summary(pl.UTF-8):      Dowiązania symboliczne do c++/cc/g++/gcc
44 Group:          Development/Tools
45 Requires:       %{name} = %{version}-%{release}
46
47 %description wrapper
48 This package contains the softlinks to ccache for each compiler.
49
50 %description wrapper -l pl.UTF-8
51 Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
52 kompilatora.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 # Make sure system zlib is used
59 %{__rm} -r zlib
60
61 %build
62 cp -f /usr/share/automake/config.* .
63 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
64 %configure
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT/etc/env.d
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
76         CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
77         CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
78         CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
79 do
80         echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
81 done
82
83 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
84 for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
85         ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
86 done
87 echo 'export PATH=%{_libdir}:$PATH' > \
88         $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
96 %attr(755,root,root) %{_bindir}/ccache
97 %{_mandir}/man1/ccache.1.*
98 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CCACHE_*
99
100 %files wrapper
101 %defattr(644,root,root,755)
102 %attr(755,root,root) /etc/profile.d/%{name}.sh
103 %dir %{_libdir}
104 %attr(755,root,root) %{_libdir}/c++
105 %attr(755,root,root) %{_libdir}/cc
106 %attr(755,root,root) %{_libdir}/g++
107 %attr(755,root,root) %{_libdir}/gcc
108 %attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-g++
109 %attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-gcc
This page took 0.043747 seconds and 4 git commands to generate.