]> git.pld-linux.org Git - packages/ccache.git/blob - ccache.spec
up to ccache 3.1.9
[packages/ccache.git] / ccache.spec
1 Summary:        Compiler cache
2 Summary(pl.UTF-8):      Przyspieszacz kompilowania
3 Summary(pt_BR.UTF-8):   Cache para compiladores C/C++
4 Name:           ccache
5 Version:        3.1.9
6 Release:        1
7 License:        GPL v3
8 Group:          Development/Tools
9 Source0:        http://samba.org/ftp/ccache/%{name}-%{version}.tar.bz2
10 # Source0-md5:  65f48376a91d3651d6527ca568858be8
11 Patch0:         %{name}-nohash_size_mtime.patch
12 URL:            http://ccache.samba.org/
13 BuildRequires:  automake
14 BuildRequires:  zlib-devel >= 1.2.3
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _libdir         %{_prefix}/%{_lib}/%{name}
18
19 %description
20 ccache is a compiler cache. It acts as a caching pre-processor to
21 C/C++ compilers, using the -E compiler switch and a hash to detect
22 when a compilation can be satisfied from cache. This often results in
23 a 5 to 10 times speedup in common compilations.
24
25 %description -l pl.UTF-8
26 ccache działa jako cachujący preprocesor dla kompilatorów C/C++. Przy
27 użyciu opcji kompilatora -E oraz tablicy haszującej do wykrywania, czy
28 do kompilacji wystarczy zawartość cache. Daje to zazwyczaj
29 przyspieszenie kompilacji 5 do 10 razy.
30
31 %description -l pt_BR.UTF-8
32 ccache é um cache para compiladores. Ele funciona mantendo um cache de
33 pré-processamento para compiladores C/C++ utilizando-se do parâmetro
34 - -E e de um hash para detectar quando uma compilação pode ser
35   reaproveitada de um cache armazenado em disco. O ganho de tempo em
36   compilações comuns pode chegar a uma escala de até 10 vezes em relação
37   ao tempo normal.
38
39 %package wrapper
40 Summary:        Symlinks for c++/cc/g++/gcc
41 Summary(pl.UTF-8):      Dowiązania symboliczne do c++/cc/g++/gcc
42 Group:          Development/Tools
43 Requires:       %{name} = %{version}-%{release}
44
45 %description wrapper
46 This package contains the softlinks to ccache for each compiler.
47
48 %description wrapper -l pl.UTF-8
49 Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
50 kompilatora.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 # Make sure system zlib is used
57 %{__rm} -r zlib
58
59 %build
60 cp -f /usr/share/automake/config.* .
61 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
62 %configure
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT/etc/env.d
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
75         CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
76         CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
77         CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
78 do
79         echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
80 done
81
82 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
83 for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
84         ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
85 done
86 echo 'export PATH=%{_libdir}:$PATH' > \
87         $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
95 %attr(755,root,root) %{_bindir}/ccache
96 %{_mandir}/man1/ccache.1.*
97 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CCACHE_*
98
99 %files wrapper
100 %defattr(644,root,root,755)
101 %attr(755,root,root) /etc/profile.d/%{name}.sh
102 %dir %{_libdir}
103 %attr(755,root,root) %{_libdir}/*
This page took 0.07571 seconds and 4 git commands to generate.