]> git.pld-linux.org Git - packages/ccache.git/blame - ccache.spec
- updated to 3.1.10
[packages/ccache.git] / ccache.spec
CommitLineData
4321e8e2 1Summary: Compiler cache
b23bd5c7
ER
2Summary(pl.UTF-8): Przyspieszacz kompilowania
3Summary(pt_BR.UTF-8): Cache para compiladores C/C++
8b92ebec 4Name: ccache
a92c8e6f 5Version: 3.1.10
75e6ea34 6Release: 1
5b5229a4 7License: GPL v3
8b92ebec 8Group: Development/Tools
a92c8e6f
JB
9Source0: http://www.samba.org/ftp/ccache/%{name}-%{version}.tar.xz
10# Source0-md5: 20cd43818f84e3208fb4859e9679060e
7cb1815a 11Patch0: %{name}-nohash_size_mtime.patch
4321e8e2 12URL: http://ccache.samba.org/
b69824c3 13BuildRequires: automake
a92c8e6f
JB
14BuildRequires: tar >= 1:1.22
15BuildRequires: xz
ba18ad01 16BuildRequires: zlib-devel >= 1.2.3
ba51398f 17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fb6cdf11 18
d8626a6e
ER
19%define _libdir %{_prefix}/%{_lib}/%{name}
20
8b92ebec 21%description
22ccache is a compiler cache. It acts as a caching pre-processor to
23C/C++ compilers, using the -E compiler switch and a hash to detect
24when a compilation can be satisfied from cache. This often results in
25a 5 to 10 times speedup in common compilations.
26
40d90c5c
JR
27%description -l pl.UTF-8
28ccache działa jako cachujący preprocesor dla kompilatorów C/C++. Przy
29użyciu opcji kompilatora -E oraz tablicy haszującej do wykrywania, czy
30do kompilacji wystarczy zawartość cache. Daje to zazwyczaj
4321e8e2 31przyspieszenie kompilacji 5 do 10 razy.
8b92ebec 32
40d90c5c
JR
33%description -l pt_BR.UTF-8
34ccache é um cache para compiladores. Ele funciona mantendo um cache de
35pré-processamento para compiladores C/C++ utilizando-se do parâmetro
36- -E e de um hash para detectar quando uma compilação pode ser
ba51398f 37 reaproveitada de um cache armazenado em disco. O ganho de tempo em
40d90c5c 38 compilações comuns pode chegar a uma escala de até 10 vezes em relação
ba51398f 39 ao tempo normal.
40
d8626a6e
ER
41%package wrapper
42Summary: Symlinks for c++/cc/g++/gcc
b23bd5c7 43Summary(pl.UTF-8): Dowiązania symboliczne do c++/cc/g++/gcc
d8626a6e 44Group: Development/Tools
04b1fe9f 45Requires: %{name} = %{version}-%{release}
d8626a6e
ER
46
47%description wrapper
bfcd2997
JB
48This package contains the softlinks to ccache for each compiler.
49
40d90c5c
JR
50%description wrapper -l pl.UTF-8
51Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
bfcd2997 52kompilatora.
d8626a6e 53
8b92ebec 54%prep
6a72a66c 55%setup -q
f286d628 56%patch0 -p1
8b92ebec 57
ba18ad01
ER
58# Make sure system zlib is used
59%{__rm} -r zlib
60
8b92ebec 61%build
b69824c3 62cp -f /usr/share/automake/config.* .
6b963ef4 63CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
8b92ebec 64%configure
65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
7cb1815a 70install -d $RPM_BUILD_ROOT/etc/env.d
71
81dca979 72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT
8b92ebec 74
7cb1815a 75for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
76 CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
77 CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
78 CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
79do
80 echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
81done
82
d8626a6e
ER
83install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
84for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
85 ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
86done
87echo 'export PATH=%{_libdir}:$PATH' > \
88 $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
89
8b92ebec 90%clean
e6282d7e 91rm -rf $RPM_BUILD_ROOT
8b92ebec 92
93%files
94%defattr(644,root,root,755)
f286d628 95%doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
8b92ebec 96%attr(755,root,root) %{_bindir}/ccache
9ad23f95
ŁK
97%{_mandir}/man1/ccache.1.*
98%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CCACHE_*
d8626a6e
ER
99
100%files wrapper
101%defattr(644,root,root,755)
102%attr(755,root,root) /etc/profile.d/%{name}.sh
103%dir %{_libdir}
a92c8e6f
JB
104%attr(755,root,root) %{_libdir}/c++
105%attr(755,root,root) %{_libdir}/cc
106%attr(755,root,root) %{_libdir}/g++
107%attr(755,root,root) %{_libdir}/gcc
108%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-g++
109%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-gcc
This page took 0.105315 seconds and 4 git commands to generate.