]> git.pld-linux.org Git - packages/carob.git/blob - carob.spec
- release 4
[packages/carob.git] / carob.spec
1 %define _ver    %(echo %{version} |tr . _)
2 Summary:        Carob library
3 Summary(pl.UTF-8):      Biblioteka carob
4 Name:           carob
5 Version:        0.7.3
6 Release:        4
7 License:        Apache License v2.0
8 Group:          Libraries
9 Source0:        https://forge.continuent.org/frs/download.php/255/%{name}-r%{_ver}.tar.gz
10 # Source0-md5:  f1023a5185bcc08d49d80564126a8592
11 URL:            http://carob.continuent.org/HomePage
12 BuildRequires:  gmp-devel
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Bringing Sequoia technology to the C/C++ world.
18
19 Carob's base is a C++ port of the JDBC driver code. It offers to
20 developpers the same access as in Java. Connections, Requests,
21 ResultSets and all necessary C++ classes can be used transparently and
22 directly in any C++ enabled application.
23
24 %description -l pl.UTF-8
25 Przeniesienie technologii Sequoia do świata C/C++.
26
27 Podstawą caroba jest port C++ kodu sterownika JDBC. Oferuje
28 programistom ten sam sposób dostępu co w Javie. Połączenia, żądania,
29 zbiory wyników (Connection, Request, ResultSet) i wszystkie potrzebne
30 klasy C++ mogą być używane w sposób przezroczysty i bezpośredni w
31 dowolnej aplikacji C++.
32
33 %package devel
34 Summary:        Header files for carob library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki carob
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 This is the package containing the header files for carob library.
41
42 %description devel -l pl.UTF-8
43 Ten pakiet zawiera pliki nagłówkowe biblioteki carob.
44
45 %package static
46 Summary:        Static carob library
47 Summary(pl.UTF-8):      Statyczna biblioteka carob
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static carob library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka carob.
56
57 %prep
58 %setup -q -n %{name}-r%{_ver}
59
60 %build
61 %{__make} \
62         CXX="%{__cxx}" \
63         CXXFLAGS="%{rpmcflags} -fPIC" \
64         LDFLAGS="%{rpmldflags} -lpthread"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT{%{_includedir}/carob,%{_libdir}}
70 install libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}
71 install libcarob.a $RPM_BUILD_ROOT%{_libdir}
72 install include/*.hpp $RPM_BUILD_ROOT%{_includedir}/carob
73 ln -s libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}/libcarob.so
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README
84 %attr(755,root,root) %{_libdir}/libcarob.so.1
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libcarob.so
89 %{_includedir}/carob
90
91 %files static
92 %defattr(644,root,root,755)
93 %{_libdir}/libcarob.a
This page took 0.037538 seconds and 3 git commands to generate.