]> git.pld-linux.org Git - packages/carob.git/blob - carob.spec
af92bbdbc68d5cbcdd8d68c329a92100d57a9af4
[packages/carob.git] / carob.spec
1 Summary:        Carob library
2 Summary(pl):    Biblioteka carob
3 Name:           carob
4 Version:        0.6.2
5 %define _ver    %(echo %{version} |tr . _)
6 Release:        0.1
7 License:        Apache License v2.0
8 Group:          Development/Libraries
9 Source0:        https://forge.continuent.org/frs/download.php/182/%{name}-r%{_ver}.tar.gz
10 # Source0-md5:  6969f74fa9f4c19c434b68d29590eb3a
11 URL:            http://carob.continuent.org/HomePage
12 BuildRequires:  gmp-devel
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Bringing Sequoia technology to the C/C++ world.
18
19 Carob's base is a C++ port of the JDBC driver code. It offers to
20 developpers the same access as in Java. Connections, Requests,
21 ResultSets and all necessary C++ classes can be used transparently and
22 directly in any C++ enabled application.
23
24 %package libs
25 Summary:        -
26 Summary(pl):    -
27 Group:          Libraries
28
29 %description libs
30
31 %description libs -l pl
32
33 %package devel
34 Summary:        Header files for carob library
35 Summary(pl):    Pliki nag³ówkowe biblioteki carob
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 This is the package containing the header files for carob library.
41
42 %description devel -l pl
43 Ten pakiet zawiera pliki nag³ówkowe biblioteki carob.
44
45 %package static
46 Summary:        Static carob library
47 Summary(pl):    Statyczna biblioteka carob
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static carob library.
53
54 %description static -l pl
55 Statyczna biblioteka carob.
56
57 %prep
58 %setup -q -n %{name}-r%{_ver}
59
60 %build
61 %{__make} \
62         CXX="%{__cxx}" \
63         CXXFLAGS="%{rpmcflags} -fPIC" \
64         LDFLAGS="%{rpmldflags}"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}/carob
70 install libcarob.so* $RPM_BUILD_ROOT%{_libdir}/carob
71 install libcarob.a $RPM_BUILD_ROOT%{_libdir}
72 install include/*.hpp $RPM_BUILD_ROOT%{_includedir}/carob
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README
83 %dir %{_libdir}/carob
84 %attr(755,root,root) %{_libdir}/carob/libcarob.so.1
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/carob
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/carob/libcarob.so
93 %{_libdir}/libcarob.a
This page took 0.061861 seconds and 2 git commands to generate.