]> git.pld-linux.org Git - packages/captive-drivers.git/commitdiff
- use lincesne-installer.sh from DistFiles
authorpawelz <pawelz@pld-linux.org>
Sat, 26 Dec 2009 11:46:35 +0000 (11:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- R: rpm-build-tools >= 4.4.35
- dropped R: wget (used by rpm-build-tools)
- dropped R: cpio (used by rpm)
- parse @DATADIR@ macro in new license-installer.sh

Changed files:
    captive-drivers.spec -> 1.10
    license-installer.sh -> 1.12

captive-drivers.spec
license-installer.sh [deleted file]

index b9d32571ca4400e773aa968a7d9aa4965ba73811..5f69b0531d8289021b72e40798c3653586decae7 100644 (file)
@@ -24,10 +24,9 @@ Source0:     %{source_url}xpsp1a_en_x86_CHK.exe
 BuildRequires: cabextract
 Requires:      captive
 %else
-Source0:       license-installer.sh
-Requires:      cpio
-Requires:      rpm-build-tools
-Requires:      wget
+Source0:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source0-md5: 4fb1600353dd57fe088e0b12fb0ecac2
+Requires:      rpm-build-tools >= 4.4.35
 Provides:      %{base_name}
 %endif
 ExclusiveArch: %{ix86}
@@ -73,6 +72,7 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@DATADIR@,%{_datadir}/%{base_name},g
 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
diff --git a/license-installer.sh b/license-installer.sh
deleted file mode 100644 (file)
index 07b3cb1..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       tmp=$(mktemp -d)
-       SPECDIR=`rpm --define "_topdir $tmp" --eval "%{_specdir}"`
-       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       SOURCEDIR=`rpm --define "_topdir $tmp" --eval "%{_sourcedir}"`
-       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
-       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               (
-               if echo "$3" | grep '://' >/dev/null; then
-                       cd $SRPMDIR
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" $SRPMDIR
-               fi
-               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
-               fi
-               )
-       else
-               cp -i "$3" $SPECDIR || exit 1
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
-                       done
-               fi
-       fi
-       ( cd $SPECDIR
-       nd=
-       if [ '@USE_DISTFILES@' = 'no' ]; then
-               nd=-nd
-       fi
-       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-else
-       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
-               cat @LICENSE@
-               echo "
-If you accept the above license rebuild the package using:
-"
-       else
-               echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-"
-       fi
-       echo "$0 --with license_agreement @SPECFILE@"
-fi
This page took 0.058329 seconds and 4 git commands to generate.