]> git.pld-linux.org Git - packages/capseo.git/blob - capseo.spec
- use http://ftp.debian.org/ url
[packages/capseo.git] / capseo.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # MMX acceleration (won't work without)
4 #
5 %ifarch %{x8664} pentium2 pentium3 pentium4 athlon
6 %define with_mmx        1
7 %endif
8 Summary:        Video codec library
9 Summary(pl.UTF-8):      Biblioteka kodeka obrazu
10 Name:           capseo
11 Version:        0.3.0
12 Release:        4
13 License:        GPL v2
14 Group:          Libraries
15 Source0:        ftp://ftp.debian.org/debian/pool/main/c/capseo/%{name}_%{version}~svn158.orig.tar.gz
16 # Source0-md5:  46660f02f7d5b8fcf7c9b5cc89eca6fe
17 URL:            http://rm-rf.in/capseo
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  libogg-devel >= 1:1.1
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtheora-devel
22 BuildRequires:  pkgconfig >= 1:0.17.2
23 %if %{with mmx}
24 BuildRequires:  yasm
25 %endif
26 Requires:       libogg >= 1:1.1
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 capseo is a realtime video encoder/decoder library. The capseo codec
31 is meant to encode fast, not to generate the smallest files on your
32 file system.
33
34 %description -l pl.UTF-8
35 capseo to biblioteka kodera/dekodera obrazu czasu rzeczywistego. Kodek
36 ma za zadanie szybko kodować, niekoniecznie generując najmniejsze
37 pliki.
38
39 %package devel
40 Summary:        Header files for capseo library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki capseo
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libogg-devel >= 1:1.1
45 Requires:       libstdc++-devel
46
47 %description devel
48 Header files for capseo library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki capseo.
52
53 %package static
54 Summary:        Static capseo library
55 Summary(pl.UTF-8):      Biblioteka statyczna capseo
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static capseo library.
61
62 %description static -l pl.UTF-8
63 Biblioteka statyczna capseo.
64
65 %prep
66 %setup -q -n %{name}-%{version}~svn158.orig
67
68 %build
69 %configure \
70         --enable-theora \
71 %if %{with mmx}
72 %ifarch %{ix86}
73         --with-accel=x86 \
74 %endif
75 %ifarch %{x8664}
76         --with-accel=amd64
77 %endif
78 %endif
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog README TODO
97 %attr(755,root,root) %{_bindir}/cpsinfo
98 %attr(755,root,root) %{_bindir}/cpsplay
99 %attr(755,root,root) %{_bindir}/cpsrecode
100 %attr(755,root,root) %{_libdir}/libcapseo.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libcapseo.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libcapseo.so
106 %{_libdir}/libcapseo.la
107 %{_includedir}/capseo.h
108 %{_pkgconfigdir}/capseo.pc
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libcapseo.a
This page took 0.069243 seconds and 3 git commands to generate.