]> git.pld-linux.org Git - packages/candl.git/commitdiff
- new auto/th/candl-0.6.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Oct 2014 12:15:28 +0000 (14:15 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Oct 2014 12:15:28 +0000 (14:15 +0200)
candl-info.patch [new file with mode: 0644]
candl-isl.patch [new file with mode: 0644]
candl.spec [new file with mode: 0644]

diff --git a/candl-info.patch b/candl-info.patch
new file mode 100644 (file)
index 0000000..ea989ef
--- /dev/null
@@ -0,0 +1,13 @@
+--- candl-0.6.2/doc/candl.texi.orig    2012-03-12 17:19:38.000000000 +0100
++++ candl-0.6.2/doc/candl.texi 2014-10-05 14:06:50.272710340 +0200
+@@ -11,6 +11,10 @@
+ @set UPDATED July 16th 2008
+ @setchapternewpage odd
++@dircategory Development Tools:
++@direntry
++* candl: (candl).                     CAnDL: the Chunky Analyzer for Dependencies in Loops
++@end direntry
+ @c % /*************************************************************************
+ @c %  *                 PART II: SUMMARY DESCRIPTION AND COPYRIGHT            *
diff --git a/candl-isl.patch b/candl-isl.patch
new file mode 100644 (file)
index 0000000..c6a8465
--- /dev/null
@@ -0,0 +1,28 @@
+--- candl-0.6.2/source/dependence.c.orig       2012-03-12 17:19:37.000000000 +0100
++++ candl-0.6.2/source/dependence.c    2014-10-05 13:31:01.296133841 +0200
+@@ -48,7 +48,7 @@
+ #ifdef CANDL_SUPPORTS_ISL
+ # undef Q // Thank you polylib...
+-# include <isl/int.h>
++# include <isl/deprecated/int.h>
+ # include <isl/constraint.h>
+ # include <isl/ctx.h>
+ # include <isl/set.h>
+--- candl-0.6.2/source/isl-wrapper.c.orig      2012-03-12 17:19:37.000000000 +0100
++++ candl-0.6.2/source/isl-wrapper.c   2014-10-05 13:33:15.439461490 +0200
+@@ -46,12 +46,13 @@
+ # ifdef CANDL_SUPPORTS_ISL
+ # undef Q
++# include <isl/deprecated/int.h>
+ # include <isl/constraint.h>
++# include <isl/deprecated/constraint_int.h>
+ # include <isl/map.h>
+ # include <isl/map.h>
+ # include <isl/set.h>
+ # include <isl/dim.h>
+-# include <isl/seq.h>
+ # include <isl/ctx.h>
diff --git a/candl.spec b/candl.spec
new file mode 100644 (file)
index 0000000..98e1862
--- /dev/null
@@ -0,0 +1,108 @@
+#
+# Conditional build:
+%bcond_without static_libs     # don't build static libraries
+#
+Summary:       Candl - Data Dependence Analysis Tool in the Polyhedral Model
+Summary(pl.UTF-8):     Candl - narzędzie do analizy zależności danych w modelu wielościennym
+Name:          candl
+Version:       0.6.2
+Release:       1
+License:       LGPL v3+
+Group:         Libraries
+Source0:       http://web.cse.ohio-state.edu/~pouchet/software/pocc/download/modules/%{name}-%{version}.tar.gz
+# Source0-md5: 4e86392fa46a514b03532f93d9c83f8d
+Patch0:                %{name}-isl.patch
+Patch1:                %{name}-info.patch
+URL:           http://icps.u-strasbg.fr/people/bastoul/public_html/development/candl/
+BuildRequires: gmp-devel
+# 0.12.x originally, 0.13 with isl patch
+BuildRequires: isl-devel >= 0.13
+BuildRequires: piplib-devel
+BuildRequires: scoplib-devel >= 0.2.1-2
+BuildRequires: texinfo
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Candl (Chunky ANalyzer for Dependences in Loops) is a free software
+and a library devoted to data dependences computation.
+
+%description -l pl.UTF-8
+Candl (Chunky ANalyzer for Dependences in Loops - blokowy analizator
+zależności w pętlach) to wolnodostępne oprogramowanie i biblioteka
+służące do obliczeń zależności danych.
+
+%package devel
+Summary:       Header files for Candl library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Candl
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      gmp-devel
+Requires:      isl-devel >= 0.13
+Requires:      piplib-devel
+Requires:      scoplib-devel >= 0.2.1-2
+
+%description devel
+Header files for Candl library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Candl.
+
+%package static
+Summary:       Static Candl library
+Summary(pl.UTF-8):     Statyczna biblioteka Candl
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static Candl library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka Candl.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%configure \
+       --enable-mp-version \
+       --disable-silent-rules
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%post  devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog README
+%attr(755,root,root) %{_bindir}/candl
+%attr(755,root,root) %{_libdir}/libcandl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcandl.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libcandl.so
+%{_libdir}/libcandl.la
+%{_includedir}/candl
+%{_infodir}/candl.info*
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libcandl.a
This page took 0.111781 seconds and 4 git commands to generate.