]> git.pld-linux.org Git - packages/camwire.git/commitdiff
- updated to 2.0.0 (guessed, as download directory is not browstable atm.)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 Aug 2019 13:56:50 +0000 (15:56 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 Aug 2019 13:56:50 +0000 (15:56 +0200)
- added bogus-inline patch (don't use "inline" keyword when definition is not in the scope)

camwire-bogus-inline.patch [new file with mode: 0644]
camwire.spec

diff --git a/camwire-bogus-inline.patch b/camwire-bogus-inline.patch
new file mode 100644 (file)
index 0000000..4b692af
--- /dev/null
@@ -0,0 +1,46 @@
+--- camwire2-2.0.0-Source/camwire/camwire_handle.h.orig        2015-05-21 23:48:01.000000000 +0200
++++ camwire2-2.0.0-Source/camwire/camwire_handle.h     2019-08-08 15:40:40.958729338 +0200
+@@ -74,11 +74,11 @@
+ /* This is the Camwire handle type. */
+-inline Camera_handle camwire_handle_get_camera(const Camwire_handle c_handle);
++Camera_handle camwire_handle_get_camera(const Camwire_handle c_handle);
+ /* Returns the dc1394camera_t camera handle for the given camwire
+    handle.  Needed by many dc1394 functions in Camwire. */
+-inline User_handle camwire_bus_get_userdata(const Camwire_handle c_handle);
++User_handle camwire_bus_get_userdata(const Camwire_handle c_handle);
+ /* Returns a pointer to the user data structure for the given camwire
+    handle.  Needed for internal status maintenance in Camwire. */
+--- camwire2-2.0.0-Source/camwire/camwirebus.c.orig    2015-05-21 23:39:48.000000000 +0200
++++ camwire2-2.0.0-Source/camwire/camwirebus.c 2019-08-08 15:41:09.205242980 +0200
+@@ -203,7 +203,7 @@
+    Returns the dc1394camera_t camera handle for the given camwire
+    handle.  Needed by many dc1394 functions in Camwire.
+ */
+-inline Camera_handle camwire_handle_get_camera(const Camwire_handle c_handle)
++Camera_handle camwire_handle_get_camera(const Camwire_handle c_handle)
+ {
+     return c_handle->camera;
+ }
+@@ -213,7 +213,7 @@
+    Returns a pointer to the user data structure for the given camwire
+    handle.  Needed for internal status maintenance in Camwire.
+ */
+-inline User_handle camwire_bus_get_userdata(
++User_handle camwire_bus_get_userdata(
+     const Camwire_handle c_handle)
+ {
+     return c_handle->userdata;
+--- camwire2-2.0.0-Source/examples/measureconf_1394.c.orig     2012-01-10 23:20:53.000000000 +0100
++++ camwire2-2.0.0-Source/examples/measureconf_1394.c  2019-08-08 15:47:50.856400383 +0200
+@@ -202,7 +202,6 @@
+                                                                     const int mode);
+ /* inline static int fixed_image_size(const dc1394video_mode_t video_mode); */
+ inline static int variable_image_size(const dc1394video_mode_t video_mode);
+-inline dc1394camera_t * get_camera(const Camwire_handle c_handle);
+ /*
index 8f9f9631adf8342613bba90dd4dccfdcca69785b..19e8a6b8958a662242d56ba643c64fd3d2fb60da 100644 (file)
@@ -1,16 +1,17 @@
 Summary:       Digital camera library for Linux
 Summary(pl.UTF-8):     Biblioteka obsÅ‚ugi kamer cyfrowych dla Linuksa
 Name:          camwire
-Version:       1.9.5
+Version:       2.0.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-# camwire1 was for libdc1394 < 2.0, camwire2 for libdc1394 2.0+
+# camwire1 was for libdc1394 < 2.0, camwire2 for libdc1394 2.1+
 Source0:       http://kauri.auck.irl.cri.nz/~johanns/camwire/download/camwire2/camwire2-%{version}-Source.tar.gz
-# Source0-md5: 8d81af3d953205cef065dc3af330090b
+# Source0-md5: 737de36d44388709a77ed00e14895b3a
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-etc.patch
 Patch2:                %{name}-lib.patch
+Patch3:                %{name}-bogus-inline.patch
 URL:           http://kauri.auck.irl.cri.nz/~johanns/camwire/
 BuildRequires: SDL-devel
 BuildRequires: cmake >= 2.6
@@ -75,6 +76,7 @@ Camwire.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 # disable unused-result warning, compilation failure with -Werror
This page took 0.139486 seconds and 4 git commands to generate.