]> git.pld-linux.org Git - packages/camlp5.git/blobdiff - camlp5.spec
- fix building with ocaml 4.02.2
[packages/camlp5.git] / camlp5.spec
index 494109846123dd11220abcc86200596ca1f9e2e2..ca36c0ed409e73ad980e8cde29ec2233c50d1b5b 100644 (file)
@@ -1,18 +1,19 @@
 Summary:       Objective Caml Preprocessor
 Summary(pl.UTF-8):     Preprocesor OCamla
 Name:          camlp5
-Version:       5.11
-Release:       0.1
+Version:       6.12
+Release:       1
 License:       distributable
 Group:         Development/Languages
 Source0:       http://pauillac.inria.fr/~ddr/camlp5/distrib/src/%{name}-%{version}.tgz
-# Source0-md5: 26d69abd669c5fda43dbf35074debc81
-Source1:       http://pauillac.inria.fr/~ddr/camlp5/doc/pdf/%{name}-%{version}.pdf
-# Source1-md5: 57cf4eb162568d9b755e8120a1b82d43
-Source2:       http://pauillac.inria.fr/~ddr/camlp5/doc/htmlz/%{name}-%{version}.html.tgz
-# Source2-md5: fcf3aa4d88a311aa27ff23e50c6f510f
+# Source0-md5: d49d30b62396b7285f3d609ac90c3fe5
+#Source1:      http://pauillac.inria.fr/~ddr/camlp5/doc/pdf/%{name}-%{version}.pdf
+Source1:       http://pauillac.inria.fr/~ddr/camlp5/doc/pdf/%{name}-6.00.pdf
+# Source1-md5: b241eabfeb48f22b0fbd3e497198a76a
 URL:           http://caml.inria.fr/
 BuildRequires: db-devel >= 4.1
+BuildRequires: ocaml
+%requires_eq   ocaml-runtime
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -58,87 +59,34 @@ Preprocesor OCamla - dokumentacja HTML.
 
 %prep
 %setup -q
-cp %{SOURCE1} docs/camlp4.pdf
-tar xzf %{SOURCE2}
+cp %{SOURCE1} doc/camlp4.pdf
+
+cp ocaml_src/lib/versdep/4.02.{1,2}.ml
+cp -a ocaml_stuff/4.02.{1,2}
 
 %build 
-cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
-        -cc "%{__cc}" \
        -bindir %{_bindir} \
-       -libdir %{_libdir}/%{name} \
+       -libdir %{_libdir}/ocaml \
        -mandir %{_mandir}/man1 \
-       -host %{_host} \
-       %{!?with_tk:-no-tk} \
-       -with-pthread \
-       -x11lib %{_libdir}
-
-%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
-%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
+       -transitional
 
-# broken build system
-sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
+%{__make} -j1 world.opt
+%{__make} -j1 -C doc/htmlp
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
-install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
-       LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
+       LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
        MANDIR=$RPM_BUILD_ROOT%{_mandir}
 
-cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
-%{_libdir}/%{name}/stublibs
-%{_libdir}/%{name}
-EOF
-
-%if %{with emacs}
-%{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
-       EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
-               else echo xemacs; fi`" \
-       EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp"
-%endif
-
-# symlink .opt versions of compilers (if present)
-# warning: don't do that with camlp4 (can't load extensions then)
-for f in ocamlc ocamlopt ocamldoc ocamllex; do
-       if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
-               mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
-                       $RPM_BUILD_ROOT%{_bindir}/$f.byte
-               ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
-       fi
-done
-
-# move includes to the proper place
-mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
-# but leave compatibility symlink
-ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
-
-# compiled sources of compiler, needed by some programs
-for f in {asm,byte}comp parsing typing utils ; do
-       install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
-       cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
-done
-
-# this isn't installed by default, but is useful
-install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
-
-# shutup checkfiles
-rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
-
-# install info pages
-cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
-
 # broken build system
-install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
-for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
-       echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
+for f in camlp5o.opt.1 camlp5r.opt.1 mkcamlp5.1 ocpp5.1 \
+                camlp5o.1 camlp5r.1 camlp5sch.1 mkcamlp5.opt.1 ; do
+       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$f
+       echo '.so camlp5.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
 done
 
 %clean
@@ -146,12 +94,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/camlp4*
-%attr(755,root,root) %{_bindir}/mkcamlp4
-%{_libdir}/%{name}/camlp4
-%{_mandir}/man1/camlp4*.1*
-%{_mandir}/man1/mkcamlp4.1*
+%doc CHANGES DEVEL ICHANGES MODE README UPGRADING doc/camlp4.pdf
+%attr(755,root,root) %{_bindir}/*
+%{_libdir}/ocaml/%{name}
+%{_mandir}/man1/*
 
 %files doc-html
 %defattr(644,root,root,755)
-%doc docs/html/camlp4*
+%doc doc/html/*
This page took 0.078773 seconds and 4 git commands to generate.