]> git.pld-linux.org Git - packages/camlp5.git/blob - camlp5.spec
- updated to 6.15
[packages/camlp5.git] / camlp5.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Objective Caml Preprocessor
11 Summary(pl.UTF-8):      Preprocesor OCamla
12 Name:           camlp5
13 Version:        6.15
14 Release:        1
15 License:        distributable
16 Group:          Development/Languages
17 Source0:        http://camlp5.gforge.inria.fr/distrib/src/%{name}-%{version}.tgz
18 # Source0-md5:  ad79f4b4384109fbb92b1b3bcb105224
19 Source1:        http://camlp5.gforge.inria.fr/doc/pdf/%{name}-6.00.pdf
20 # Source1-md5:  b241eabfeb48f22b0fbd3e497198a76a
21 URL:            http://caml.inria.fr/
22 BuildRequires:  db-devel >= 4.1
23 BuildRequires:  ocaml
24 %requires_eq    ocaml-runtime
25 Requires:       %{name} = %{epoch}:%{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Camlp5 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
30 tools for syntax (grammars) and the ability to modify the concrete
31 syntax of the language (quotations, syntax extensions).
32
33 Camlp5 can parse normal Ocaml concrete syntax or any other
34 user-definable syntax. As an example, an alternative syntax is
35 provided, named revised, because it tries to fix some small problems
36 of the normal syntax.
37
38 Camlp5 can pretty print the normal Ocaml concrete syntax or the
39 revised one. It is therefore always possible to have a version of your
40 sources compilable by the Objective Caml compiler without
41 preprocessing.
42
43 %description -l pl.UTF-8
44 Camlp5 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
45 składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
46 języka (cytowania, rozszerzenia).
47
48 Camlp5 może sparsować oryginalną składnię Ocamla lub dowolną inną
49 definiowalną przez użytkownika. Jako przykład podana jest alternatywna
50 składnia (revised syntax), która próbuje poprawić drobne problemy
51 występujące w składni oryginalnej.
52
53 Camlp5 umie ładnie formatować źródła zarówno w oryginalnej jak i
54 poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
55 składni na drugą.
56
57 %package doc-html
58 Summary:        Objective Caml Preprocessor - HTML documentation 
59 Summary(pl.UTF-8):      Preprocesor OCamla - dokumentacja HTML 
60 Group:          Development/Languages
61
62 %description doc-html
63 Objective Caml Preprocessor - HTML documentation.
64
65 %description doc-html -l pl.UTF-8
66 Preprocesor OCamla - dokumentacja HTML.
67
68 %prep
69 %setup -q
70
71 cp %{SOURCE1} doc/camlp4.pdf
72
73 %build 
74 ./configure \
75         -bindir %{_bindir} \
76         -libdir %{_libdir}/ocaml \
77         -mandir %{_mandir}/man1 \
78         -transitional
79
80 %{__make} -j1 world%{?with_ocaml_opt:.opt}
81 %{__make} -j1 -C doc/htmlp
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
88         LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
89         MANDIR=$RPM_BUILD_ROOT%{_mandir}
90
91 # broken build system
92 for f in mkcamlp5.1 ocpp5.1 camlp5o.1 camlp5r.1 camlp5sch.1 \
93         %{?with_ocaml_opt:camlp5o.opt.1 camlp5r.opt.1 mkcamlp5.opt.1} ; do
94         %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/$f
95         echo '.so camlp5.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
96 done
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc CHANGES DEVEL ICHANGES MODE README UPGRADING doc/camlp4.pdf
104 %attr(755,root,root) %{_bindir}/camlp5*
105 %attr(755,root,root) %{_bindir}/mkcamlp5*
106 %attr(755,root,root) %{_bindir}/ocpp5
107 %{_libdir}/ocaml/%{name}
108 %{_mandir}/man1/camlp5*.1*
109 %{_mandir}/man1/mkcamlp5*.1*
110 %{_mandir}/man1/ocpp5.1*
111
112 %files doc-html
113 %defattr(644,root,root,755)
114 %doc doc/html/*
This page took 0.085883 seconds and 4 git commands to generate.