]> git.pld-linux.org Git - packages/camlp5.git/blame_incremental - camlp5.spec
- fix building with ocaml 4.02.2
[packages/camlp5.git] / camlp5.spec
... / ...
CommitLineData
1Summary: Objective Caml Preprocessor
2Summary(pl.UTF-8): Preprocesor OCamla
3Name: camlp5
4Version: 6.12
5Release: 1
6License: distributable
7Group: Development/Languages
8Source0: http://pauillac.inria.fr/~ddr/camlp5/distrib/src/%{name}-%{version}.tgz
9# Source0-md5: d49d30b62396b7285f3d609ac90c3fe5
10#Source1: http://pauillac.inria.fr/~ddr/camlp5/doc/pdf/%{name}-%{version}.pdf
11Source1: http://pauillac.inria.fr/~ddr/camlp5/doc/pdf/%{name}-6.00.pdf
12# Source1-md5: b241eabfeb48f22b0fbd3e497198a76a
13URL: http://caml.inria.fr/
14BuildRequires: db-devel >= 4.1
15BuildRequires: ocaml
16%requires_eq ocaml-runtime
17Requires: %{name} = %{epoch}:%{version}-%{release}
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
22tools for syntax (grammars) and the ability to modify the concrete
23syntax of the language (quotations, syntax extensions).
24
25Camlp4 can parse normal Ocaml concrete syntax or any other
26user-definable syntax. As an example, an alternative syntax is
27provided, named revised, because it tries to fix some small problems
28of the normal syntax.
29
30Camlp4 can pretty print the normal Ocaml concrete syntax or the
31revised one. It is therefore always possible to have a version of your
32sources compilable by the Objective Caml compiler without
33preprocessing.
34
35%description -l pl.UTF-8
36Camlp4 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
37składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
38języka (cytowania, rozszerzenia).
39
40Camlp4 może sparsować oryginalną składnię Ocamla lub dowolną inną
41definiowalną przez użytkownika. Jako przykład podana jest alternatywna
42składnia (revised syntax), która próbuje poprawić drobne problemy
43występujące w składni oryginalnej.
44
45Camlp4 umie ładnie formatować źródła zarówno w oryginalnej jak i
46poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
47składni na drugą.
48
49%package doc-html
50Summary: Objective Caml Preprocessor - HTML documentation
51Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
52Group: Development/Languages
53
54%description doc-html
55Objective Caml Preprocessor - HTML documentation.
56
57%description doc-html -l pl.UTF-8
58Preprocesor OCamla - dokumentacja HTML.
59
60%prep
61%setup -q
62cp %{SOURCE1} doc/camlp4.pdf
63
64cp ocaml_src/lib/versdep/4.02.{1,2}.ml
65cp -a ocaml_stuff/4.02.{1,2}
66
67%build
68./configure \
69 -bindir %{_bindir} \
70 -libdir %{_libdir}/ocaml \
71 -mandir %{_mandir}/man1 \
72 -transitional
73
74%{__make} -j1 world.opt
75%{__make} -j1 -C doc/htmlp
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} install \
81 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
82 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
83 MANDIR=$RPM_BUILD_ROOT%{_mandir}
84
85# broken build system
86for f in camlp5o.opt.1 camlp5r.opt.1 mkcamlp5.1 ocpp5.1 \
87 camlp5o.1 camlp5r.1 camlp5sch.1 mkcamlp5.opt.1 ; do
88 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$f
89 echo '.so camlp5.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
90done
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(644,root,root,755)
97%doc CHANGES DEVEL ICHANGES MODE README UPGRADING doc/camlp4.pdf
98%attr(755,root,root) %{_bindir}/*
99%{_libdir}/ocaml/%{name}
100%{_mandir}/man1/*
101
102%files doc-html
103%defattr(644,root,root,755)
104%doc doc/html/*
This page took 0.039507 seconds and 4 git commands to generate.