]> git.pld-linux.org Git - packages/camlp5.git/blame - camlp5.spec
- up to 6.17
[packages/camlp5.git] / camlp5.spec
CommitLineData
bfe7d50f
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
170a6c18
JR
10Summary: Objective Caml Preprocessor
11Summary(pl.UTF-8): Preprocesor OCamla
12Name: camlp5
77729407
JR
13Version: 6.17
14%define gitver rel617
15Release: 1
170a6c18
JR
16License: distributable
17Group: Development/Languages
77729407
JR
18#Source0: http://camlp5.gforge.inria.fr/distrib/src/%{name}-%{version}.tgz
19Source0: https://github.com/camlp5/camlp5/archive/%{gitver}/%{name}-%{version}.tar.gz
20# Source0-md5: 572e0fa053715e40a40415ea3ca5d4ea
0576448b 21Source1: http://camlp5.gforge.inria.fr/doc/pdf/%{name}-6.00.pdf
f95747ae 22# Source1-md5: b241eabfeb48f22b0fbd3e497198a76a
170a6c18
JR
23URL: http://caml.inria.fr/
24BuildRequires: db-devel >= 4.1
f95747ae 25BuildRequires: ocaml
77729407 26BuildRequires: ocaml-ocamlbuild
62e5c235 27%requires_eq ocaml-runtime
170a6c18
JR
28Requires: %{name} = %{epoch}:%{version}-%{release}
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
1aebc93e 32Camlp5 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
170a6c18
JR
33tools for syntax (grammars) and the ability to modify the concrete
34syntax of the language (quotations, syntax extensions).
35
1aebc93e 36Camlp5 can parse normal Ocaml concrete syntax or any other
170a6c18
JR
37user-definable syntax. As an example, an alternative syntax is
38provided, named revised, because it tries to fix some small problems
39of the normal syntax.
40
1aebc93e 41Camlp5 can pretty print the normal Ocaml concrete syntax or the
170a6c18
JR
42revised one. It is therefore always possible to have a version of your
43sources compilable by the Objective Caml compiler without
44preprocessing.
45
46%description -l pl.UTF-8
1aebc93e 47Camlp5 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
170a6c18
JR
48składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
49języka (cytowania, rozszerzenia).
50
1aebc93e 51Camlp5 może sparsować oryginalną składnię Ocamla lub dowolną inną
170a6c18
JR
52definiowalną przez użytkownika. Jako przykład podana jest alternatywna
53składnia (revised syntax), która próbuje poprawić drobne problemy
54występujące w składni oryginalnej.
55
1aebc93e 56Camlp5 umie ładnie formatować źródła zarówno w oryginalnej jak i
170a6c18
JR
57poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
58składni na drugą.
59
60%package doc-html
61Summary: Objective Caml Preprocessor - HTML documentation
62Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
63Group: Development/Languages
64
65%description doc-html
66Objective Caml Preprocessor - HTML documentation.
67
68%description doc-html -l pl.UTF-8
69Preprocesor OCamla - dokumentacja HTML.
70
71%prep
77729407 72%setup -q -n %{name}-%{gitver}
1aebc93e 73
6b574e5a 74cp %{SOURCE1} doc/camlp4.pdf
170a6c18
JR
75
76%build
170a6c18 77./configure \
170a6c18 78 -bindir %{_bindir} \
6b574e5a 79 -libdir %{_libdir}/ocaml \
170a6c18 80 -mandir %{_mandir}/man1 \
6b574e5a 81 -transitional
170a6c18 82
bfe7d50f 83%{__make} -j1 world%{?with_ocaml_opt:.opt}
6b574e5a 84%{__make} -j1 -C doc/htmlp
170a6c18
JR
85
86%install
87rm -rf $RPM_BUILD_ROOT
170a6c18
JR
88
89%{__make} install \
90 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
6b574e5a 91 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
170a6c18
JR
92 MANDIR=$RPM_BUILD_ROOT%{_mandir}
93
170a6c18 94# broken build system
bfe7d50f
JB
95for f in mkcamlp5.1 ocpp5.1 camlp5o.1 camlp5r.1 camlp5sch.1 \
96 %{?with_ocaml_opt:camlp5o.opt.1 camlp5r.opt.1 mkcamlp5.opt.1} ; do
97 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/$f
6b574e5a 98 echo '.so camlp5.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
170a6c18
JR
99done
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(644,root,root,755)
fd602860 106%doc CHANGES DEVEL ICHANGES MODE README UPGRADING doc/camlp4.pdf
1aebc93e
JB
107%attr(755,root,root) %{_bindir}/camlp5*
108%attr(755,root,root) %{_bindir}/mkcamlp5*
109%attr(755,root,root) %{_bindir}/ocpp5
6b574e5a 110%{_libdir}/ocaml/%{name}
1aebc93e
JB
111%{_mandir}/man1/camlp5*.1*
112%{_mandir}/man1/mkcamlp5*.1*
113%{_mandir}/man1/ocpp5.1*
170a6c18
JR
114
115%files doc-html
116%defattr(644,root,root,755)
6b574e5a 117%doc doc/html/*
This page took 0.138488 seconds and 4 git commands to generate.