]> git.pld-linux.org Git - packages/caja-python.git/blob - caja-python.spec
Release 3 (by relup.sh)
[packages/caja-python.git] / caja-python.spec
1 # NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2 # but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3 Summary:        Python bindings for libcaja-extension library
4 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libcaja-extension
5 Name:           caja-python
6 Version:        1.20.0
7 Release:        1
8 License:        GPL v2+
9 Group:          Libraries/Python
10 Source0:        http://pub.mate-desktop.org/releases/1.20/python-caja-%{version}.tar.xz
11 # Source0-md5:  b09e092e6a7ca1b093467e94ceee78df
12 URL:            http://mate-desktop.org/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1:1.10
15 BuildRequires:  caja-devel >= 1.17.1
16 BuildRequires:  gtk-doc >= 1.9
17 BuildRequires:  intltool >= 0.35.0
18 BuildRequires:  libtool >= 1:1.4.3
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRequires:  python-devel >= 1:2.7
22 BuildRequires:  python-pygobject3-devel >= 3.0.0
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       caja >= 1.17.1
28 Requires:       python-libs
29 Obsoletes:      mate-file-manager-python
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Python bindings for libcaja-extension library, allowing to write Caja
34 extensions in Python.
35
36 %description -l pl.UTF-8
37 Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
38 tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
39
40 %package devel
41 Summary:        Development files for Python Caja extensions
42 Summary(pl.UTF-8):      Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
43 Group:          Development/Libraries
44 # doesn't require base; the only file is pkg-config specific, so let's require it
45 Requires:       pkgconfig
46 Obsoletes:      mate-file-manager-python-devel
47
48 %description devel
49 Development files for Caja extensions written in Python.
50
51 %description devel -l pl.UTF-8
52 Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
53 Pythonie.
54
55 %package apidocs
56 Summary:        Python Caja API documentation
57 Summary(pl.UTF-8):      Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
58 Group:          Documentation
59 Obsoletes:      mate-file-manager-python-apidocs
60 %if "%{_rpmversion}" >= "5"
61 BuildArch:      noarch
62 %endif
63
64 %description apidocs
65 Python Caja API documentation.
66
67 %description apidocs -l pl.UTF-8
68 Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
69
70 %package examples
71 Summary:        Example Python extensions for Caja file manager
72 Summary(pl.UTF-8):      Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
73 Group:          Documentation
74 Obsoletes:      mate-file-manager-python-examples
75
76 %description examples
77 Example Python extensions for Caja file manager.
78
79 %description examples -l pl.UTF-8
80 Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
81
82 %prep
83 %setup -q -n python-caja-%{version}
84
85 %build
86 %{__libtoolize}
87 %{__aclocal} -I m4
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         --enable-gtk-doc \
93         --with-html-dir=%{_gtkdocdir}
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         HTMLdir=%{_gtkdocdir}/caja-python
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
105
106 # not installed because of incomplete docs/Makefile
107 cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
108
109 # examples
110 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113
114 # directory for python plugins for caja - see src/caja-python.c or caja-python.pc
115 install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
116
117 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{es_ES,frp,ku_IQ,jv,pms}
118
119 %find_lang python-caja
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f python-caja.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README
127 %attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
128 %{_datadir}/caja/extensions/libcaja-python.caja-extension
129 %dir %{_datadir}/caja-python
130 %dir %{_datadir}/caja-python/extensions
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_pkgconfigdir}/caja-python.pc
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_gtkdocdir}/caja-python
139
140 %files examples
141 %defattr(644,root,root,755)
142 %{_examplesdir}/%{name}-%{version}
This page took 0.113876 seconds and 3 git commands to generate.