]> git.pld-linux.org Git - packages/caja-python.git/blame - caja-python.spec
Release 3 (by relup.sh)
[packages/caja-python.git] / caja-python.spec
CommitLineData
911c11cc
JB
1# NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2# but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3Summary: Python bindings for libcaja-extension library
4Summary(pl.UTF-8): Wiązania Pythona do biblioteki libcaja-extension
d658ea88 5Name: caja-python
02b9fe0a 6Version: 1.26.0
c178cdac 7Release: 3
911c11cc
JB
8License: GPL v2+
9Group: Libraries/Python
02b9fe0a
JP
10Source0: https://pub.mate-desktop.org/releases/1.26/python-caja-%{version}.tar.xz
11# Source0-md5: 08991236a39d9ad8e4c59e564786b9bd
a9149b81 12URL: https://wiki.mate-desktop.org/mate-desktop/components/python-caja/
911c11cc 13BuildRequires: autoconf >= 2.53
fb4a7cd3 14BuildRequires: automake >= 1:1.10
b06bdf71 15BuildRequires: caja-devel >= 1.17.1
f9c9cb0e 16BuildRequires: gettext-tools >= 0.19.8
911c11cc
JB
17BuildRequires: gtk-doc >= 1.9
18BuildRequires: libtool >= 1:1.4.3
19BuildRequires: libxslt-progs
911c11cc 20BuildRequires: pkgconfig
f9c9cb0e
JP
21BuildRequires: python3-devel >= 1:3.6
22BuildRequires: python3-pygobject3-devel >= 3.0.0
a9149b81 23BuildRequires: rpm-build >= 4.6
911c11cc
JB
24BuildRequires: rpm-pythonprov
25BuildRequires: rpmbuild(macros) >= 1.219
26BuildRequires: tar >= 1:1.22
27BuildRequires: xz
b06bdf71 28Requires: caja >= 1.17.1
f9c9cb0e 29Requires: python3-libs >= 1:3.6
a9149b81 30Obsoletes: mate-file-manager-python < 1.8.0
911c11cc
JB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Python bindings for libcaja-extension library, allowing to write Caja
35extensions in Python.
36
37%description -l pl.UTF-8
38Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
39tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
40
41%package devel
42Summary: Development files for Python Caja extensions
43Summary(pl.UTF-8): Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
44Group: Development/Libraries
45# doesn't require base; the only file is pkg-config specific, so let's require it
46Requires: pkgconfig
a9149b81 47Obsoletes: mate-file-manager-python-devel < 1.8.0
911c11cc
JB
48
49%description devel
50Development files for Caja extensions written in Python.
51
52%description devel -l pl.UTF-8
53Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
54Pythonie.
55
56%package apidocs
57Summary: Python Caja API documentation
58Summary(pl.UTF-8): Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
59Group: Documentation
a9149b81 60Obsoletes: mate-file-manager-python-apidocs < 1.8.0
d3b5c796 61BuildArch: noarch
911c11cc
JB
62
63%description apidocs
64Python Caja API documentation.
65
66%description apidocs -l pl.UTF-8
67Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
68
69%package examples
70Summary: Example Python extensions for Caja file manager
71Summary(pl.UTF-8): Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
72Group: Documentation
a9149b81 73Obsoletes: mate-file-manager-python-examples < 1.8.0
911c11cc
JB
74
75%description examples
76Example Python extensions for Caja file manager.
77
78%description examples -l pl.UTF-8
79Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
80
81%prep
82%setup -q -n python-caja-%{version}
83
84%build
85%{__libtoolize}
86%{__aclocal} -I m4
87%{__autoconf}
88%{__autoheader}
89%{__automake}
90%configure \
91 --enable-gtk-doc \
52974e09 92 --disable-silent-rules \
911c11cc
JB
93 --with-html-dir=%{_gtkdocdir}
94
fb4a7cd3 95%{__make}
911c11cc
JB
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100%{__make} install \
101 DESTDIR=$RPM_BUILD_ROOT \
fb4a7cd3 102 HTMLdir=%{_gtkdocdir}/caja-python
911c11cc
JB
103
104%{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
105
106# not installed because of incomplete docs/Makefile
107cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
108
109# examples
110install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
8b1b8983
JB
111%{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112%{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
911c11cc
JB
113
114# directory for python plugins for caja - see src/caja-python.c or caja-python.pc
115install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
116
c672e77d 117%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{es_ES,frp,ie,jv,ku_IQ,pms}
8cbf9ea2 118
db2c8960
JB
119%find_lang python-caja
120
911c11cc
JB
121%clean
122rm -rf $RPM_BUILD_ROOT
123
db2c8960 124%files -f python-caja.lang
911c11cc
JB
125%defattr(644,root,root,755)
126%doc AUTHORS ChangeLog NEWS README
127%attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
db2c8960 128%{_datadir}/caja/extensions/libcaja-python.caja-extension
911c11cc
JB
129%dir %{_datadir}/caja-python
130%dir %{_datadir}/caja-python/extensions
131
132%files devel
133%defattr(644,root,root,755)
134%{_pkgconfigdir}/caja-python.pc
135
136%files apidocs
137%defattr(644,root,root,755)
138%{_gtkdocdir}/caja-python
139
140%files examples
141%defattr(644,root,root,755)
142%{_examplesdir}/%{name}-%{version}
This page took 0.103536 seconds and 4 git commands to generate.