]> git.pld-linux.org Git - packages/cacti-plugin-weathermap.git/blob - cacti-plugin-weathermap.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cacti-plugin-weathermap.git] / cacti-plugin-weathermap.spec
1 # TODO
2 #  - config file, patches, package for not cacti plugin
3 #  - system vera ttf fonts, jquery
4 %define         plugin  weathermap
5 %define         php_min_version 5.2.0
6 %include        /usr/lib/rpm/macros.php
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Plugin for Cacti - WeatherMap
9 Summary(pl.UTF-8):      Wtyczka do Cacti - WeatherMap (mapa pogody)
10 Name:           cacti-plugin-weathermap
11 Version:        0.97a
12 Release:        0.1
13 License:        GPL v2
14 Group:          Applications/WWW
15 Source0:        http://www.network-weathermap.com/files/php-%{plugin}-%{version}.zip
16 # Source0-md5:  7eb70243fef163721423b3e87d7e84b4
17 URL:            http://www.network-weathermap.com/
18 BuildRequires:  rpm-perlprov
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
20 BuildRequires:  rpmbuild(macros) >= 1.554
21 BuildRequires:  sed >= 4.0
22 BuildRequires:  unzip
23 Requires:       cacti
24 Requires:       php(core) >= %{php_min_version}
25 Requires:       php(date)
26 Requires:       php(gd)
27 Requires:       php(mysql)
28 Requires:       php(pcre)
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         cactidir                /usr/share/cacti
33 %define         plugindir               %{cactidir}/plugins/%{plugin}
34
35 # provided by package itself
36 %define         _noautopear     pear(HTML_ImageMap.class.php) pear(Weathermap.class.php) pear(editor-config.php) pear(editor.inc.php)
37
38 # put it together for rpmbuild
39 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
40
41 %description
42 Weathermap plugin for Cacti is a network visualisation tool, to take
43 data you already have and show you an overview of your network in map
44 form.
45
46 Support is built in for RRD, MRTG (RRD and old log-format), and
47 tab-delimited text files. Other sources are via plugins or external
48 scripts.
49
50 %description -l pl.UTF-8
51 Wtyczka Weathermap dla Cacti to narzędzie do wizualizacji sieci,
52 pobierające już istniejące dane i tworzące widok sieci w postaci mapy.
53
54 Ma wbudowaną obsługę plików RRD, MRTG (RRD i starego formatu logów)
55 oraz tekstowych rozdzielonych tabulacjami. Inne źródła są dostępne
56 przez wtyczki lub zewnętrzne skrypty.
57
58 %prep
59 %setup -qc
60
61 %undos -f php,inc
62
63 # fix php path
64 %{__sed} -i -e '1s,#!.*bin/php,#!%{_bindir}/php,' %{plugin}/%{plugin}
65
66 mv %{plugin}/editor-config.php{-dist,}
67
68 # in docs
69 mv %{plugin}/{CHANGES,COPYING,README} .
70 mv %{plugin}/docs .
71
72 # junk not neccessary for plugin run
73 mv %{plugin}/random-bits .
74 mv %{plugin}/net-data.txt .
75 mv %{plugin}/convert-to-dsstats.php .
76 rm -rf %{plugin}/output
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{plugindir}/output
81 cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README CHANGES
89 %{plugindir}
This page took 0.11092 seconds and 3 git commands to generate.