]> git.pld-linux.org Git - packages/ca-certificates.git/blobdiff - ca-certificates.spec
remove _outdated_ _intermediate_ Let's Encrypt certs
[packages/ca-certificates.git] / ca-certificates.spec
index df3443ff381d36bce9c9dc5d2ad3f657f9e939e8..6ab1a461dbbc1a0f1d875db60d228a8785dfaa5e 100644 (file)
@@ -6,18 +6,19 @@
 # - make pidgin use system certs
 # - swap %{certsdir}/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt regards file vs symlink
 #
-%bcond_without tests
+# Conditional build:
+%bcond_without tests   # skip duplicates check
+
 Summary:       Common CA Certificates PEM files
 Summary(pl.UTF-8):     Pliki PEM popularnych certyfikatów CA
 Name:          ca-certificates
-Version:       20160104
+%define        ver_date        20170717
+Version:       %{ver_date}
 Release:       2
 License:       GPL v2 (scripts), MPL v2 (mozilla certs), distributable (other certs)
-Group:         Libraries
-Source0:       ftp://ftp.debian.org/debian/pool/main/c/ca-certificates/%{name}_%{version}.tar.xz
-# Source0-md5: d9665a83d0d3ef8176a38e6aa20458e9
-Source1:       https://www.verisign.com/support/thawte-roots.zip
-# Source1-md5: 21a284ebdc6e8f4178d5cc10fb9e1ef2
+Group:         Base
+Source0:       http://ftp.debian.org/debian/pool/main/c/ca-certificates/%{name}_%{version}.tar.xz
+# Source0-md5: 55a6bb6b98afb16b3cde8e3ad1e262eb
 Source2:       http://www.certum.pl/keys/CA.pem
 # Source2-md5: 35610177afc9c64e70f1ce62c1885496
 Source3:       http://www.certum.pl/keys/level1.pem
@@ -96,7 +97,7 @@ Patch5:               %{name}-DESTDIR.patch
 Patch6:                %{name}.d.patch
 URL:           https://packages.debian.org/sid/ca-certificates
 BuildRequires: openssl-tools
-BuildRequires: python
+BuildRequires: python >= 1:2.6
 BuildRequires: python-modules
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: sed >= 4.0
@@ -135,8 +136,7 @@ Script and data for updating CA Certificates database.
 Skrypt i dane do odświeżania bazy certyfikatów CA.
 
 %prep
-%setup -qc
-mv %{name}/* .
+%setup -q -n %{name}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -146,20 +146,6 @@ mv %{name}/* .
 
 %{__sed} -i -e 's,@openssldir@,%{openssldir},' sbin/update-ca-certificates*
 
-%{__unzip} -qq %{SOURCE1} -d thawte
-
-find thawte/ -name *.pem -o -name *.txt| while read f ; do
-       if (file "$f" | grep -q "PEM"); then
-               ff=$(echo $f | sed -e 's|[ ,]|_|g' -e 's|[()]|=|g')
-               nname=$(basename "$ff" .pem)
-               nname=$(basename "$nname" .txt)
-               nname=$(basename "$nname" _b64)
-               cp -pi "$f" "thawte/${nname}.crt"
-       else
-               echo "Skipping $f, doesn't look like PEM CERT"
-       fi
-done
-
 install -d certum
 cp -pi %{SOURCE2} certum
 cp -pi %{SOURCE3} certum
@@ -213,13 +199,10 @@ sed 's/\r//' %{SOURCE36} > terena/$(basename %{SOURCE36} .pem).crt
 %{__make}
 
 # We have those and more in specific dirs
-rm mozilla/{thawte,Certum,IGC_A,Deutsche_Telekom_Root_CA_2,Juur-SK}*.crt
-
-# Duplicate with Verisign_Class_3_Public_Primary_Certification_Authority_2.crt
-rm thawte/Class_3_Public_Primary_Certification_Authority.crt
+%{__rm} mozilla/{Certum,Deutsche_Telekom_Root_CA_2}*.crt
 
 # See TODO
-# rm mozilla/RSA_Security_1024_v3.crt
+# %{__rm} mozilla/RSA_Security_1024_v3.crt
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -246,7 +229,7 @@ install -d pld-tests
 cd pld-tests
 
 # check for duplicates (to avoid X509_STORE_add_cert "cert already in hash table" problem)
-cat $RPM_BUILD_ROOT/%{certsdir}/ca-certificates.crt | awk '/BEGIN/ { i++; } /BEGIN/, /END/ { print > i ".extracted.crt" }'
+cat $RPM_BUILD_ROOT%{certsdir}/ca-certificates.crt | awk '/BEGIN/ { i++; } /BEGIN/, /END/ { print > i ".extracted.crt" }'
 for cert in *.extracted.crt; do
        openssl x509 -in "$cert" -noout -sha1 -fingerprint > "$cert.fingerprint"
 done
This page took 0.033691 seconds and 4 git commands to generate.