]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
- updated to 1.28.1
[packages/c-ares.git] / c-ares.spec
1 Summary:        A library that performs asynchronous DNS operations
2 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
3 Name:           c-ares
4 Version:        1.12.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        https://c-ares.haxx.se/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  2ca44be1715cd2c5666a165d35788424
10 Patch0:         %{name}-resolv.conf-reading-is-not-fatal.patch
11 URL:            https://c-ares.haxx.se/
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  sed >= 4.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 c-ares is a C library that performs DNS requests and name resolves
20 asynchronously. c-ares is a fork of the library named 'ares', written
21 by Greg Hudson at MIT.
22
23 %description -l pl.UTF-8
24 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
25 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
26 Grega Hudsona w MIT.
27
28 %package devel
29 Summary:        Development files for c-ares library
30 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for c-ares library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki c-ares.
39
40 %package static
41 Summary:        Static c-ares library
42 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static c-ares library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka c-ares.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 # we want our own debug flags, if any
57 %{__sed} -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4
58 %{__sed} -i -e 's/flags_opt_yes=".*"/flags_opt_yes="%{rpmcflags}"/' m4/cares-compilers.m4
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I m4
63 %{__autoheader}
64 %{__autoconf}
65 %{__automake}
66 %configure \
67         --disable-silent-rules \
68         --enable-optimize="%{rpmcflags}" \
69         --enable-shared
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS CHANGES LICENSE.md NEWS README.cares README.md RELEASE-NOTES TODO
87 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libcares.so
93 %{_libdir}/libcares.la
94 %{_includedir}/ares.h
95 %{_includedir}/ares_build.h
96 %{_includedir}/ares_dns.h
97 %{_includedir}/ares_rules.h
98 %{_includedir}/ares_version.h
99 %{_mandir}/man3/ares_*.3*
100 %{_pkgconfigdir}/libcares.pc
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libcares.a
This page took 0.109457 seconds and 3 git commands to generate.