]> git.pld-linux.org Git - packages/c-algorithms.git/commitdiff
- updated to 1.2.0 (ISC licensed now), separated -apidocs master auto/th/c-algorithms-1.2.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 1 Apr 2024 15:29:15 +0000 (17:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 1 Apr 2024 15:29:15 +0000 (17:29 +0200)
c-algorithms.spec

index d1dd2ae91885fe051c0d4ce3d75faf2424a435f7..96023b716163e03aa922d44fa2f6610e77fabe61 100644 (file)
@@ -1,20 +1,24 @@
 #
 # Conditional build:
-%bcond_without static_libs     # static libraries
+%bcond_without static_libs     # static library
 #
 Summary:       Common Computer Science data structures and algorithms to use in C projects
 Summary(pl.UTF-8):     Popularne struktury danych i algorytmy informatyczne do używania w programach w C
 Name:          c-algorithms
-Version:       1.0.0
-Release:       0.1
-License:       BSD-like
+Version:       1.2.0
+Release:       1
+License:       ISC
 Group:         Libraries
+# future versions:
+#Source0Download: https://github.com/fragglet/c-algorithms/releases
+#Source0:      https://github.com/fragglet/c-algorithms/releases/download/c-algorithms-%{version}/%{name}-%{version}.tar.gz
 Source0:       https://downloads.sourceforge.net/c-algorithms/%{name}-%{version}.tar.gz
-# Source0-md5: 3435f8705ff83360b48bfba61decdb7a
+# Source0-md5: d104d55ee9c97a2766b0850b44b6e85f
 URL:           https://github.com/fragglet/c-algorithms
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
+BuildRequires: rpm-build >= 4.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -49,6 +53,18 @@ Static c-algorithms library.
 %description static -l pl.UTF-8
 Statyczna biblioteka c-algorithms.
 
+%package apidocs
+Summary:       API documentation for c-algorithms library
+Summary(pl.UTF-8):     Dokumentacja API biblioteki c-algorithms
+Group:         Documentation
+BuildArch:     noarch
+
+%description apidocs
+API documentation for c-algorithms library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki c-algorithms.
+
 %prep
 %setup -q
 
@@ -68,6 +84,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcalg.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -76,19 +95,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%doc AUTHORS COPYING ChangeLog NEWS README
+%attr(755,root,root) %{_libdir}/libcalg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcalg.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/html/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libcalg.so
 %{_includedir}/libcalg-1.0
-%{_pkgconfigdir}/*.pc
+%{_pkgconfigdir}/libcalg-1.0.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcalg.a
 %endif
+
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*.{css,html,png}
This page took 0.0778 seconds and 4 git commands to generate.