]> git.pld-linux.org Git - packages/c-algorithms.git/blob - c-algorithms.spec
- updated to 1.2.0 (ISC licensed now), separated -apidocs
[packages/c-algorithms.git] / c-algorithms.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        Common Computer Science data structures and algorithms to use in C projects
6 Summary(pl.UTF-8):      Popularne struktury danych i algorytmy informatyczne do używania w programach w C
7 Name:           c-algorithms
8 Version:        1.0.0
9 Release:        0.1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/c-algorithms/%{name}-%{version}.tar.gz
13 # Source0-md5:  3435f8705ff83360b48bfba61decdb7a
14 URL:            http://c-algorithms.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Collection of common Computer Science data structures and algorithms
22 which may be used in C projects.
23
24 %description -l pl.UTF-8
25 Zbiór popularnych struktur danych i algorytmów informatycznych, które
26 można wykorzystywać w projektach w C.
27
28 %package devel
29 Summary:        Header files for c-algorithms library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki c-algorithms
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for c-algorithms library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki c-algorithms.
39
40 %package static
41 Summary:        Static c-algorithms library
42 Summary(pl.UTF-8):      Statyczna biblioteka c-algorithms
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static c-algorithms library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka c-algorithms.
51
52 %prep
53 %setup -q
54
55 %build
56 %{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__autoheader}
60 %{__automake}
61 %configure \
62         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog NEWS README
80 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc doc/html/*
85 %attr(755,root,root) %{_libdir}/lib*.so
86 %{_libdir}/lib*.la
87 %{_includedir}/libcalg-1.0
88 %{_pkgconfigdir}/*.pc
89
90 %if %{with static_libs}
91 %files static
92 %defattr(644,root,root,755)
93 %{_libdir}/lib*.a
94 %endif
This page took 0.094862 seconds and 3 git commands to generate.