]> git.pld-linux.org Git - packages/c-algorithms.git/blob - c-algorithms.spec
- added
[packages/c-algorithms.git] / c-algorithms.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        Collection of common Computer Science data structures and algorithms which may be used in C projects
6 #Summary(pl):   -
7 Name:           c-algorithms
8 Version:        1.0.0
9 Release:        0.1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/c-algorithms/%{name}-%{version}.tar.gz
13 # Source0-md5:  3435f8705ff83360b48bfba61decdb7a
14 URL:            http://c-algorithms.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Collection of common Computer Science data structures and algorithms
22 which may be used in C projects.
23
24 ##%description -l pl
25
26 %package devel
27 Summary:        Header files for c-algorithms library
28 Summary(pl):    Pliki nag³ówkowe biblioteki c-algorithms
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       pkgconfig
32
33 %description devel
34 Header files for c-algorithms library.
35
36 %description devel -l pl
37 Pliki nag³ówkowe biblioteki c-algorithms.
38
39 %package static
40 Summary:        Static c-algorithms library
41 Summary(pl):    Statyczna biblioteka c-algorithms
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static c-algorithms library.
47
48 %description static -l pl
49 Statyczna biblioteka c-algorithms.
50
51 %prep
52 %setup -q
53
54 %build
55 %{__libtoolize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 %configure \
61         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc AUTHORS ChangeLog NEWS README
79 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
80
81 %files devel
82 %defattr(644,root,root,755)
83 %doc doc/html/*
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %{_libdir}/lib*.la
86 %{_includedir}/libcalg-1.0
87 %{_pkgconfigdir}/*.pc
88
89 %if %{with static_libs}
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/lib*.a
93 %endif
This page took 0.095603 seconds and 3 git commands to generate.