]> git.pld-linux.org Git - packages/c-algorithms.git/blame - c-algorithms.spec
- converted to UTF-8
[packages/c-algorithms.git] / c-algorithms.spec
CommitLineData
c2e8672b 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
df32ab4a 5Summary: Common Computer Science data structures and algorithms to use in C projects
c14ad9a5 6Summary(pl.UTF-8): Popularne struktury danych i algorytmy informatyczne do używania w programach w C
c2e8672b 7Name: c-algorithms
8Version: 1.0.0
9Release: 0.1
10License: BSD-like
11Group: Libraries
12Source0: http://dl.sourceforge.net/c-algorithms/%{name}-%{version}.tar.gz
13# Source0-md5: 3435f8705ff83360b48bfba61decdb7a
14URL: http://c-algorithms.sourceforge.net/
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: libtool
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Collection of common Computer Science data structures and algorithms
22which may be used in C projects.
23
c14ad9a5
JR
24%description -l pl.UTF-8
25Zbiór popularnych struktur danych i algorytmów informatycznych, które
26można wykorzystywać w projektach w C.
c2e8672b 27
28%package devel
29Summary: Header files for c-algorithms library
c14ad9a5 30Summary(pl.UTF-8): Pliki nagłówkowe biblioteki c-algorithms
c2e8672b 31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
c2e8672b 33
34%description devel
35Header files for c-algorithms library.
36
c14ad9a5
JR
37%description devel -l pl.UTF-8
38Pliki nagłówkowe biblioteki c-algorithms.
c2e8672b 39
40%package static
41Summary: Static c-algorithms library
c14ad9a5 42Summary(pl.UTF-8): Statyczna biblioteka c-algorithms
c2e8672b 43Group: Development/Libraries
44Requires: %{name}-devel = %{version}-%{release}
45
46%description static
47Static c-algorithms library.
48
c14ad9a5 49%description static -l pl.UTF-8
c2e8672b 50Statyczna biblioteka c-algorithms.
51
52%prep
53%setup -q
54
55%build
56%{__libtoolize}
57%{__aclocal}
58%{__autoconf}
59%{__autoheader}
60%{__automake}
61%configure \
62 --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
63%{__make}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68%{__make} install \
69 DESTDIR=$RPM_BUILD_ROOT
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post -p /sbin/ldconfig
75%postun -p /sbin/ldconfig
76
77%files
78%defattr(644,root,root,755)
79%doc AUTHORS ChangeLog NEWS README
80%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
81
82%files devel
83%defattr(644,root,root,755)
84%doc doc/html/*
85%attr(755,root,root) %{_libdir}/lib*.so
86%{_libdir}/lib*.la
87%{_includedir}/libcalg-1.0
88%{_pkgconfigdir}/*.pc
89
90%if %{with static_libs}
91%files static
92%defattr(644,root,root,755)
93%{_libdir}/lib*.a
94%endif
This page took 0.087561 seconds and 4 git commands to generate.