]> git.pld-linux.org Git - packages/bzrtp.git/blob - bzrtp.spec
- updated dependencies, don't assume gcc>=8
[packages/bzrtp.git] / bzrtp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Open source implementation of ZRTP keys exchange protocol
6 Summary(pl.UTF-8):      Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
7 Name:           bzrtp
8 Version:        1.0.6
9 Release:        3
10 License:        GPL v2+
11 Group:          Libraries
12 Source0:        http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
13 # Source0-md5:  e77a6b074bb810a02cc77a1df776fb79
14 URL:            http://www.linphone.org/
15 BuildRequires:  CUnit
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  bctoolbox-devel
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  sqlite3-devel >= 3.6.0
23 Requires:       sqlite3 >= 3.6.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 bzrtp is an opensource implementation of ZRTP keys exchange protocol. 
28 The library written in C 89 is fully portable and can be executed on
29 many platforms including both ARM processor and x86. 
30
31 %description -l pl.UTF-8
32 bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
33 ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
34 wykonywana na wielu platformach, w tym ARM oraz x86.
35
36 %package devel
37 Summary:        Header file for bzrtp library
38 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bzrtp
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header file for bzrtp library.
44
45 %description devel -l pl.UTF-8
46 Plik nagłówkowy biblioteki bzrtp.
47
48 %package static
49 Summary:        Static bzrtp library
50 Summary(pl.UTF-8):      Statyczna biblioteka bzrtp
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static bzrtp library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka bzrtp.
59
60 %prep
61 %setup -q
62
63 %build
64 # rebuild ac/am/lt for as-needed to work
65 %{__libtoolize}
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__automake}
69 %if "%{cc_version}" >= "8.0"
70 CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type"
71 %endif
72 %configure \
73         --disable-silent-rules \
74         %{?with_static_libs:--enable-static}
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 # obsoleted by pkg-config
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS NEWS README.md
96 %attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libbzrtp.so
102 %{_includedir}/bzrtp
103 %{_pkgconfigdir}/libbzrtp.pc
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libbzrtp.a
109 %endif
This page took 0.055974 seconds and 3 git commands to generate.