]> git.pld-linux.org Git - packages/bzrtp.git/blob - bzrtp.spec
- updated to 5.3.26
[packages/bzrtp.git] / bzrtp.spec
1 # TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Open source implementation of ZRTP keys exchange protocol
7 Summary(pl.UTF-8):      Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
8 Name:           bzrtp
9 Version:        1.0.6
10 Release:        3
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
14 # Source0-md5:  e77a6b074bb810a02cc77a1df776fb79
15 URL:            http://www.linphone.org/
16 BuildRequires:  CUnit
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  bctoolbox-devel
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  polarssl-devel
23 BuildRequires:  pkgconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 bzrtp is an opensource implementation of ZRTP keys exchange protocol. 
28 The library written in C 89 is fully portable and can be executed on
29 many platforms including both ARM processor and x86. 
30
31 %description -l pl.UTF-8
32 bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
33 ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
34 wykonywana na wielu platformach, w tym ARM oraz x86.
35
36 %package devel
37 Summary:        Header file for bzrtp library
38 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bzrtp
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header file for bzrtp library.
44
45 %description devel -l pl.UTF-8
46 Plik nagłówkowy biblioteki bzrtp.
47
48 %package static
49 Summary:        Static bzrtp library
50 Summary(pl.UTF-8):      Statyczna biblioteka bzrtp
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static bzrtp library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka bzrtp.
59
60 %prep
61 %setup -q
62
63 %build
64 # rebuild ac/am/lt for as-needed to work
65 %{__libtoolize}
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type" \
71         --disable-silent-rules \
72         %{?with_static_libs:--enable-static}
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 # obsoleted by pkg-config
83 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS NEWS README.md
94 %attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libbzrtp.so
100 %{_includedir}/bzrtp
101 %{_pkgconfigdir}/libbzrtp.pc
102
103 %if %{with static_libs}
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libbzrtp.a
107 %endif
This page took 0.084485 seconds and 3 git commands to generate.