]> git.pld-linux.org Git - packages/bzrtp.git/blob - bzrtp.spec
- up to 1.0.6
[packages/bzrtp.git] / bzrtp.spec
1 # TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Open source implementation of ZRTP keys exchange protocol
7 Summary(pl.UTF-8):      Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
8 Name:           bzrtp
9 Version:        1.0.6
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
14 # Source0-md5:  e77a6b074bb810a02cc77a1df776fb79
15 URL:            http://www.linphone.org/
16 BuildRequires:  CUnit
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  polarssl-devel
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 bzrtp is an opensource implementation of ZRTP keys exchange protocol. 
27 The library written in C 89 is fully portable and can be executed on
28 many platforms including both ARM processor and x86. 
29
30 %description -l pl.UTF-8
31 bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
32 ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
33 wykonywana na wielu platformach, w tym ARM oraz x86.
34
35 %package devel
36 Summary:        Header file for bzrtp library
37 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bzrtp
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header file for bzrtp library.
43
44 %description devel -l pl.UTF-8
45 Plik nagłówkowy biblioteki bzrtp.
46
47 %package static
48 Summary:        Static bzrtp library
49 Summary(pl.UTF-8):      Statyczna biblioteka bzrtp
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static bzrtp library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka bzrtp.
58
59 %prep
60 %setup -q
61
62 %build
63 # rebuild ac/am/lt for as-needed to work
64 %{__libtoolize}
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %{__automake}
68 %configure \
69         CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type" \
70         --disable-silent-rules \
71         %{?with_static_libs:--enable-static}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # obsoleted by pkg-config
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS NEWS README.md
93 %attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libbzrtp.so
99 %{_includedir}/bzrtp
100 %{_pkgconfigdir}/libbzrtp.pc
101
102 %if %{with static_libs}
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libbzrtp.a
106 %endif
This page took 0.09044 seconds and 3 git commands to generate.