]> git.pld-linux.org Git - packages/bzrtp.git/blame - bzrtp.spec
- up to 1.0.6
[packages/bzrtp.git] / bzrtp.spec
CommitLineData
f05f634e 1# TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
ff5ec0a1
JB
2#
3# Conditional build:
4%bcond_without static_libs # static library
5#
6Summary: Open source implementation of ZRTP keys exchange protocol
7Summary(pl.UTF-8): Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
8Name: bzrtp
fa43ff76 9Version: 1.0.6
ff5ec0a1
JB
10Release: 1
11License: GPL v2+
12Group: Libraries
13Source0: http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
fa43ff76 14# Source0-md5: e77a6b074bb810a02cc77a1df776fb79
ff5ec0a1
JB
15URL: http://www.linphone.org/
16BuildRequires: CUnit
17BuildRequires: autoconf >= 2.63
18BuildRequires: automake
19BuildRequires: libtool >= 2:2
20BuildRequires: libxml2-devel >= 2.0
21BuildRequires: polarssl-devel
22BuildRequires: pkgconfig
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26bzrtp is an opensource implementation of ZRTP keys exchange protocol.
27The library written in C 89 is fully portable and can be executed on
28many platforms including both ARM processor and x86.
29
30%description -l pl.UTF-8
31bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
32ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
33wykonywana na wielu platformach, w tym ARM oraz x86.
34
35%package devel
36Summary: Header file for bzrtp library
37Summary(pl.UTF-8): Plik nagłówkowy biblioteki bzrtp
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Header file for bzrtp library.
43
44%description devel -l pl.UTF-8
45Plik nagłówkowy biblioteki bzrtp.
46
47%package static
48Summary: Static bzrtp library
49Summary(pl.UTF-8): Statyczna biblioteka bzrtp
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static bzrtp library.
55
56%description static -l pl.UTF-8
57Statyczna biblioteka bzrtp.
58
59%prep
60%setup -q
61
62%build
63# rebuild ac/am/lt for as-needed to work
64%{__libtoolize}
65%{__aclocal} -I m4
66%{__autoconf}
67%{__automake}
68%configure \
fa43ff76 69 CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type" \
ff5ec0a1
JB
70 --disable-silent-rules \
71 %{?with_static_libs:--enable-static}
72
73%{__make}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81# obsoleted by pkg-config
82%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(644,root,root,755)
fa43ff76 92%doc AUTHORS NEWS README.md
ff5ec0a1
JB
93%attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
94%attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
95
96%files devel
97%defattr(644,root,root,755)
98%attr(755,root,root) %{_libdir}/libbzrtp.so
99%{_includedir}/bzrtp
100%{_pkgconfigdir}/libbzrtp.pc
101
102%if %{with static_libs}
103%files static
104%defattr(644,root,root,755)
105%{_libdir}/libbzrtp.a
106%endif
This page took 0.095417 seconds and 4 git commands to generate.