]> git.pld-linux.org Git - packages/bzrtp.git/blame - bzrtp.spec
- updated to 1.0.3
[packages/bzrtp.git] / bzrtp.spec
CommitLineData
f05f634e 1# TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
ff5ec0a1
JB
2#
3# Conditional build:
4%bcond_without static_libs # static library
5#
6Summary: Open source implementation of ZRTP keys exchange protocol
7Summary(pl.UTF-8): Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
8Name: bzrtp
f05f634e 9Version: 1.0.3
ff5ec0a1
JB
10Release: 1
11License: GPL v2+
12Group: Libraries
13Source0: http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
f05f634e 14# Source0-md5: 0d0c694e114d85420d351b94f0e9d867
ff5ec0a1
JB
15URL: http://www.linphone.org/
16BuildRequires: CUnit
17BuildRequires: autoconf >= 2.63
18BuildRequires: automake
19BuildRequires: libtool >= 2:2
20BuildRequires: libxml2-devel >= 2.0
21BuildRequires: polarssl-devel
22BuildRequires: pkgconfig
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26bzrtp is an opensource implementation of ZRTP keys exchange protocol.
27The library written in C 89 is fully portable and can be executed on
28many platforms including both ARM processor and x86.
29
30%description -l pl.UTF-8
31bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
32ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
33wykonywana na wielu platformach, w tym ARM oraz x86.
34
35%package devel
36Summary: Header file for bzrtp library
37Summary(pl.UTF-8): Plik nagłówkowy biblioteki bzrtp
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Header file for bzrtp library.
43
44%description devel -l pl.UTF-8
45Plik nagłówkowy biblioteki bzrtp.
46
47%package static
48Summary: Static bzrtp library
49Summary(pl.UTF-8): Statyczna biblioteka bzrtp
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static bzrtp library.
55
56%description static -l pl.UTF-8
57Statyczna biblioteka bzrtp.
58
59%prep
60%setup -q
61
62%build
63# rebuild ac/am/lt for as-needed to work
64%{__libtoolize}
65%{__aclocal} -I m4
66%{__autoconf}
67%{__automake}
68%configure \
69 --disable-silent-rules \
70 %{?with_static_libs:--enable-static}
71
72%{__make}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} install \
78 DESTDIR=$RPM_BUILD_ROOT
79
80# obsoleted by pkg-config
81%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%files
90%defattr(644,root,root,755)
91%doc AUTHORS NEWS README
92%attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
93%attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
94
95%files devel
96%defattr(644,root,root,755)
97%attr(755,root,root) %{_libdir}/libbzrtp.so
98%{_includedir}/bzrtp
99%{_pkgconfigdir}/libbzrtp.pc
100
101%if %{with static_libs}
102%files static
103%defattr(644,root,root,755)
104%{_libdir}/libbzrtp.a
105%endif
This page took 0.057784 seconds and 4 git commands to generate.