]> git.pld-linux.org Git - packages/bzrtp.git/blame - bzrtp.spec
- rel 2; BR: bctoolbox
[packages/bzrtp.git] / bzrtp.spec
CommitLineData
f05f634e 1# TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
ff5ec0a1
JB
2#
3# Conditional build:
4%bcond_without static_libs # static library
5#
6Summary: Open source implementation of ZRTP keys exchange protocol
7Summary(pl.UTF-8): Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
8Name: bzrtp
fa43ff76 9Version: 1.0.6
e7251907 10Release: 2
ff5ec0a1
JB
11License: GPL v2+
12Group: Libraries
13Source0: http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
fa43ff76 14# Source0-md5: e77a6b074bb810a02cc77a1df776fb79
ff5ec0a1
JB
15URL: http://www.linphone.org/
16BuildRequires: CUnit
17BuildRequires: autoconf >= 2.63
18BuildRequires: automake
e7251907 19BuildRequires: bctoolbox
ff5ec0a1
JB
20BuildRequires: libtool >= 2:2
21BuildRequires: libxml2-devel >= 2.0
22BuildRequires: polarssl-devel
23BuildRequires: pkgconfig
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27bzrtp is an opensource implementation of ZRTP keys exchange protocol.
28The library written in C 89 is fully portable and can be executed on
29many platforms including both ARM processor and x86.
30
31%description -l pl.UTF-8
32bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
33ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
34wykonywana na wielu platformach, w tym ARM oraz x86.
35
36%package devel
37Summary: Header file for bzrtp library
38Summary(pl.UTF-8): Plik nagłówkowy biblioteki bzrtp
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Header file for bzrtp library.
44
45%description devel -l pl.UTF-8
46Plik nagłówkowy biblioteki bzrtp.
47
48%package static
49Summary: Static bzrtp library
50Summary(pl.UTF-8): Statyczna biblioteka bzrtp
51Group: Development/Libraries
52Requires: %{name}-devel = %{version}-%{release}
53
54%description static
55Static bzrtp library.
56
57%description static -l pl.UTF-8
58Statyczna biblioteka bzrtp.
59
60%prep
61%setup -q
62
63%build
64# rebuild ac/am/lt for as-needed to work
65%{__libtoolize}
66%{__aclocal} -I m4
67%{__autoconf}
68%{__automake}
69%configure \
fa43ff76 70 CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type" \
ff5ec0a1
JB
71 --disable-silent-rules \
72 %{?with_static_libs:--enable-static}
73
74%{__make}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79%{__make} install \
80 DESTDIR=$RPM_BUILD_ROOT
81
82# obsoleted by pkg-config
83%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(644,root,root,755)
fa43ff76 93%doc AUTHORS NEWS README.md
ff5ec0a1
JB
94%attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
95%attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
96
97%files devel
98%defattr(644,root,root,755)
99%attr(755,root,root) %{_libdir}/libbzrtp.so
100%{_includedir}/bzrtp
101%{_pkgconfigdir}/libbzrtp.pc
102
103%if %{with static_libs}
104%files static
105%defattr(644,root,root,755)
106%{_libdir}/libbzrtp.a
107%endif
This page took 0.176224 seconds and 4 git commands to generate.