]> git.pld-linux.org Git - packages/bzrtp.git/blame - bzrtp.spec
- new
[packages/bzrtp.git] / bzrtp.spec
CommitLineData
ff5ec0a1
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Open source implementation of ZRTP keys exchange protocol
6Summary(pl.UTF-8): Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
7Name: bzrtp
8Version: 1.0.2
9Release: 1
10License: GPL v2+
11Group: Libraries
12Source0: http://linphone.org/releases/sources/bzrtp/%{name}-%{version}.tar.gz
13# Source0-md5: b52fa670fb319022166cb10d641da4e6
14URL: http://www.linphone.org/
15BuildRequires: CUnit
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake
18BuildRequires: libtool >= 2:2
19BuildRequires: libxml2-devel >= 2.0
20BuildRequires: polarssl-devel
21BuildRequires: pkgconfig
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25bzrtp is an opensource implementation of ZRTP keys exchange protocol.
26The library written in C 89 is fully portable and can be executed on
27many platforms including both ARM processor and x86.
28
29%description -l pl.UTF-8
30bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
31ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
32wykonywana na wielu platformach, w tym ARM oraz x86.
33
34%package devel
35Summary: Header file for bzrtp library
36Summary(pl.UTF-8): Plik nagłówkowy biblioteki bzrtp
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41Header file for bzrtp library.
42
43%description devel -l pl.UTF-8
44Plik nagłówkowy biblioteki bzrtp.
45
46%package static
47Summary: Static bzrtp library
48Summary(pl.UTF-8): Statyczna biblioteka bzrtp
49Group: Development/Libraries
50Requires: %{name}-devel = %{version}-%{release}
51
52%description static
53Static bzrtp library.
54
55%description static -l pl.UTF-8
56Statyczna biblioteka bzrtp.
57
58%prep
59%setup -q
60
61%build
62# rebuild ac/am/lt for as-needed to work
63%{__libtoolize}
64%{__aclocal} -I m4
65%{__autoconf}
66%{__automake}
67%configure \
68 --disable-silent-rules \
69 %{?with_static_libs:--enable-static}
70
71%{__make}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%{__make} install \
77 DESTDIR=$RPM_BUILD_ROOT
78
79# obsoleted by pkg-config
80%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(644,root,root,755)
90%doc AUTHORS NEWS README
91%attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
92%attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
93
94%files devel
95%defattr(644,root,root,755)
96%attr(755,root,root) %{_libdir}/libbzrtp.so
97%{_includedir}/bzrtp
98%{_pkgconfigdir}/libbzrtp.pc
99
100%if %{with static_libs}
101%files static
102%defattr(644,root,root,755)
103%{_libdir}/libbzrtp.a
104%endif
This page took 0.044456 seconds and 4 git commands to generate.