]> git.pld-linux.org Git - packages/bzr-gtk.git/blob - bzr-gtk.spec
95d30156518130226a87bdfe9949420730145c75
[packages/bzr-gtk.git] / bzr-gtk.spec
1 # TODO:
2 # - Add locale files
3 # - Add new package for Olive, previously included here now it's own project: http://wiki.bazaar.canonical.com/Olive/
4 %define         ver     0.99
5 %define         minor   1
6 Summary:        Plugin for Bazaar-NG (bzr)
7 Summary(pl.UTF-8):      Wtyczka do Bazaar-NG (bzr)
8 Name:           bzr-gtk
9 Version:        %{ver}.%{minor}
10 Release:        8
11 License:        GPL v2+
12 Group:          Development/Version Control
13 # Source0:      https://launchpad.net/bzr-gtk/%{ver}/%{version}/+download/bzr-gtk-%{version}.tar.gz
14 Source0:        http://samba.org/~jelmer/bzr/%{name}-%{version}.tar.gz
15 # Source0-md5:  68354924f3104ab1ba7efc8bfe15ae0b
16 URL:            http://bazaar-vcs.org/bzr-gtk
17 BuildRequires:  bzr >= %{ver}
18 BuildRequires:  gettext-tools
19 BuildRequires:  pkgconfig
20 BuildRequires:  python >= 1:2.4
21 BuildRequires:  python-devel
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires(post,postun):  desktop-file-utils
25 %pyrequires_eq  python
26 Requires:       bzr >= %{ver}
27 Requires:       python-pygtk-glade >= 2:2.10
28 Requires:       python-pygtk-gtk >= 2:2.10
29 Suggests:       python-gnome
30 Suggests:       python-pycairo
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 bzr-gtk is a plugin for Bazaar-NG (bzr) that aims to provide GTK+
35 interfaces to most Bazaar operations. Provided commands are:
36 - gcommit
37 - gdiff
38 - visualise
39 - gannotate
40 - gbranch
41
42 %description -l pl.UTF-8
43 bzr-gtk jest wtyczką dla Bazaar-NG (bzr), która ma na celu
44 dostarczenie graficznego interfejsu GTK+ dla większości poleceń
45 Bazaar. Dostępnymi poleceniami są:
46 - gcommit
47 - gdiff
48 - visualise
49 - gannotate
50 - gbranch
51
52 %prep
53 %setup -q
54
55 %build
56 %{__python} setup.py build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__python} setup.py install \
62         --install-purelib %{py_sitedir} \
63         --optimize=2 \
64         --root=$RPM_BUILD_ROOT
65
66 %py_postclean
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 %update_desktop_database_post
73 %banner %{name} -e << EOF
74 For full functionality, you need to install:
75 - python-pycairo (for graphs in the visualisation tool)
76 - python-gnome (for Nautilus integration)
77 EOF
78
79 %postun
80 %update_desktop_database_postun
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS NEWS README TODO
85 %attr(755,root,root) %{_bindir}/bzr-handle-patch
86 %attr(755,root,root) %{_bindir}/bzr-notify
87 %{py_sitedir}/bzrlib/plugins/gtk
88 %{_datadir}/bzr-gtk
89 %{_desktopdir}/bazaar-properties.desktop
90 %{_desktopdir}/bzr-notify.desktop
91 %{_desktopdir}/bzr-handle-patch.desktop
92 %{_pixmapsdir}/bzr-icon-64.png
93 %{_iconsdir}/hicolor/scalable/emblems
94 %{_datadir}/application-registry/bzr-gtk.applications
This page took 0.062395 seconds and 2 git commands to generate.