]> git.pld-linux.org Git - packages/bzr-gtk.git/blob - bzr-gtk.spec
150aef08db59e14cf3dbf603727175e326191ea0
[packages/bzr-gtk.git] / bzr-gtk.spec
1 # TODO:
2 # - Add locale files
3 # - Add new package for Olive, previously included here now it's own project: http://wiki.bazaar.canonical.com/Olive/
4 %define         ver     0.99
5 %define         minor   1
6 Summary:        Plugin for Bazaar-NG (bzr)
7 Summary(pl.UTF-8):      Wtyczka do Bazaar-NG (bzr)
8 Name:           bzr-gtk
9 Version:        %{ver}.%{minor}
10 Release:        8
11 License:        GPL v2+
12 Group:          Development/Version Control
13 # Source0:      https://launchpad.net/bzr-gtk/%{ver}/%{version}/+download/bzr-gtk-%{version}.tar.gz
14 Source0:        http://samba.org/~jelmer/bzr/%{name}-%{version}.tar.gz
15 # Source0-md5:  68354924f3104ab1ba7efc8bfe15ae0b
16 Patch0:         %{name}-dbus_detection_fix.patch
17 URL:            http://bazaar-vcs.org/bzr-gtk
18 BuildRequires:  gettext-devel
19 BuildRequires:  pkgconfig
20 BuildRequires:  python >= 1:2.4
21 BuildRequires:  python-devel
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires(post,postun):  desktop-file-utils
25 %pyrequires_eq  python
26 Requires:       bzr >= %{ver}
27 Requires:       python-pygtk-glade >= 2:2.10
28 Requires:       python-pygtk-gtk >= 2:2.10
29 Suggests:       python-gnome
30 Suggests:       python-pycairo
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 bzr-gtk is a plugin for Bazaar-NG (bzr) that aims to provide GTK+
35 interfaces to most Bazaar operations. Provided commands are:
36 - gcommit
37 - gdiff
38 - visualise
39 - gannotate
40 - gbranch
41
42 %description -l pl.UTF-8
43 bzr-gtk jest wtyczką dla Bazaar-NG (bzr), która ma na celu
44 dostarczenie graficznego interfejsu GTK+ dla większości poleceń
45 Bazaar. Dostępnymi poleceniami są:
46 - gcommit
47 - gdiff
48 - visualise
49 - gannotate
50 - gbranch
51
52 %prep
53 %setup -q
54 #%patch0 -p1
55
56 %build
57 %{__python} setup.py build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__python} setup.py install \
63         --install-purelib %{py_sitedir} \
64         --optimize=2 \
65         --root=$RPM_BUILD_ROOT
66
67 %py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %update_desktop_database_post
74 %banner %{name} -e << EOF
75 For full functionality, you need to install:
76 - python-pycairo (for graphs in the visualisation tool)
77 - python-gnome (for Nautilus integration)
78 EOF
79
80 %postun
81 %update_desktop_database_postun
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS NEWS README TODO
86 %attr(755,root,root) %{_bindir}/bzr-handle-patch
87 %attr(755,root,root) %{_bindir}/bzr-notify
88 %{py_sitedir}/bzrlib/plugins/gtk
89 %{_datadir}/bzr-gtk
90 %{_desktopdir}/bazaar-properties.desktop
91 %{_desktopdir}/bzr-notify.desktop
92 %{_desktopdir}/bzr-handle-patch.desktop
93 %{_pixmapsdir}/bzr-icon-64.png
94 %{_iconsdir}/hicolor/scalable/emblems
95 %{_datadir}/application-registry/bzr-gtk.applications
This page took 0.062512 seconds and 2 git commands to generate.