]> git.pld-linux.org Git - packages/bzr-fastimport.git/commitdiff
patch to make authors map file to support equal signs auto/th/bzr-fastimport-0.13.0-1
authorElan Ruusamäe <glen@delfi.ee>
Sat, 19 Jan 2013 12:04:15 +0000 (14:04 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 19 Jan 2013 12:04:15 +0000 (14:04 +0200)
bug-1101776.patch [new file with mode: 0644]
bzr-fastimport.spec

diff --git a/bug-1101776.patch b/bug-1101776.patch
new file mode 100644 (file)
index 0000000..a897093
--- /dev/null
@@ -0,0 +1,23 @@
+--- bzr-fastimport-0.13.0/user_mapper.py~      2013-01-19 14:01:00.135642260 +0200
++++ bzr-fastimport-0.13.0/user_mapper.py       2013-01-19 14:01:47.191146251 +0200
+@@ -43,16 +44,16 @@
+             line = line.strip()
+             if len(line) == 0 or line.startswith('#'):
+                 continue
+-            old, new = line.split('=', 1)
+-            old = old.strip()
+-            new = new.strip()
++
++            old = "=".join(line.split('=')[:-1]).strip()
++            new = "=".join(line.split('=')[-1:]).strip()
+             if old == '@':
+                 self._default_domain = new
+                 continue
+             # Parse each id into a name and email address
+             old_name, old_email = self._parse_id(old)
+             new_name, new_email = self._parse_id(new)
+-            #print "found user map: %s => %s" % ((old_name, old_email), (new_name, new_email))
++            #print >> sys.stderr, "found user map: %s => %s" % ((old_name, old_email), (new_name, new_email))
+             self._user_map[(old_name, old_email)] = (new_name, new_email)
+     def _parse_id(self, id):
index 2461b438ab99eeb2cef61a4dcaedace138c1abcf..1fcdb65bdbec9c31baad2a6ae94a7a9cc21c0c3b 100644 (file)
@@ -8,6 +8,7 @@ License:        GPL v2+ and MIT
 URL:           https://launchpad.net/bzr-fastimport
 Source0:       http://launchpad.net/bzr-fastimport/trunk/%{version}/+download/%{name}-%{version}.tar.gz
 # Source0-md5: e47115774d44ae0c3b027ae0374aa52e
+Patch0:                bug-1101776.patch
 BuildRequires: bzr
 BuildRequires: python-distribute
 Requires:      bzr
@@ -27,6 +28,7 @@ custom migration solution.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__python} setup.py build
@@ -40,7 +42,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %py_postclean
 
-# not interested of tests at runtime
+# not interested to package tests at runtime
 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/bzrlib/plugins/fastimport/tests
 
 %clean
This page took 0.03851 seconds and 4 git commands to generate.