]> git.pld-linux.org Git - packages/byteman.git/blame - byteman.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/byteman.git] / byteman.spec
CommitLineData
1b10e3db
JB
1# TODO:
2# - build from source, see e.g.:
3# http://pkgs.fedoraproject.org/cgit/byteman.git/plain/byteman.spec
4# - javadocs
5#
1b10e3db
JB
6Summary: Java agent-based bytecode injection tool
7Summary(pl.UTF-8): Oparte na agencie narzędzie do wstrzykiwania kodu dla Javy
8Name: byteman
00492f93 9Version: 3.0.1
1b10e3db
JB
10Release: 1
11License: LGPL v2+
12Group: Development/Languages/Java
13#Source0Download: https://www.jboss.org:443/byteman/downloads.html
14Source0: http://downloads.jboss.org/byteman/%{version}/byteman-download-%{version}-full.zip
00492f93 15# Source0-md5: c704769662f4dd06233dc659f2d24329
1b10e3db
JB
16URL: http://www.jboss.com/byteman/
17# this is needed for the LC_ALL=en_US in build part dependency
18%if %(locale -a | grep -q '^en_US$'; echo $?)
19#BuildRequires: glibc-localedb-all
20%endif
21BuildRequires: jpackage-utils
22BuildRequires: rpm-javaprov
23BuildRequires: rpmbuild(macros) >= 1.300
24# to build from source:
25#BuildRequires: jarjar
26#BuildRequires: java_cup
27#BuildRequires: javapackages-tools
28#BuildRequires: jdk
29#BuildRequires: junit4
30#BuildRequires: maven-failsafe-plugin
31#BuildRequires: maven-jar-plugin
32#BuildRequires: maven-local
33#BuildRequires: maven-shade-plugin
34#BuildRequires: maven-surefire-plugin
35#BuildRequires: maven-surefire-provider-junit4
36#BuildRequires: maven-surefire-provider-testng
37#BuildRequires: maven-verifier-plugin
38#BuildRequires: objectweb-asm
39#BuildRequires: testng
40Requires: jpackage-utils
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Byteman is a tool which simplifies tracing and testing of Java
46programs. Byteman allows you to insert extra Java code into your
47application, either as it is loaded during JVM startup or even after
48it has already started running. The injected code is allowed to access
49any of your data and call any application methods, including where
50they are private. You can inject code almost anywhere you want and
51there is no need to prepare the original source code in advance nor do
52you have to recompile, repackage or redeploy your application. In fact
53you can remove injected code and reinstall different code while the
54application continues to execute.
55
56%description -l pl.UTF-8
57Byteman to narzędzie upraszczajace śledzenie i testowanie programów w
58Javie. Pozwala wstawić dodatkowy kod w Javie do aplikacji - albo w
59trakcie wczytywania go przy uruchamianiu JVM, albo nawet po jej
60uruchomieniu. Wstrzyknięty kod ma dostęp do dowolnych danych i może
61wywoływać dowolne metody aplikacji, włącznie z prywatnymi. Kod można
62wstrzyknąć prawie wszędzie i nie ma potrzeby wcześniejszego
63przygotowywania kodu źródłowego ani rekompilacji, ponownego
64pakietowania ani wdrażania aplikacji. W praktyce można usunąć
65wstrzyknięty kod i zainstalować inny kod, kiedy aplikacja cały czas
66działa.
67
68%package javadoc
69Summary: Javadocs for Byteman
70Summary(pl.UTF-8): Dokumentacja w formacie javadoc do Bytemana
71Group: Documentation
72Requires: jpackage-utils
73
74%description javadoc
75Javadocs for Byteman.
76
77%description javadoc -l pl.UTF-8
78Dokumentacja w formacie javadoc do Bytemana.
79
80%prep
81%setup -q -n byteman-download-%{version}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85install -d $RPM_BUILD_ROOT{%{_javadir}/byteman,%{_datadir}/byteman/{bin,lib},%{_bindir}}
86
87cp -p lib/byteman*.jar contrib/bmunit/byteman-bmunit.jar contrib/dtest/byteman-dtest.jar \
88 $RPM_BUILD_ROOT%{_javadir}/byteman
89for f in $RPM_BUILD_ROOT%{_javadir}/byteman/byteman*.jar ; do
90 ln -sf %{_javadir}/$(basename $f) $RPM_BUILD_ROOT%{_datadir}/byteman/lib
91done
92install bin/{bmcheck,bmjava,bminstall,bmsubmit}.sh $RPM_BUILD_ROOT%{_datadir}/byteman/bin
93for f in bmcheck bmjava bminstall bmsubmit ; do
94cat >$RPM_BUILD_ROOT%{_bindir}/$f <<EOF
95#!/bin/sh
96
97BYTEMAN_HOME=%{_datadir}/byteman
98JAVA_HOME=%{_jvmdir}/java
99
100\$BYTEMAN_HOME/bin/${f}.sh "\$@"
101EOF
102done
103
104# TODO: javadocs
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
111%attr(755,root,root) %{_bindir}/bmcheck
112%attr(755,root,root) %{_bindir}/bmjava
113%attr(755,root,root) %{_bindir}/bminstall
114%attr(755,root,root) %{_bindir}/bmsubmit
115%{_javadir}/byteman
116%dir %{_datadir}/byteman
117%dir %{_datadir}/byteman/bin
118%attr(755,root,root) %{_datadir}/byteman/bin/*.sh
119%{_datadir}/byteman/lib
120
121# TODO
122#%files javadoc
123#%defattr(644,root,root,755)
124#%{_javadocdir}/byteman-%{version}
This page took 0.073784 seconds and 4 git commands to generate.