]> git.pld-linux.org Git - packages/busybox.git/commitdiff
- disable RPC/NFS (build fails on tirpc linking with default bconds)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Jun 2022 08:25:49 +0000 (10:25 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Jun 2022 08:25:49 +0000 (10:25 +0200)
- disable stack protector   (/busybox-1.35.0/libbb/vfork_daemon_rexec.c:45: undefined reference to
`__stack_chk_fail') with uClibc
- debug packages are not generated since everything is stripped

busybox.config
busybox.spec

index 61cf0d593db94be6f1a14c34378a2bc99029a1b7..7a51807aadf54aebe500f655131b77ada8e694d8 100644 (file)
@@ -49,7 +49,7 @@ CONFIG_FEATURE_PREFER_APPLETS=y
 CONFIG_BUSYBOX_EXEC_PATH="/bin/busybox"
 CONFIG_FEATURE_SYSLOG=y
 CONFIG_FEATURE_SYSLOG_INFO=y
-CONFIG_FEATURE_HAVE_RPC=y
+# CONFIG_FEATURE_HAVE_RPC is not set
 CONFIG_PLATFORM_LINUX=y
 
 #
@@ -723,7 +723,7 @@ CONFIG_FEATURE_MOUNT_FAKE=y
 CONFIG_FEATURE_MOUNT_VERBOSE=y
 CONFIG_FEATURE_MOUNT_HELPERS=y
 CONFIG_FEATURE_MOUNT_LABEL=y
-CONFIG_FEATURE_MOUNT_NFS=y
+# CONFIG_FEATURE_MOUNT_NFS is not set
 CONFIG_FEATURE_MOUNT_CIFS=y
 CONFIG_FEATURE_MOUNT_FLAGS=y
 CONFIG_FEATURE_MOUNT_FSTAB=y
@@ -942,7 +942,7 @@ CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_DISCARD=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_TIME=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_DAYTIME=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_CHARGEN=y
-CONFIG_FEATURE_INETD_RPC=y
+# CONFIG_FEATURE_INETD_RPC is not set
 CONFIG_IP=y
 CONFIG_FEATURE_IP_ADDRESS=y
 CONFIG_FEATURE_IP_LINK=y
index 4076bdb12cd6459a5f4471c11ed5a60e3f5029d9..f972d06fa195dd14e7d66a3599b4256d89e16d22 100644 (file)
@@ -1,4 +1,5 @@
 # TODO:
+# - RPC/NFS with uClibc doesn't build (due to tirpc linking), so it's currently disabled
 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
 #   if it still serves a purpose
 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
@@ -94,6 +95,8 @@ BuildRequires:        uClibc-static >= 3:0.9.30.1
 Provides:      busybox-implementation = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %define                _bindir         /bin
 
 %if "%{_target_base_arch}" != "%{_host_base_arch}"
@@ -194,7 +197,7 @@ echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE" \
+       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
@@ -225,7 +228,7 @@ echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE" \
+       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
@@ -257,7 +260,7 @@ echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcdlibs}}"' >> .config
 %{__make} \
        %{?with_verbose:V=1} \
        %{CrossOpts} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}}" \
+       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -Wl,-z,noexecstack" \
        CC="%{__cc}"
 %{__make} busybox.links docs/busybox.1
This page took 0.238085 seconds and 4 git commands to generate.