]> git.pld-linux.org Git - packages/busybox.git/commitdiff
- Began upgrade to 0.17.3, NFY
authorCaleb Maclennan <caleb@alerque.com>
Mon, 8 Nov 2010 19:40:51 +0000 (19:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    busybox-dhcp.patch -> 1.5
    busybox-loadfont.patch -> 1.6
    busybox-logconsole.patch -> 1.10
    busybox.spec -> 1.181

busybox-dhcp.patch
busybox-loadfont.patch
busybox-logconsole.patch
busybox.spec

index 9c588e4cee0f5b9baa23d7a296617e24cf8e231f..f708b247a068209b746f6cc269270cd37bb9e34a 100644 (file)
@@ -1,14 +1,13 @@
---- busybox-1.3.1/networking/udhcp/options.c.orig      2006-12-27 05:52:33.000000000 +0100
-+++ busybox-1.3.1/networking/udhcp/options.c   2006-12-30 12:31:57.305539547 +0100
-@@ -24,8 +24,8 @@
+--- busybox-1.17.3/networking/udhcp/common.c~  2010-10-09 22:57:14.000000000 +0300
++++ busybox-1.17.3/networking/udhcp/common.c   2010-11-08 21:36:56.660518687 +0200
+@@ -32,8 +32,8 @@
        { OPTION_STRING               | OPTION_REQ, 0x0c }, /* DHCP_HOST_NAME     */
        { OPTION_U16                              , 0x0d }, /* DHCP_BOOT_SIZE     */
-       { OPTION_STRING | OPTION_LIST | OPTION_REQ, 0x0f }, /* DHCP_DOMAIN_NAME   */
+       { OPTION_STRING               | OPTION_REQ, 0x0f }, /* DHCP_DOMAIN_NAME   */
 -      { OPTION_IP                               , 0x10 }, /* DHCP_SWAP_SERVER   */
 -      { OPTION_STRING                           , 0x11 }, /* DHCP_ROOT_PATH     */
-+      { OPTION_IP | OPTION_REQ                  , 0x10 }, /* DHCP_SWAP_SERVER   */
-+      { OPTION_STRING | OPTION_REQ              , 0x11 }, /* DHCP_ROOT_PATH     */
++      { OPTION_IP                   | OPTION_REQ, 0x10 }, /* DHCP_SWAP_SERVER   */
++      { OPTION_STRING               | OPTION_REQ, 0x11 }, /* DHCP_ROOT_PATH     */
        { OPTION_U8                               , 0x17 }, /* DHCP_IP_TTL        */
        { OPTION_U16                              , 0x1a }, /* DHCP_MTU           */
        { OPTION_IP                   | OPTION_REQ, 0x1c }, /* DHCP_BROADCAST     */
-
index 666d7a4924156a4d1c97af79d06cfcd415baa90d..1c2ef4857084fc14bb5cfa01724181ebc81c0242 100644 (file)
@@ -1,13 +1,12 @@
---- busybox-1.12.2/console-tools/loadfont.c~   2008-11-19 12:27:34.314700966 +0100
-+++ busybox-1.12.2/console-tools/loadfont.c    2008-11-19 12:28:35.598028789 +0100
-@@ -115,8 +115,10 @@
-               head0 = sizeof(struct psf_header);
+--- busybox-1.17.3/console-tools/loadfont.c.orig       2010-10-09 22:57:13.000000000 +0300
++++ busybox-1.17.3/console-tools/loadfont.c    2010-11-08 21:30:00.827185361 +0200
+@@ -274,9 +274,6 @@
+       table = font + fontsize * charsize;
+       buffer += len;
  
-               head = head0 + fontsize * unit;
-+              /*
-               if (head > len || (!hastable && head != len))
-                       bb_error_msg_and_die("input file: bad length");
-+              */
-       } else {
-               /* file with three code pages? */
-               if (len == 9780) {
+-      if (table > buffer || (!has_table && table != buffer))
+-              bb_error_msg_and_die("input file: bad length");
+-
+       do_loadfont(fd, font, height, width, charsize, fontsize);
+       if (has_table)
index 8d38d1614be13aa453d510088503bd6f1249d1e9..69dc16e47940fe23badf3a79754607803fef26cc 100644 (file)
@@ -1,22 +1,21 @@
-diff -urN busybox-1.00-pre2/include/libbb.h busybox-1.00-pre2.org/include/libbb.h
---- busybox-1.00-pre2/include/libbb.h  2003-08-02 23:40:57.000000000 +0200
-+++ busybox-1.00-pre2.org/include/libbb.h      2003-08-02 23:45:09.000000000 +0200
-@@ -346,7 +346,7 @@
+--- busybox-1.17.3/include/libbb.h.orig        2010-10-09 22:57:13.000000000 +0300
++++ busybox-1.17.3/include/libbb.h     2010-11-08 21:21:38.520518694 +0200
+@@ -1620,7 +1620,7 @@
  # define VC_2 "/dev/vc/2"
  # define VC_3 "/dev/vc/3"
  # define VC_4 "/dev/vc/4"
 -# define VC_5 "/dev/vc/5"
 +# define VC_12 "/dev/vc/12"
- #if defined(__sh__) || defined(__H8300H__) || defined(__H8300S__)
+ # if defined(__sh__) || defined(__H8300H__) || defined(__H8300S__)
  /* Yes, this sucks, but both SH (including sh64) and H8 have a SCI(F) for their
     respective serial ports .. as such, we can't use the common device paths for
-@@ -367,7 +367,7 @@
+@@ -1644,7 +1644,7 @@
  # define VC_2 "/dev/tty2"
  # define VC_3 "/dev/tty3"
  # define VC_4 "/dev/tty4"
 -# define VC_5 "/dev/tty5"
 +# define VC_12 "/dev/tty12"
- #if defined(__sh__) || defined(__H8300H__) || defined(__H8300S__)
+ # if defined(__sh__) || defined(__H8300H__) || defined(__H8300S__)
  #  define SC_0 "/dev/ttySC0"
  #  define SC_1 "/dev/ttySC1"
 --- busybox/init/init.c.orig   2008-04-19 04:03:13.000000000 +0000
index 405d41652a53c8949a88e762d92033d29879630d..00f8b3f196a6e09e3588d39485dfa432ea8ed903 100644 (file)
@@ -1,13 +1,16 @@
 # TODO:
-#      - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
-#      - make internal commands work even if busybox is not in /bin/busybox (initrd)
-#        or when /proc is not mounted (static / normal)
+# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
+#   if it still serves a purpose
+# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
+# - make internal commands work even if busybox is not in /bin/busybox (initrd)
+#   or when /proc is not mounted (static / normal)
 #
 # Conditional build:
 # alternative busybox config file (replaces default one) you should
 # define cfgfile macro, i.e.
 #
 #      rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
+#
 %bcond_with    altconfig       # use alternative config (defined by cfgfile)
 %bcond_with    linkfl          # creates links to busybox binary and puts them into file list
 %bcond_without static          # don't build static version
@@ -15,7 +18,6 @@
 %bcond_with    dietlibc        # build dietlibc-based initrd and static versions
 %bcond_with    glibc           # build glibc-based initrd and static versions
 %bcond_with    verbose         # verbose build
-#
 # Options below are useful, when you want fileutils and grep providing.
 # For example, ash package requires fileutils and grep.
 %bcond_with    fileutl_prov    # adds fileutils providing
@@ -34,12 +36,12 @@ Summary(pl.UTF-8):  Zestaw narzędzi uniksowych dla systemów wbudowanych
 Summary(pt_BR.UTF-8):  BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
 # stable line only
-Version:       1.16.2
-Release:       1
+Version:       1.17.3
+Release:       0.1
 License:       GPL
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 2ba980f720a5bdce4ec05423519acc35
+# Source0-md5: a2ce1a951571da8c6e0eaf75b1acef60
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
@@ -74,9 +76,9 @@ BuildRequires:        uClibc-static >= 3:0.9.30.1
                %endif
        %endif
 %endif
+%{?with_sh_prov:Provides:      /bin/sh}
 %{?with_fileutl_prov:Provides: fileutils}
 %{?with_grep_prov:Provides:    grep}
-%{?with_sh_prov:Provides:      /bin/sh}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
@@ -151,7 +153,7 @@ Statycznie skonsolidowany busybox dla initrd.
 %setup -q
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
@@ -175,9 +177,9 @@ install %{SOURCE2} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-    %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
-    %endif
+       %endif
        CC="%{_target_cpu}-uclibc-gcc"
 %endif
 %endif
@@ -207,9 +209,9 @@ install %{SOURCE1} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-    %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
-    %endif
+       %endif
        CC="%{_target_cpu}-uclibc-gcc"
 %endif
 %endif
@@ -257,7 +259,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS README .config
 
 %if %{with linkfl}
-%attr(755,root,root) /bin/*
+%attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) /sbin/*
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
This page took 0.188616 seconds and 4 git commands to generate.