]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- up to 1.24.2
[packages/busybox.git] / busybox.spec
index e7dd4f891af9db96006e7a1dd4595ec54a470822..e7df2bfb506333f9cbaad742b1274b9d00cbb6a9 100644 (file)
@@ -18,7 +18,7 @@
 %bcond_without initrd          # don't build initrd version
 %bcond_with    dietlibc        # build dietlibc-based initrd and static versions
 %bcond_with    glibc           # build glibc-based initrd and static versions
-%bcond_with    verbose         # verbose build
+%bcond_without verbose         # verbose build
 # Options below are useful, when you want fileutils and grep providing.
 # For example, ash package requires fileutils and grep.
 %bcond_with    fileutl_prov    # adds fileutils providing
 # functionality as their GNU countenders.
 #
 %ifnarch %{ix86} %{x8664} ppc
-%define with_glibc 1
+%define                with_glibc      1
+%endif
+%ifarch x32
+# until uClibc builds on x32
+%undefine      with_static
 %endif
 Summary:       Set of common Unix utilities for embeded systems
 Summary(pl.UTF-8):     Zestaw narzędzi uniksowych dla systemów wbudowanych
 Summary(pt_BR.UTF-8):  BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
 # stable line only
-Version:       1.20.2
-Release:       0.1
+Version:       1.24.2
+Release:       1
 License:       GPL v2
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: e025414bc6cd79579cc7a32a45d3ae1c
+# Source0-md5: 2eaae519cac1143bcf583636a745381f
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
-Patch100:      http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-kernel_ver.patch
-# Patch100-md5:        3386a2bf992f2284b86608498f4cb822
-Patch101:      http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-pkg-config-selinux.patch
-# Patch101-md5:        a1b6587697c70808808f3693c4610884
-Patch102:      http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-sys-resource.patch
-# Patch102-md5:        cfb5d5d7ed1414b5749f2c2ec0bf066a
-
+Patch100:      https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2147.patch
+# Patch100-md5:        c45a85f5ced712743efbb683900f8c1d
+Patch101:      https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2148.patch
+# Patch101-md5:        850a57ca2871e370b4916161a0320a3f
+Patch102:      https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-ash-recursive-heredocs.patch
+# Patch102-md5:        b59eb7536609db1ab5215de860d9e558
+Patch0:                x32.patch
 Patch1:                %{name}-logconsole.patch
 Patch2:                %{name}-printf-gettext.patch
 Patch3:                %{name}-loadfont.patch
@@ -64,7 +68,7 @@ Patch9:               %{name}-ash-export-PATH.patch
 URL:           http://www.busybox.net/
 BuildRequires: gcc >= 3.2
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.333
+BuildRequires: rpmbuild(macros) >= 1.652
 %if %{with initrd} || %{with static}
        %if %{with dietlibc}
 BuildRequires: dietlibc-static
@@ -72,7 +76,7 @@ BuildRequires:        dietlibc-static
                %if %{with glibc}
 BuildRequires: glibc-static
                %else
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
 BuildRequires: cross%{_target_base_arch}-uClibc-static
 %else
        %ifarch ppc %{x8664}
@@ -91,7 +95,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
 
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
        %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
 %else
        %define CrossOpts %{nil}
@@ -163,6 +167,7 @@ Statycznie skonsolidowany busybox dla initrd.
 %patch101 -p1
 %patch102 -p1
 
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 #%patch3 -p1
@@ -189,7 +194,7 @@ install %{SOURCE2} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-       %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
        %endif
        CC="%{_target_cpu}-uclibc-gcc"
@@ -220,7 +225,7 @@ install %{SOURCE1} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-       %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
        %endif
        CC="%{_target_cpu}-uclibc-gcc"
@@ -278,7 +283,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS README .config
 
 %if %{with linkfl}
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) /bin/*
 %attr(755,root,root) /sbin/*
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
@@ -287,7 +292,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %{_libdir}/busybox
-%{_mandir}/man1/*
+%{_mandir}/man1/busybox.1*
 %endif
 
 %if %{with static}
This page took 0.057933 seconds and 4 git commands to generate.