]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
rel 8; enable builtin sleep for initrd
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.26.2
45 Release:        1
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  bb59d25ee2643db20f212eec539429f1
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch0:         x32.patch
54 Patch1:         %{name}-logconsole.patch
55 Patch2:         %{name}-printf-gettext.patch
56 Patch3:         %{name}-loadfont.patch
57 Patch4:         %{name}-kernel_headers.patch
58 Patch5:         %{name}-insmod-morearchs.patch
59 Patch6:         %{name}-dhcp.patch
60 Patch7:         %{name}-fix_64_archs.patch
61 Patch9:         %{name}-ash-export-PATH.patch
62 URL:            http://www.busybox.net/
63 BuildRequires:  gcc >= 3.2
64 BuildRequires:  perl-tools-pod
65 BuildRequires:  rpmbuild(macros) >= 1.652
66 %if %{with initrd} || %{with static}
67         %if %{with dietlibc}
68 BuildRequires:  dietlibc-static
69         %else
70                 %if %{with glibc}
71 BuildRequires:  glibc-static
72                 %else
73 %if "%{_target_base_arch}" != "%{_host_base_arch}"
74 BuildRequires:  cross%{_target_base_arch}-uClibc-static
75 %else
76         %ifarch ppc %{x8664}
77 BuildRequires:  uClibc-static >= 3:0.9.30.1
78         %else
79 BuildRequires:  uClibc-static >= 3:0.9.30.1
80         %endif
81 %endif
82                 %endif
83         %endif
84 %endif
85 %{?with_sh_prov:Provides:       /bin/sh}
86 %{?with_fileutl_prov:Provides:  fileutils}
87 %{?with_grep_prov:Provides:     grep}
88 Provides:       busybox-implementation = %{version}-%{release}
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _bindir         /bin
92
93 %if "%{_target_base_arch}" != "%{_host_base_arch}"
94         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
95 %else
96         %define CrossOpts %{nil}
97 %endif
98
99 %define         filterout_ld    -Wl,-z,(combreloc|relro)
100
101 %description
102 BusyBox combines tiny versions of many common UNIX utilities into a
103 single small executable. It provides minimalist replacements for most
104 of the utilities you usually find in fileutils, shellutils, findutils,
105 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
106 POSIX environment for any small or embedded system. The utilities in
107 BusyBox generally have fewer options than their full-featured GNU
108 cousins; however, the options that are included provide the expected
109 functionality and behave very much like their GNU counterparts.
110
111 BusyBox has been written with size-optimization and limited resources
112 in mind. It is also extremely modular so you can easily include or
113 exclude commands (or features) at compile time. This makes it easy to
114 customize your embedded systems. To create a working system, just add
115 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
116 ae).
117
118 %description -l pl.UTF-8
119 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
120 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
121 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
122 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
123 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
124 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
125 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
126 (np. elvis-tiny albo ae).
127
128 %description -l pt_BR.UTF-8
129 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
130 executável, fornecendo substitutos minimalistas para muitos dos
131 executáveis encontrados em pacotes como fileutils, shellutils,
132 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
133 em geral têm menos opções que os utilitários GNU, mas as opções
134 implementadas comportam-se de maneira similar aos equivalentes GNU.
135
136 %package static
137 Summary:        Static busybox
138 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
139 Group:          Applications
140
141 %description static
142 Static busybox.
143
144 %description static -l pl.UTF-8
145 Statycznie skonsolidowany busybox.
146
147 %package initrd
148 Summary:        Static busybox for initrd
149 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
150 Group:          Base
151 Conflicts:      geninitrd < 10000.20
152 Provides:       busybox-implementation = %{version}-%{release}
153
154 %description initrd
155 Static busybox for initrd.
156
157 %description initrd -l pl.UTF-8
158 Statycznie skonsolidowany busybox dla initrd.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165 #%patch3 -p1
166 %patch4 -p1
167 %patch5 -p1
168 %patch6 -p1
169 %patch7 -p1
170 %patch9 -p1
171
172 %build
173 install -d built
174 %if %{with initrd}
175 install %{SOURCE2} .config
176 %{__make} oldconfig
177 %{__make} \
178         %{?with_verbose:V=1} \
179         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
180         LDFLAGS="%{rpmldflags} -static" \
181 %if %{with dietlibc}
182         LIBRARIES="-lrpc" \
183         CC="diet %{__cc}"
184 %else
185 %if %{with glibc}
186         %{CrossOpts} \
187         CC="%{__cc}"
188 %else
189         %if "%{_target_base_arch}" != "%{_host_base_arch}"
190         CROSS="%{_target_cpu}-uclibc-" \
191         %endif
192         CC="%{_target_cpu}-uclibc-gcc"
193 %endif
194 %endif
195
196 mv -f busybox built/busybox.initrd
197 %{__make} clean
198 %endif
199
200 %if %{with altconfig}
201 install %{SOURCE3} .config
202 %else
203 install %{SOURCE1} .config
204 %endif
205
206 %if %{with static}
207 %{__make} oldconfig
208 %{__make} \
209         %{?with_verbose:V=1} \
210         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
211         LDFLAGS="%{rpmldflags} -static" \
212 %if %{with dietlibc}
213         LIBRARIES="-lrpc" \
214         CC="diet %{__cc}"
215 %else
216 %if %{with glibc}
217         %{CrossOpts} \
218         CC="%{__cc}"
219 %else
220         %if "%{_target_base_arch}" != "%{_host_base_arch}"
221         CROSS="%{_target_cpu}-uclibc-" \
222         %endif
223         CC="%{_target_cpu}-uclibc-gcc"
224 %endif
225 %endif
226
227 mv -f busybox built/busybox.static
228 %{__make} clean
229 %endif
230
231 %if %{with dynamic}
232 %{__make} oldconfig
233 %{__make} \
234         %{?with_verbose:V=1} \
235         %{CrossOpts} \
236         CFLAGS_EXTRA="%{rpmcflags}" \
237         LDFLAGS="%{rpmldflags}" \
238         CC="%{__cc}"
239 %{__make} busybox.links docs/busybox.1
240 %endif
241
242 %install
243 rm -rf $RPM_BUILD_ROOT
244
245 %if %{with static}
246 install -d $RPM_BUILD_ROOT%{_bindir}
247 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
248 %endif
249
250 %if %{with initrd}
251 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
252 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
253 %endif
254
255 %if %{with dynamic}
256 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
257 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
258 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
259
260 # install links to busybox binary, when linkfl is defined
261 %if %{with linkfl}
262 %{__make} install \
263         PREFIX=$RPM_BUILD_ROOT
264 %else
265 install busybox $RPM_BUILD_ROOT%{_bindir}
266 %endif
267 %endif
268
269 %clean
270 rm -rf $RPM_BUILD_ROOT
271
272 %if %{with dynamic}
273 %files
274 %defattr(644,root,root,755)
275 %doc AUTHORS README .config
276
277 %if %{with linkfl}
278 %attr(755,root,root) /bin/*
279 %attr(755,root,root) /sbin/*
280 %attr(755,root,root) %{_bindir}/*
281 %attr(755,root,root) %{_sbindir}/*
282 %else
283 %attr(755,root,root) %{_bindir}/busybox
284 %endif
285
286 %{_libdir}/busybox
287 %{_mandir}/man1/busybox.1*
288 %endif
289
290 %if %{with static}
291 %files static
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_bindir}/busybox.static
294 %endif
295
296 %if %{with initrd}
297 %files initrd
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_libdir}/initrd/busybox
300 %endif
This page took 0.211817 seconds and 3 git commands to generate.