]> git.pld-linux.org Git - packages/busybox.git/blame_incremental - busybox.spec
- enabled nc (netcat)
[packages/busybox.git] / busybox.spec
... / ...
CommitLineData
1Summary: Set of common unix utils for embeded systems
2Name: busybox
3Version: 0.51
4Release: 10
5License: GPL
6Group: Applications
7Group(de): Applikationen
8Group(pl): Aplikacje
9Source0: ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10Source1: %{name}-config.h
11Patch0: %{name}-logconsole.patch
12Patch1: %{name}-tee.patch
13Patch2: %{name}-sh-name.patch
14Patch3: %{name}-printf-gettext.patch
15Patch4: %{name}-loadfont.patch
16Patch5: %{name}-cread.patch
17URL: http://busybox.lineo.com/
18%{?BOOT:BuildRequires: uClibc-devel-BOOT >= 20010521-3}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22BusyBox combines tiny versions of many common UNIX utilities into a
23single small executable. It provides minimalist replacements for most
24of the utilities you usually find in fileutils, shellutils, findutils,
25textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
26POSIX environment for any small or embedded system. The utilities in
27BusyBox generally have fewer options than their full-featured GNU
28cousins; however, the options that are included provide the expected
29functionality and behave very much like their GNU counterparts.
30
31BusyBox has been written with size-optimization and limited resources
32in mind. It is also extremely modular so you can easily include or
33exclude commands (or features) at compile time. This makes it easy to
34customize your embedded systems. To create a working system, just add
35a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
36ae).
37
38%package BOOT
39Summary: busybox for PLD bootdisk
40Group: Applications
41Group(de): Applikationen
42Group(pl): Aplikacje
43
44%description BOOT
45busybox for PLD bootdisk.
46
47%prep
48%setup -q
49%patch0
50%patch1
51%patch2 -p1
52%patch3 -p1
53%patch4 -p1
54%patch5 -p1
55
56%build
57# BOOT
58cp %{SOURCE1} Config.h
59%{__make} \
60 CFLAGS_EXTRA="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
61 LDFLAGS="-nostdlib -s" \
62 LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
63
64# TODO make main package dynamically linked
65
66%install
67rm -rf $RPM_BUILD_ROOT
68%{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
69%{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/{bin,%{_libdir}/busybox}
70
71%{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
72
73for i in `cat busybox.links`; do
74 ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
75done
76%{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
77# change sh to lash (see sh_name patch)
78mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
79
80%{__install} busybox $RPM_BUILD_ROOT%{_bindir}
81%{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
82%{__install} docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
83echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
84
85gzip -9nf AUTHORS TODO Changelog README
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
92%doc *.gz
93%attr(755,root,root) %{_bindir}/*
94%{_libdir}/busybox
95%{_mandir}/man1/*
96
97%files BOOT
98%defattr(644,root,root,755)
99%attr(755,root,root) %{_libdir}/bootdisk/bin/*
100%{_libdir}/bootdisk%{_libdir}/*
This page took 1.16885 seconds and 4 git commands to generate.