]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- rel 3; show usage help in initrd applets when wrongly called
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
3637c580
JR
16%bcond_without static # don't build static version
17%bcond_without initrd # don't build initrd version
18%bcond_with dietlibc # build dietlibc-based initrd and static versions
19%bcond_with glibc # build glibc-based initrd and static versions
20%bcond_with verbose # verbose build
d635bde0 21# Options below are useful, when you want fileutils and grep providing.
22# For example, ash package requires fileutils and grep.
2678f462
JB
23%bcond_with fileutl_prov # adds fileutils providing
24%bcond_with grep_prov # adds grep providing
d635bde0 25# Option below is useful, when busybox is built with shell support.
2678f462 26%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 27# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 28# Fileutils, grep and shell provided with busybox have not such
29# functionality as their GNU countenders.
2678f462 30#
c15e3058 31%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
32%define with_glibc 1
33%endif
dce89576 34Summary: Set of common Unix utilities for embeded systems
718bff43
ER
35Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
36Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 37Name: busybox
586f52e3 38# stable line only
ddb676e8 39Version: 1.18.3
ede1d75f 40Release: 3
ee61dafa 41License: GPL
d79d7625 42Group: Applications
693dc2a0 43Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
ddb676e8 44# Source0-md5: 660af4d44661d32b22025a66f4f78df2
4f8fe04f
AM
45Source1: %{name}.config
46Source2: %{name}-initrd.config
8f98fac8 47%{?with_altconfig:Source3: %{cfgfile}}
08457c94
AM
48Patch100: busybox-1.18.3-buildsys.patch
49Patch101: busybox-1.18.3-modutils24.patch
50Patch102: busybox-1.18.3-wget.patch
b2b9509f 51Patch1: %{name}-logconsole.patch
52Patch2: %{name}-printf-gettext.patch
53Patch3: %{name}-loadfont.patch
29a4a582
JR
54Patch4: %{name}-kernel_headers.patch
55Patch5: %{name}-insmod-morearchs.patch
56Patch6: %{name}-dhcp.patch
57Patch7: %{name}-fix_64_archs.patch
29a4a582 58Patch9: %{name}-ash-export-PATH.patch
87902b66 59URL: http://www.busybox.net/
255676bf 60BuildRequires: gcc >= 3.2
839c36a5 61BuildRequires: perl-tools-pod
02cf2722 62BuildRequires: rpmbuild(macros) >= 1.333
ef0df9c1 63%if %{with initrd} || %{with static}
6f6b5afa 64 %if %{with dietlibc}
1735ff25 65BuildRequires: dietlibc-static
6f6b5afa 66 %else
67 %if %{with glibc}
1735ff25 68BuildRequires: glibc-static
6f6b5afa 69 %else
9922ba41 70%if "%{_target_base_arch}" != "%{_arch}"
71BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 72%else
9922ba41 73 %ifarch ppc %{x8664}
c574afd9 74BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 75 %else
c574afd9 76BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 77 %endif
9a45af3a 78%endif
6f6b5afa 79 %endif
80 %endif
1735ff25 81%endif
a54ace54 82%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
83%{?with_fileutl_prov:Provides: fileutils}
84%{?with_grep_prov:Provides: grep}
ee61dafa
MM
85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
e7982b05 87%define _bindir /bin
fc11b50f 88
9922ba41 89%if "%{_target_base_arch}" != "%{_arch}"
90 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
91%else
92 %define CrossOpts %{nil}
93%endif
94
558ca139
JR
95%define filterout_ld -Wl,-z,(combreloc|relro)
96
ee61dafa 97%description
65512310 98BusyBox combines tiny versions of many common UNIX utilities into a
99single small executable. It provides minimalist replacements for most
100of the utilities you usually find in fileutils, shellutils, findutils,
101textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
102POSIX environment for any small or embedded system. The utilities in
103BusyBox generally have fewer options than their full-featured GNU
104cousins; however, the options that are included provide the expected
105functionality and behave very much like their GNU counterparts.
106
107BusyBox has been written with size-optimization and limited resources
108in mind. It is also extremely modular so you can easily include or
109exclude commands (or features) at compile time. This makes it easy to
110customize your embedded systems. To create a working system, just add
111a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
112ae).
ee61dafa 113
c499e458
JR
114%description -l pl.UTF-8
115BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
116wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 117zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
118tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
119lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
120odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
121systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
122(np. elvis-tiny albo ae).
123
c499e458
JR
124%description -l pt_BR.UTF-8
125BusyBox combina versões reduzidas de muitos utilitários UNIX num único
126executável, fornecendo substitutos minimalistas para muitos dos
127executáveis encontrados em pacotes como fileutils, shellutils,
128findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
129em geral têm menos opções que os utilitários GNU, mas as opções
68092394 130implementadas comportam-se de maneira similar aos equivalentes GNU.
131
34ec6041
JB
132%package static
133Summary: Static busybox
718bff43 134Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 135Group: Applications
34ec6041
JB
136
137%description static
138Static busybox.
139
c499e458 140%description static -l pl.UTF-8
dfafd31f 141Statycznie skonsolidowany busybox.
34ec6041 142
52db7bd4
MM
143%package initrd
144Summary: Static busybox for initrd
718bff43 145Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 146Group: Base
1857f402 147Conflicts: geninitrd < 10000.20
52db7bd4
MM
148
149%description initrd
150Static busybox for initrd.
151
c499e458 152%description initrd -l pl.UTF-8
dfafd31f 153Statycznie skonsolidowany busybox dla initrd.
52db7bd4 154
ee61dafa 155%prep
693dc2a0 156%setup -q
08457c94
AM
157%patch100 -p1
158%patch101 -p1
159%patch102 -p1
0b555ee8
JB
160%patch1 -p1
161%patch2 -p1
a54ace54 162#%patch3 -p1
0cf45dc5 163%patch4 -p1
0b555ee8 164%patch5 -p1
5a7abf9a 165%patch6 -p1
0b555ee8 166%patch7 -p1
586f52e3 167%patch9 -p1
ea0cda84 168
ee61dafa 169%build
839c36a5 170install -d built
52db7bd4 171%if %{with initrd}
4f8fe04f
AM
172install %{SOURCE2} .config
173%{__make} oldconfig
52db7bd4 174%{__make} \
91a4c8e3 175 %{?with_verbose:V=1} \
95f61a42 176 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
02cf2722 177 LDFLAGS="%{ld_rpmldflags} -static" \
27ca3ce9 178%if %{with dietlibc}
52db7bd4 179 LIBRARIES="-lrpc" \
661e2e64 180 CC="diet %{__cc}"
1735ff25
MM
181%else
182%if %{with glibc}
9922ba41 183 %{CrossOpts} \
1735ff25 184 CC="%{__cc}"
27ca3ce9 185%else
a54ace54 186 %if "%{_target_base_arch}" != "%{_arch}"
9922ba41 187 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 188 %endif
27ca3ce9
AM
189 CC="%{_target_cpu}-uclibc-gcc"
190%endif
1735ff25
MM
191%endif
192
839c36a5 193mv -f busybox built/busybox.initrd
52db7bd4 194%{__make} clean
52db7bd4
MM
195%endif
196
13fc95fb 197
1735ff25
MM
198%if %{with altconfig}
199install %{SOURCE3} .config
13fc95fb
ER
200%else
201install %{SOURCE1} .config
1735ff25
MM
202%endif
203
4a69c6c5 204%if %{with static}
4f8fe04f 205%{__make} oldconfig
6f6b5afa 206%{__make} \
91a4c8e3 207 %{?with_verbose:V=1} \
ef0df9c1 208 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
02cf2722 209 LDFLAGS="%{ld_rpmldflags} -static" \
ef0df9c1
JR
210%if %{with dietlibc}
211 LIBRARIES="-lrpc" \
661e2e64 212 CC="diet %{__cc}"
ef0df9c1
JR
213%else
214%if %{with glibc}
215 %{CrossOpts} \
52db7bd4 216 CC="%{__cc}"
ef0df9c1 217%else
a54ace54 218 %if "%{_target_base_arch}" != "%{_arch}"
ef0df9c1 219 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 220 %endif
ef0df9c1
JR
221 CC="%{_target_cpu}-uclibc-gcc"
222%endif
223%endif
224
839c36a5 225mv -f busybox built/busybox.static
2481202a 226%{__make} clean
34ec6041 227%endif
2481202a 228
b5011fd7 229%{__make} oldconfig
b7f899e9 230%{__make} \
91a4c8e3 231 %{?with_verbose:V=1} \
9922ba41 232 %{CrossOpts} \
b7f899e9 233 CFLAGS_EXTRA="%{rpmcflags}" \
02cf2722 234 LDFLAGS="%{ld_rpmldflags}" \
f5ad7fd6 235 CC="%{__cc}"
bf1f4257 236%{__make} busybox.links docs/busybox.1
4e2ab1f5 237
ee61dafa
MM
238%install
239rm -rf $RPM_BUILD_ROOT
17f25024 240install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 241
839c36a5 242%{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
a71afd72
JR
243%if %{with initrd}
244install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 245install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 246%endif
34ec6041 247
b7f899e9 248install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 249install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 250
d635bde0 251# install links to busybox binary, when linkfl is defined
4a69c6c5 252%if %{with linkfl}
2678f462 253%{__make} install \
5a7abf9a 254 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
255%else
256install busybox $RPM_BUILD_ROOT%{_bindir}
257%endif
d635bde0 258
ee61dafa
MM
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%files
263%defattr(644,root,root,755)
a230e0df 264%doc AUTHORS README .config
d635bde0 265
4a69c6c5 266%if %{with linkfl}
a54ace54 267%attr(755,root,root) %{_bindir}/*
d635bde0 268%attr(755,root,root) /sbin/*
269%attr(755,root,root) %{_bindir}/*
270%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
271%else
272%attr(755,root,root) %{_bindir}/busybox
d635bde0 273%endif
274
65512310 275%{_libdir}/busybox
276%{_mandir}/man1/*
bb4ca08e 277
4a69c6c5 278%if %{with static}
34ec6041
JB
279%files static
280%defattr(644,root,root,755)
281%attr(755,root,root) %{_bindir}/busybox.static
282%endif
52db7bd4
MM
283
284%if %{with initrd}
285%files initrd
286%defattr(644,root,root,755)
1857f402 287%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 288%endif
This page took 0.181345 seconds and 4 git commands to generate.