]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
dynamic configuration needs libtirpc-devel
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
4643837f 19%bcond_with musl # build musl-based initrd and static versions
3637c580 20%bcond_with glibc # build glibc-based initrd and static versions
494a100b 21%bcond_without verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
9e624dde 33%define with_musl 1
1735ff25 34%endif
dce89576 35Summary: Set of common Unix utilities for embeded systems
718bff43
ER
36Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
37Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 38Name: busybox
586f52e3 39# stable line only
36e1d67e 40Version: 1.35.0
a9ed32a3 41Release: 2
bbbc183d 42License: GPL v2
d79d7625 43Group: Applications
693dc2a0 44Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
36e1d67e 45# Source0-md5: 585949b1dd4292b604b7d199866e9913
4f8fe04f
AM
46Source1: %{name}.config
47Source2: %{name}-initrd.config
8f98fac8 48%{?with_altconfig:Source3: %{cfgfile}}
aad3a7f3 49Patch0: x32.patch
b2b9509f 50Patch1: %{name}-logconsole.patch
51Patch2: %{name}-printf-gettext.patch
52Patch3: %{name}-loadfont.patch
29a4a582
JR
53Patch4: %{name}-kernel_headers.patch
54Patch5: %{name}-insmod-morearchs.patch
55Patch6: %{name}-dhcp.patch
56Patch7: %{name}-fix_64_archs.patch
7a6bf0ae 57Patch8: busybox-1.31.1-stime-fix.patch
29a4a582 58Patch9: %{name}-ash-export-PATH.patch
459c400e 59Patch10: 0001-modutils-check-ELF-header-before-calling-finit_module.patch
b36f2957 60Patch11: strip-quotes.patch
87902b66 61URL: http://www.busybox.net/
255676bf 62BuildRequires: gcc >= 3.2
839c36a5 63BuildRequires: perl-tools-pod
d41f35db 64BuildRequires: rpmbuild(macros) >= 1.652
7d81af7d 65%if %{with glibc} || %{with dynamic}
6648e383
JP
66BuildRequires: libtirpc-devel
67BuildRequires: pkgconfig
68%endif
ef0df9c1 69%if %{with initrd} || %{with static}
4643837f
AM
70 %if %{with musl}
71BuildRequires: linux-musl-headers
72BuildRequires: musl-devel
d32b3739 73BuildRequires: libtirpc-musl-devel
6f6b5afa 74 %else
75 %if %{with glibc}
1735ff25 76BuildRequires: glibc-static
b36f2957 77BuildRequires: libcom_err-static
6648e383 78BuildRequires: libtirpc-static
b36f2957
AM
79BuildRequires: openssl-static
80BuildRequires: sqlite3-static
6f6b5afa 81 %else
cbbddfaa 82%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 83BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 84%else
9922ba41 85 %ifarch ppc %{x8664}
c574afd9 86BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 87 %else
c574afd9 88BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 89 %endif
9a45af3a 90%endif
6f6b5afa 91 %endif
92 %endif
1735ff25 93%endif
a54ace54 94%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
95%{?with_fileutl_prov:Provides: fileutils}
96%{?with_grep_prov:Provides: grep}
0f80cc3e 97Provides: busybox-implementation = %{version}-%{release}
ee61dafa
MM
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
a7ec8c50
AM
100%define _enable_debug_packages 0
101
e7982b05 102%define _bindir /bin
fc11b50f 103
cbbddfaa 104%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 105 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
106%else
107 %define CrossOpts %{nil}
108%endif
109
558ca139
JR
110%define filterout_ld -Wl,-z,(combreloc|relro)
111
6648e383 112%define tirpccflags %(pkg-config --cflags libtirpc)
c92df9cf 113%if %{with glibc}
6648e383 114%if %{with initrd} || %{with static}
b36f2957 115%define tirpcslibs %(pkg-config --libs --static libtirpc krb5 krb5-gssapi openssl sqlite3|sed 's/-l//g')
6648e383 116%endif
6648e383 117%endif
c92df9cf
AM
118
119%if %{with dynamic}
120%define tirpcdlibs %(pkg-config --libs libtirpc|sed s/-l//g)
6648e383
JP
121%endif
122
a9ed32a3
AM
123%if %{with musl}
124%define tirpcslibs %(pkg-config --libs libtirpc|sed s/-l//g)
125%endif
126
ee61dafa 127%description
65512310 128BusyBox combines tiny versions of many common UNIX utilities into a
129single small executable. It provides minimalist replacements for most
130of the utilities you usually find in fileutils, shellutils, findutils,
131textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
132POSIX environment for any small or embedded system. The utilities in
133BusyBox generally have fewer options than their full-featured GNU
134cousins; however, the options that are included provide the expected
135functionality and behave very much like their GNU counterparts.
136
137BusyBox has been written with size-optimization and limited resources
138in mind. It is also extremely modular so you can easily include or
139exclude commands (or features) at compile time. This makes it easy to
140customize your embedded systems. To create a working system, just add
141a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
142ae).
ee61dafa 143
c499e458
JR
144%description -l pl.UTF-8
145BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
146wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 147zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
148tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
149lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
150odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
151systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
152(np. elvis-tiny albo ae).
153
c499e458
JR
154%description -l pt_BR.UTF-8
155BusyBox combina versões reduzidas de muitos utilitários UNIX num único
156executável, fornecendo substitutos minimalistas para muitos dos
157executáveis encontrados em pacotes como fileutils, shellutils,
158findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
159em geral têm menos opções que os utilitários GNU, mas as opções
68092394 160implementadas comportam-se de maneira similar aos equivalentes GNU.
161
34ec6041
JB
162%package static
163Summary: Static busybox
718bff43 164Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 165Group: Applications
34ec6041
JB
166
167%description static
168Static busybox.
169
c499e458 170%description static -l pl.UTF-8
dfafd31f 171Statycznie skonsolidowany busybox.
34ec6041 172
52db7bd4
MM
173%package initrd
174Summary: Static busybox for initrd
718bff43 175Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 176Group: Base
1857f402 177Conflicts: geninitrd < 10000.20
0f80cc3e 178Provides: busybox-implementation = %{version}-%{release}
52db7bd4
MM
179
180%description initrd
181Static busybox for initrd.
182
c499e458 183%description initrd -l pl.UTF-8
dfafd31f 184Statycznie skonsolidowany busybox dla initrd.
52db7bd4 185
ee61dafa 186%prep
693dc2a0 187%setup -q
aad3a7f3 188%patch0 -p1
0b555ee8
JB
189%patch1 -p1
190%patch2 -p1
a54ace54 191#%patch3 -p1
0cf45dc5 192%patch4 -p1
0b555ee8 193%patch5 -p1
5a7abf9a 194%patch6 -p1
0b555ee8 195%patch7 -p1
7a6bf0ae 196%patch8 -p1
586f52e3 197%patch9 -p1
459c400e 198%patch10 -p1
b36f2957 199%patch11 -p1
ea0cda84 200
ee61dafa 201%build
839c36a5 202install -d built
52db7bd4 203%if %{with initrd}
4f8fe04f 204install %{SOURCE2} .config
4643837f
AM
205%if %{with musl}
206sed -i -e 's|CONFIG_FEATURE_VI_REGEX_SEARCH=y|# CONFIG_FEATURE_VI_REGEX_SEARCH is not set|g' .config
4643837f 207%endif
a9ed32a3 208echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}} %{?with_musl:%{tirpcslibs}}"' >> .config
4f8fe04f 209%{__make} oldconfig
52db7bd4 210%{__make} \
91a4c8e3 211 %{?with_verbose:V=1} \
4643837f
AM
212 EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} -Os -D_GNU_SOURCE %{?with_musl:-I%{_includedir}/musl} %{!?with_glibc:-fno-stack-protector}" \
213 EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack %{?with_musl:-L%{_libdir}/musl}" \
214%if %{with musl}
215 CC="musl-gcc"
1735ff25
MM
216%else
217%if %{with glibc}
9922ba41 218 %{CrossOpts} \
1735ff25 219 CC="%{__cc}"
27ca3ce9 220%else
cbbddfaa 221 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 222 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 223 %endif
27ca3ce9
AM
224 CC="%{_target_cpu}-uclibc-gcc"
225%endif
1735ff25
MM
226%endif
227
839c36a5 228mv -f busybox built/busybox.initrd
52db7bd4 229%{__make} clean
52db7bd4
MM
230%endif
231
6648e383 232%if %{with static}
1735ff25
MM
233%if %{with altconfig}
234install %{SOURCE3} .config
13fc95fb
ER
235%else
236install %{SOURCE1} .config
a9ed32a3 237echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}} %{?with_musl:%{tirpcslibs}}""' >> .config
1735ff25 238%endif
4643837f
AM
239%if %{with musl}
240sed -i -e 's|CONFIG_FEATURE_VI_REGEX_SEARCH=y|# CONFIG_FEATURE_VI_REGEX_SEARCH is not set|g' .config
4643837f
AM
241sed -i -e 's|CONFIG_EXTRA_COMPAT=y|# CONFIG_EXTRA_COMPAT is not set|g' .config
242%endif
4f8fe04f 243%{__make} oldconfig
6f6b5afa 244%{__make} \
91a4c8e3 245 %{?with_verbose:V=1} \
4643837f
AM
246 EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} -Os -D_GNU_SOURCE %{?with_musl:-I%{_includedir}/musl} %{!?with_glibc:-fno-stack-protector}" \
247 EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack %{?with_musl:-L%{_libdir}/musl}" \
248%if %{with musl}
249 CC="musl-gcc"
ef0df9c1
JR
250%else
251%if %{with glibc}
252 %{CrossOpts} \
52db7bd4 253 CC="%{__cc}"
ef0df9c1 254%else
cbbddfaa 255 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 256 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 257 %endif
ef0df9c1
JR
258 CC="%{_target_cpu}-uclibc-gcc"
259%endif
260%endif
261
839c36a5 262mv -f busybox built/busybox.static
2481202a 263%{__make} clean
34ec6041 264%endif
2481202a 265
63de0802 266%if %{with dynamic}
6648e383
JP
267%if %{with altconfig}
268install %{SOURCE3} .config
269%else
270install %{SOURCE1} .config
c92df9cf 271echo 'CONFIG_EXTRA_LDLIBS="%{tirpcdlibs}"' >> .config
6648e383 272%endif
b5011fd7 273%{__make} oldconfig
b7f899e9 274%{__make} \
91a4c8e3 275 %{?with_verbose:V=1} \
9922ba41 276 %{CrossOpts} \
c92df9cf 277 EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} %{!?with_glibc:-fno-stack-protector}" \
fb8bb2b8 278 EXTRA_LDFLAGS="%{rpmldflags} -Wl,-z,noexecstack" \
f5ad7fd6 279 CC="%{__cc}"
bf1f4257 280%{__make} busybox.links docs/busybox.1
63de0802 281%endif
4e2ab1f5 282
ee61dafa
MM
283%install
284rm -rf $RPM_BUILD_ROOT
b7f899e9 285
63de0802
JB
286%if %{with static}
287install -d $RPM_BUILD_ROOT%{_bindir}
288install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
289%endif
290
a71afd72
JR
291%if %{with initrd}
292install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 293install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 294%endif
34ec6041 295
63de0802
JB
296%if %{with dynamic}
297install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 298install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 299install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 300
d635bde0 301# install links to busybox binary, when linkfl is defined
4a69c6c5 302%if %{with linkfl}
2678f462 303%{__make} install \
5a7abf9a 304 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
305%else
306install busybox $RPM_BUILD_ROOT%{_bindir}
307%endif
63de0802 308%endif
d635bde0 309
ee61dafa
MM
310%clean
311rm -rf $RPM_BUILD_ROOT
312
63de0802 313%if %{with dynamic}
ee61dafa
MM
314%files
315%defattr(644,root,root,755)
a230e0df 316%doc AUTHORS README .config
d635bde0 317
4a69c6c5 318%if %{with linkfl}
77109ddb 319%attr(755,root,root) /bin/*
d635bde0 320%attr(755,root,root) /sbin/*
321%attr(755,root,root) %{_bindir}/*
322%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
323%else
324%attr(755,root,root) %{_bindir}/busybox
d635bde0 325%endif
326
65512310 327%{_libdir}/busybox
77109ddb 328%{_mandir}/man1/busybox.1*
63de0802 329%endif
bb4ca08e 330
4a69c6c5 331%if %{with static}
34ec6041
JB
332%files static
333%defattr(644,root,root,755)
334%attr(755,root,root) %{_bindir}/busybox.static
335%endif
52db7bd4
MM
336
337%if %{with initrd}
338%files initrd
339%defattr(644,root,root,755)
1857f402 340%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 341%endif
This page took 0.425594 seconds and 4 git commands to generate.