]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- rel 3; enable more basic utilities for initrd version: chmod, chown, cp, df, ln...
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
21%bcond_with verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
33%define with_glibc 1
34%endif
dce89576 35Summary: Set of common Unix utilities for embeded systems
718bff43
ER
36Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
37Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 38Name: busybox
586f52e3 39# stable line only
49ef74f6 40Version: 1.20.2
8b30709f 41Release: 3
bbbc183d 42License: GPL v2
d79d7625 43Group: Applications
693dc2a0 44Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49ef74f6 45# Source0-md5: e025414bc6cd79579cc7a32a45d3ae1c
4f8fe04f
AM
46Source1: %{name}.config
47Source2: %{name}-initrd.config
8f98fac8 48%{?with_altconfig:Source3: %{cfgfile}}
49ef74f6
AM
49Patch100: http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-kernel_ver.patch
50# Patch100-md5: 3386a2bf992f2284b86608498f4cb822
51Patch101: http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-pkg-config-selinux.patch
52# Patch101-md5: a1b6587697c70808808f3693c4610884
53Patch102: http://busybox.net/downloads/fixes-1.20.2/busybox-1.20.2-sys-resource.patch
54# Patch102-md5: cfb5d5d7ed1414b5749f2c2ec0bf066a
55
b2b9509f 56Patch1: %{name}-logconsole.patch
57Patch2: %{name}-printf-gettext.patch
58Patch3: %{name}-loadfont.patch
29a4a582
JR
59Patch4: %{name}-kernel_headers.patch
60Patch5: %{name}-insmod-morearchs.patch
61Patch6: %{name}-dhcp.patch
62Patch7: %{name}-fix_64_archs.patch
29a4a582 63Patch9: %{name}-ash-export-PATH.patch
87902b66 64URL: http://www.busybox.net/
255676bf 65BuildRequires: gcc >= 3.2
839c36a5 66BuildRequires: perl-tools-pod
d41f35db 67BuildRequires: rpmbuild(macros) >= 1.652
ef0df9c1 68%if %{with initrd} || %{with static}
6f6b5afa 69 %if %{with dietlibc}
1735ff25 70BuildRequires: dietlibc-static
6f6b5afa 71 %else
72 %if %{with glibc}
1735ff25 73BuildRequires: glibc-static
6f6b5afa 74 %else
cbbddfaa 75%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 76BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 77%else
9922ba41 78 %ifarch ppc %{x8664}
c574afd9 79BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 80 %else
c574afd9 81BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 82 %endif
9a45af3a 83%endif
6f6b5afa 84 %endif
85 %endif
1735ff25 86%endif
a54ace54 87%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
88%{?with_fileutl_prov:Provides: fileutils}
89%{?with_grep_prov:Provides: grep}
ee61dafa
MM
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
e7982b05 92%define _bindir /bin
fc11b50f 93
cbbddfaa 94%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 95 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
96%else
97 %define CrossOpts %{nil}
98%endif
99
558ca139
JR
100%define filterout_ld -Wl,-z,(combreloc|relro)
101
ee61dafa 102%description
65512310 103BusyBox combines tiny versions of many common UNIX utilities into a
104single small executable. It provides minimalist replacements for most
105of the utilities you usually find in fileutils, shellutils, findutils,
106textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
107POSIX environment for any small or embedded system. The utilities in
108BusyBox generally have fewer options than their full-featured GNU
109cousins; however, the options that are included provide the expected
110functionality and behave very much like their GNU counterparts.
111
112BusyBox has been written with size-optimization and limited resources
113in mind. It is also extremely modular so you can easily include or
114exclude commands (or features) at compile time. This makes it easy to
115customize your embedded systems. To create a working system, just add
116a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
117ae).
ee61dafa 118
c499e458
JR
119%description -l pl.UTF-8
120BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
121wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 122zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
123tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
124lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
125odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
126systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
127(np. elvis-tiny albo ae).
128
c499e458
JR
129%description -l pt_BR.UTF-8
130BusyBox combina versões reduzidas de muitos utilitários UNIX num único
131executável, fornecendo substitutos minimalistas para muitos dos
132executáveis encontrados em pacotes como fileutils, shellutils,
133findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
134em geral têm menos opções que os utilitários GNU, mas as opções
68092394 135implementadas comportam-se de maneira similar aos equivalentes GNU.
136
34ec6041
JB
137%package static
138Summary: Static busybox
718bff43 139Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 140Group: Applications
34ec6041
JB
141
142%description static
143Static busybox.
144
c499e458 145%description static -l pl.UTF-8
dfafd31f 146Statycznie skonsolidowany busybox.
34ec6041 147
52db7bd4
MM
148%package initrd
149Summary: Static busybox for initrd
718bff43 150Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 151Group: Base
1857f402 152Conflicts: geninitrd < 10000.20
52db7bd4
MM
153
154%description initrd
155Static busybox for initrd.
156
c499e458 157%description initrd -l pl.UTF-8
dfafd31f 158Statycznie skonsolidowany busybox dla initrd.
52db7bd4 159
ee61dafa 160%prep
693dc2a0 161%setup -q
4a48b58b
AM
162%patch100 -p1
163%patch101 -p1
164%patch102 -p1
49ef74f6 165
0b555ee8
JB
166%patch1 -p1
167%patch2 -p1
a54ace54 168#%patch3 -p1
0cf45dc5 169%patch4 -p1
0b555ee8 170%patch5 -p1
5a7abf9a 171%patch6 -p1
0b555ee8 172%patch7 -p1
586f52e3 173%patch9 -p1
ea0cda84 174
ee61dafa 175%build
839c36a5 176install -d built
52db7bd4 177%if %{with initrd}
4f8fe04f
AM
178install %{SOURCE2} .config
179%{__make} oldconfig
52db7bd4 180%{__make} \
91a4c8e3 181 %{?with_verbose:V=1} \
95f61a42 182 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 183 LDFLAGS="%{rpmldflags} -static" \
27ca3ce9 184%if %{with dietlibc}
52db7bd4 185 LIBRARIES="-lrpc" \
661e2e64 186 CC="diet %{__cc}"
1735ff25
MM
187%else
188%if %{with glibc}
9922ba41 189 %{CrossOpts} \
1735ff25 190 CC="%{__cc}"
27ca3ce9 191%else
cbbddfaa 192 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 193 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 194 %endif
27ca3ce9
AM
195 CC="%{_target_cpu}-uclibc-gcc"
196%endif
1735ff25
MM
197%endif
198
839c36a5 199mv -f busybox built/busybox.initrd
52db7bd4 200%{__make} clean
52db7bd4
MM
201%endif
202
1735ff25
MM
203%if %{with altconfig}
204install %{SOURCE3} .config
13fc95fb
ER
205%else
206install %{SOURCE1} .config
1735ff25
MM
207%endif
208
4a69c6c5 209%if %{with static}
4f8fe04f 210%{__make} oldconfig
6f6b5afa 211%{__make} \
91a4c8e3 212 %{?with_verbose:V=1} \
ef0df9c1 213 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 214 LDFLAGS="%{rpmldflags} -static" \
ef0df9c1
JR
215%if %{with dietlibc}
216 LIBRARIES="-lrpc" \
661e2e64 217 CC="diet %{__cc}"
ef0df9c1
JR
218%else
219%if %{with glibc}
220 %{CrossOpts} \
52db7bd4 221 CC="%{__cc}"
ef0df9c1 222%else
cbbddfaa 223 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 224 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 225 %endif
ef0df9c1
JR
226 CC="%{_target_cpu}-uclibc-gcc"
227%endif
228%endif
229
839c36a5 230mv -f busybox built/busybox.static
2481202a 231%{__make} clean
34ec6041 232%endif
2481202a 233
63de0802 234%if %{with dynamic}
b5011fd7 235%{__make} oldconfig
b7f899e9 236%{__make} \
91a4c8e3 237 %{?with_verbose:V=1} \
9922ba41 238 %{CrossOpts} \
b7f899e9 239 CFLAGS_EXTRA="%{rpmcflags}" \
63de0802 240 LDFLAGS="%{rpmldflags}" \
f5ad7fd6 241 CC="%{__cc}"
bf1f4257 242%{__make} busybox.links docs/busybox.1
63de0802 243%endif
4e2ab1f5 244
ee61dafa
MM
245%install
246rm -rf $RPM_BUILD_ROOT
b7f899e9 247
63de0802
JB
248%if %{with static}
249install -d $RPM_BUILD_ROOT%{_bindir}
250install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
251%endif
252
a71afd72
JR
253%if %{with initrd}
254install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 255install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 256%endif
34ec6041 257
63de0802
JB
258%if %{with dynamic}
259install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 260install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 261install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 262
d635bde0 263# install links to busybox binary, when linkfl is defined
4a69c6c5 264%if %{with linkfl}
2678f462 265%{__make} install \
5a7abf9a 266 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
267%else
268install busybox $RPM_BUILD_ROOT%{_bindir}
269%endif
63de0802 270%endif
d635bde0 271
ee61dafa
MM
272%clean
273rm -rf $RPM_BUILD_ROOT
274
63de0802 275%if %{with dynamic}
ee61dafa
MM
276%files
277%defattr(644,root,root,755)
a230e0df 278%doc AUTHORS README .config
d635bde0 279
4a69c6c5 280%if %{with linkfl}
a54ace54 281%attr(755,root,root) %{_bindir}/*
d635bde0 282%attr(755,root,root) /sbin/*
283%attr(755,root,root) %{_bindir}/*
284%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
285%else
286%attr(755,root,root) %{_bindir}/busybox
d635bde0 287%endif
288
65512310 289%{_libdir}/busybox
290%{_mandir}/man1/*
63de0802 291%endif
bb4ca08e 292
4a69c6c5 293%if %{with static}
34ec6041
JB
294%files static
295%defattr(644,root,root,755)
296%attr(755,root,root) %{_bindir}/busybox.static
297%endif
52db7bd4
MM
298
299%if %{with initrd}
300%files initrd
301%defattr(644,root,root,755)
1857f402 302%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 303%endif
This page took 0.168961 seconds and 4 git commands to generate.