]> git.pld-linux.org Git - packages/bugzilla.git/blob - bugzilla.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/bugzilla.git] / bugzilla.spec
1 # TODO
2 # - Split DB packages for mysql/pgsql
3 # - fill brr and add autodeps bcond
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Bug tracking system
6 Summary(pl.UTF-8):      System śledzenia błędów
7 Name:           bugzilla
8 Version:        3.3.3
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/WWW
12 Source0:        http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
13 # Source0-md5:  893273266255f15e5b253719e8abcb50
14 Source1:        %{name}-skins.tar.bz2
15 # Source1-md5:  4e6e8c2b65cab635975eff5ab318057b
16 Source2:        %{name}.conf
17 Source3:        %{name}-localconfig.pl
18 Source4:        %{name}.cron
19 Patch0:         %{name}-pld.patch
20 URL:            http://www.bugzilla.org/
21 # http://www.bugzilla.org/security/3.2.2/
22 BuildRequires:  security(3.2.2)
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 BuildRequires:  sed >= 4.0
26 Requires:       perl(Email::MIME::Modifier)
27 Requires:       perl(Email::Send) >= 2.00
28 Requires:       perl-DBD-mysql
29 Requires:       perl-DBI >= 1.41
30 Requires:       perl-MailTools >= 1.67
31 Requires:       smtpdaemon
32 Requires:       webapps
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _webapps        /etc/webapps
37 %define         _webapp         %{name}
38 %define         _sysconfdir     %{_webapps}/%{_webapp}
39 %define         _appdir         %{_datadir}/%{_webapp}
40 # Don't enforce DBD driver and exclude optional packages according to release notes
41 %define         _noautoreq              'perl(DBD::.*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
42
43 #D perl-Apache-DBI-1.01-1, perl-AppConfig-1.56-2, perl-BSD-Resource-1.28-1, perl-Class-Inspector-1.16-1,
44 #D perl-DBD-Pg-1.49-1, perl-Data-Flow-0.09-2, perl-Email-Abstract-2.13-1, perl-Email-Address-1.86-1,
45 #D perl-Email-MIME-1.85-1, perl-Email-MIME-Attachment-Stripper-1.3-1, perl-Email-MIME-ContentType-1.0-1,
46 #D perl-Email-MIME-Creator-1.45-1, perl-Email-MIME-Encodings-1.3-2, perl-Email-MIME-Modifier-1.43-1,
47 #D perl-Email-MessageID-1.35-1, perl-Email-Reply-1.1-1, perl-Email-Send-1.46-1, perl-Email-Simple-1.96-1,
48 #D perl-Email-Simple-Creator-1.41-1, perl-IO-All-0.33-2, perl-IO-String-1.08-1, perl-Module-Pluggable-3.1-4,
49 #D perl-Return-Value-1.28-1, perl-Spiffy-0.30-1, perl-Template-Toolkit-2.15-1, perl-mixin-0.04-1, perl-mod_perl-2.0.3-2
50
51
52 %description
53 Bugzilla is the Bug-Tracking System from the Mozilla project.
54
55 %description -l pl.UTF-8
56 System śledzenia błędów.
57
58 %prep
59 %setup -q %{?_rc:-n %{name}-%{version}%{_rc}} -a1
60 %patch0 -p1
61
62 sed -i -e '
63 s,use lib ".",use lib "%{_appdir}",
64 s,use lib qw(.),use lib "%{_appdir}",
65 ' *.cgi
66
67 find -name CVS -type d | xargs rm -rf
68 find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
69
70 # won't package tests
71 rm -f runtests.pl
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
76         $RPM_BUILD_ROOT%{perl_vendorlib}
77
78 install *.pl $RPM_BUILD_ROOT%{_appdir}
79 cp -a template $RPM_BUILD_ROOT%{_appdir}
80 cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
81
82 install *.{cgi,txt,dtd} js/*.js $RPM_BUILD_ROOT%{_appdir}/htdocs
83 cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
84
85 ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
86
87 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
88 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
89 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
90 install -D %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 if [ "$1" = 1 ]; then
97 # shamelessly stolen from gentoo
98 %banner -e %{name} <<'EOF'
99 0. Bugzilla has been installed into %{_appdir}
100
101 1. To finish the installation, please read
102    http://www.bugzilla.org/docs/%{version}/html/installation.html
103    You will need to run %{_appdir}/checksetup.pl
104
105    IMPORTANT: If you have customized the values in your
106    Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
107    IT. Please see the Release Notes for more details.
108
109 2. Please read the Release Notes, especially if you are upgrading:
110    http://www.bugzilla.org/releases/%{version}/release-notes.html
111 EOF
112 fi
113
114 %triggerin -- apache1 < 1.3.37-3, apache1-base
115 %webapp_register apache %{_webapp}
116
117 %triggerun -- apache1 < 1.3.37-3, apache1-base
118 %webapp_unregister apache %{_webapp}
119
120 %triggerin -- apache < 2.2.0, apache-base
121 %webapp_register httpd %{_webapp}
122
123 %triggerun -- apache < 2.2.0, apache-base
124 %webapp_unregister httpd %{_webapp}
125
126 %files
127 %defattr(644,root,root,755)
128 %doc QUICKSTART README UPGRADING* docs/en/rel_notes.txt docs/en/txt/Bugzilla-Guide.txt
129 %doc contrib docs/en/html
130 %dir %attr(750,root,http) %{_sysconfdir}
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
133 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
134
135 %attr(755,root,root) /etc/cron.daily/bugzilla
136
137 %{perl_vendorlib}/Bugzilla
138 %{perl_vendorlib}/Bugzilla.pm
139
140 %dir %{_appdir}
141 %{_appdir}/template
142 %attr(700,root,root) %{_appdir}/checksetup.pl
143 %attr(755,root,root) %{_appdir}/collectstats.pl
144 %attr(755,root,root) %{_appdir}/email_in.pl
145 %attr(755,root,root) %{_appdir}/importxml.pl
146 %attr(755,root,root) %{_appdir}/install-module.pl
147 %attr(755,root,root) %{_appdir}/jobqueue.pl
148 %attr(755,root,root) %{_appdir}/mod_perl.pl
149 %attr(755,root,root) %{_appdir}/sanitycheck.pl
150 %attr(755,root,root) %{_appdir}/testserver.pl
151 %attr(755,root,root) %{_appdir}/whine.pl
152 %attr(755,root,root) %{_appdir}/whineatnews.pl
153
154 %dir %{_appdir}/htdocs
155 %attr(755,root,root) %{_appdir}/htdocs/*.cgi
156 %{_appdir}/htdocs/*.dtd
157 %{_appdir}/htdocs/*.js
158 %{_appdir}/htdocs/*.txt
159 %{_appdir}/htdocs/graphs
160 %{_appdir}/htdocs/images
161 %{_appdir}/htdocs/js
162 %dir %{_appdir}/htdocs/skins
163 %dir %{_appdir}/htdocs/skins/contrib
164 %dir %{_appdir}/htdocs/skins/contrib/Dusk
165 %dir %{_appdir}/htdocs/skins/custom
166 %{_appdir}/htdocs/skins/standard
167 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/custom/*.css
168 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/contrib/Dusk/*.css
169
170 %dir /var/lib/%{name}
171 %attr(770,root,http) /var/lib/%{name}/data
172 %attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.078041 seconds and 3 git commands to generate.