]> git.pld-linux.org Git - packages/bugzilla.git/blame - bugzilla.spec
- security blocker
[packages/bugzilla.git] / bugzilla.spec
CommitLineData
cfd1a589
ER
1# TODO
2# - Split DB packages for mysql/pgsql
3# - fill brr and add autodeps bcond
8274a9bf
TO
4%include /usr/lib/rpm/macros.perl
5Summary: Bug tracking system
59e2cd84 6Summary(pl.UTF-8): System śledzenia błędów
8274a9bf 7Name: bugzilla
62e780f5 8Version: 3.3.3
a2979f52 9Release: 0.1
8274a9bf 10License: GPL
29309029 11Group: Applications/WWW
f59432ca 12Source0: http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
62e780f5 13# Source0-md5: 893273266255f15e5b253719e8abcb50
b27983c1
ER
14Source1: %{name}-skins.tar.bz2
15# Source1-md5: 4e6e8c2b65cab635975eff5ab318057b
16Source2: %{name}.conf
17Source3: %{name}-localconfig.pl
18Source4: %{name}.cron
6f24946d 19Patch0: %{name}-pld.patch
8274a9bf 20URL: http://www.bugzilla.org/
52df0c76
PG
21# http://www.bugzilla.org/security/3.2.2/
22BuildRequires: security(3.2.2)
90c1b784 23BuildRequires: rpm-perlprov >= 4.1-13
ce824031 24BuildRequires: rpmbuild(macros) >= 1.268
3e50bea3 25BuildRequires: sed >= 4.0
f59432ca
ER
26Requires: perl(Email::MIME::Modifier)
27Requires: perl(Email::Send) >= 2.00
8274a9bf 28Requires: perl-DBD-mysql
2ffbd3ad 29Requires: perl-DBI >= 1.41
6f24946d 30Requires: perl-MailTools >= 1.67
cfd1a589 31Requires: smtpdaemon
bd1423d3 32Requires: webapps
cfd1a589 33BuildArch: noarch
8274a9bf
TO
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
bd1423d3
ER
36%define _webapps /etc/webapps
37%define _webapp %{name}
38%define _sysconfdir %{_webapps}/%{_webapp}
39%define _appdir %{_datadir}/%{_webapp}
d15bced7 40# Don't enforce DBD driver and exclude optional packages according to release notes
2ffbd3ad
ER
41%define _noautoreq 'perl(DBD::.*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
42
43#D perl-Apache-DBI-1.01-1, perl-AppConfig-1.56-2, perl-BSD-Resource-1.28-1, perl-Class-Inspector-1.16-1,
44#D perl-DBD-Pg-1.49-1, perl-Data-Flow-0.09-2, perl-Email-Abstract-2.13-1, perl-Email-Address-1.86-1,
45#D perl-Email-MIME-1.85-1, perl-Email-MIME-Attachment-Stripper-1.3-1, perl-Email-MIME-ContentType-1.0-1,
46#D perl-Email-MIME-Creator-1.45-1, perl-Email-MIME-Encodings-1.3-2, perl-Email-MIME-Modifier-1.43-1,
47#D perl-Email-MessageID-1.35-1, perl-Email-Reply-1.1-1, perl-Email-Send-1.46-1, perl-Email-Simple-1.96-1,
48#D perl-Email-Simple-Creator-1.41-1, perl-IO-All-0.33-2, perl-IO-String-1.08-1, perl-Module-Pluggable-3.1-4,
49#D perl-Return-Value-1.28-1, perl-Spiffy-0.30-1, perl-Template-Toolkit-2.15-1, perl-mixin-0.04-1, perl-mod_perl-2.0.3-2
50
8274a9bf
TO
51
52%description
cfd1a589 53Bugzilla is the Bug-Tracking System from the Mozilla project.
8274a9bf 54
b31e80bd
JR
55%description -l pl.UTF-8
56System śledzenia błędów.
8274a9bf
TO
57
58%prep
b27983c1 59%setup -q %{?_rc:-n %{name}-%{version}%{_rc}} -a1
a8d6ba6e 60%patch0 -p1
6f24946d
ER
61
62sed -i -e '
63s,use lib ".",use lib "%{_appdir}",
64s,use lib qw(.),use lib "%{_appdir}",
65' *.cgi
8274a9bf 66
cfd1a589
ER
67find -name CVS -type d | xargs rm -rf
68find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
8274a9bf 69
6f24946d
ER
70# won't package tests
71rm -f runtests.pl
72
8274a9bf
TO
73%install
74rm -rf $RPM_BUILD_ROOT
6f24946d
ER
75install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
76 $RPM_BUILD_ROOT%{perl_vendorlib}
77
78install *.pl $RPM_BUILD_ROOT%{_appdir}
79cp -a template $RPM_BUILD_ROOT%{_appdir}
80cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
8274a9bf 81
62e780f5 82install *.{cgi,txt,dtd} js/*.js $RPM_BUILD_ROOT%{_appdir}/htdocs
6f24946d 83cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
8274a9bf 84
6f24946d 85ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
a8d6ba6e 86
b27983c1
ER
87install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
88install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
89install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
90install -D %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
8274a9bf
TO
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
6f24946d
ER
95%post
96if [ "$1" = 1 ]; then
4ff49655
ER
97# shamelessly stolen from gentoo
98%banner -e %{name} <<'EOF'
990. Bugzilla has been installed into %{_appdir}
100
1011. To finish the installation, please read
102 http://www.bugzilla.org/docs/%{version}/html/installation.html
103 You will need to run %{_appdir}/checksetup.pl
104
105 IMPORTANT: If you have customized the values in your
106 Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
107 IT. Please see the Release Notes for more details.
108
1092. Please read the Release Notes, especially if you are upgrading:
110 http://www.bugzilla.org/releases/%{version}/release-notes.html
6f24946d
ER
111EOF
112fi
113
04eebeb6 114%triggerin -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
115%webapp_register apache %{_webapp}
116
04eebeb6 117%triggerun -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
118%webapp_unregister apache %{_webapp}
119
120%triggerin -- apache < 2.2.0, apache-base
121%webapp_register httpd %{_webapp}
122
123%triggerun -- apache < 2.2.0, apache-base
124%webapp_unregister httpd %{_webapp}
8274a9bf
TO
125
126%files
127%defattr(644,root,root,755)
62e780f5 128%doc QUICKSTART README UPGRADING* docs/en/rel_notes.txt docs/en/txt/Bugzilla-Guide.txt
129%doc contrib docs/en/html
bd1423d3 130%dir %attr(750,root,http) %{_sysconfdir}
cfd1a589 131%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
bd1423d3 132%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
d15bced7 133%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
bd1423d3 134
4ff49655
ER
135%attr(755,root,root) /etc/cron.daily/bugzilla
136
6f24946d
ER
137%{perl_vendorlib}/Bugzilla
138%{perl_vendorlib}/Bugzilla.pm
139
bd1423d3 140%dir %{_appdir}
bd1423d3 141%{_appdir}/template
b27983c1
ER
142%attr(700,root,root) %{_appdir}/checksetup.pl
143%attr(755,root,root) %{_appdir}/collectstats.pl
144%attr(755,root,root) %{_appdir}/email_in.pl
145%attr(755,root,root) %{_appdir}/importxml.pl
62e780f5 146%attr(755,root,root) %{_appdir}/install-module.pl
147%attr(755,root,root) %{_appdir}/jobqueue.pl
b27983c1 148%attr(755,root,root) %{_appdir}/mod_perl.pl
62e780f5 149%attr(755,root,root) %{_appdir}/sanitycheck.pl
b27983c1
ER
150%attr(755,root,root) %{_appdir}/testserver.pl
151%attr(755,root,root) %{_appdir}/whine.pl
152%attr(755,root,root) %{_appdir}/whineatnews.pl
6f24946d
ER
153
154%dir %{_appdir}/htdocs
b27983c1 155%attr(755,root,root) %{_appdir}/htdocs/*.cgi
6f24946d
ER
156%{_appdir}/htdocs/*.dtd
157%{_appdir}/htdocs/*.js
158%{_appdir}/htdocs/*.txt
6f24946d
ER
159%{_appdir}/htdocs/graphs
160%{_appdir}/htdocs/images
161%{_appdir}/htdocs/js
b27983c1
ER
162%dir %{_appdir}/htdocs/skins
163%dir %{_appdir}/htdocs/skins/contrib
62e780f5 164%dir %{_appdir}/htdocs/skins/contrib/Dusk
b27983c1
ER
165%dir %{_appdir}/htdocs/skins/custom
166%{_appdir}/htdocs/skins/standard
167%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/custom/*.css
62e780f5 168%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/contrib/Dusk/*.css
6f24946d 169
a8d6ba6e
TO
170%dir /var/lib/%{name}
171%attr(770,root,http) /var/lib/%{name}/data
6f24946d 172%attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.083361 seconds and 4 git commands to generate.