]> git.pld-linux.org Git - packages/bttv.git/blob - bttv.spec
- tabs in preamble
[packages/bttv.git] / bttv.spec
1 #
2 # TODO: UP/SMP (if this spec is useful for something now?)
3 #
4 # Conditional build:
5 %bcond_without  dist_kernel     # without kernel from distribution
6 #
7 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
8 %define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
9 %define         smpstr  %{?with_smp:-smp}
10 %define         smp     %{?with_smp:1}%{!?with_smp:0}
11
12 Summary:        BrookTree TV tuner driver
13 Summary(pl.UTF-8):      Sterownik dla kart TV na chipsecie BrookTree
14 Name:           bttv
15 Version:        0.7.87
16 Release:        1
17 License:        GPL
18 Group:          Base/Kernel
19 Source0:        http://dl.bytesex.org/releases/video4linux/%{name}-%{version}.tar.gz
20 # Source0-md5:  61a0e73e433173c10b6edd2e9f27d69e
21 Patch0:         %{name}-Makefile.patch
22 URL:            http://linux.bytesex.org/v4l2/bttv.html
23 BuildRequires:  i2c-devel
24 %{?with_dist_kernel:BuildRequires: kernel-source}
25 BuildRequires:  rpmbuild(macros) >= 1.118
26 BuildConflicts: kernel-source < 2.2.0
27 Requires:       i2c
28 Requires:       modutils
29 ExclusiveArch:  %{ix86}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Kernel modules which add support for TV cards based on BrookTree BT
34 848 and 878 chips.
35
36 %description -l pl.UTF-8
37 Moduły jądra dodające obsługę kart TV na układach BrookTree BT 848 i
38 878.
39
40 %package -n kernel%{smpstr}-misc-bttv
41 Summary:        Kernel modules for BrookTree TV tuner
42 Summary(pl.UTF-8):      Moduły jądra do obsługi tunerów TV BrookTree
43 Release:        %{release}@%{_kernel_ver_str}
44 Group:          Base/Kernel
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       modutils >= 2.4.6-4
47 %{?with_dist_kernel:Conflicts:  kernel < %{_kernel_ver}, kernel > %{_kernel_ver}}
48 %{?with_dist_kernel:Conflicts:  kernel-%{?with_smp:up}%{!?with_smp:smp}}
49 Obsoletes:      bttv
50
51 %description -n kernel%{smpstr}-misc-bttv
52 Kernel modules which add support for TV cards based on BrookTree BT
53 848 and 878 chips.
54
55 %description -n kernel%{smpstr}-misc-bttv -l pl.UTF-8
56 Moduły jądra dodające obsługę kart TV na układach BrookTree BT 848 i
57 878.
58
59 %package devel
60 Summary:        Header files for bttv
61 Summary(pl.UTF-8):      Pliki nagłówkowe bttv
62 Group:          Development
63
64 %description devel
65 Header files for bttv.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe bttv.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 %{__make} \
76         EXTRA_CFLAGS="%{rpmcflags}"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} -C driver install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -n kernel%{smpstr}-misc-bttv
88 %depmod %{_kernel_ver}
89
90 %postun -n kernel%{smpstr}-misc-bttv
91 %depmod %{_kernel_ver}
92
93 %files -n kernel%{smpstr}-misc-bttv
94 %defattr(644,root,root,755)
95 /lib/modules/*/misc/*
96
97 %files
98 %defattr(644,root,root,755)
99 %doc CARDLIST Changes Insmod-options README* Sound-FAQ Specs Cards
100
101 #%files devel
102 #%defattr(644,root,root,755)
103 #%{_kernelsrcdir}/drivers/char/*
This page took 0.07947 seconds and 3 git commands to generate.