]> git.pld-linux.org Git - packages/btsco.git/blame - btsco.spec
- release 20
[packages/btsco.git] / btsco.spec
CommitLineData
80a94d8f 1#
7ebd2e19 2# Conditional build:
3%bcond_without dist_kernel # without kernel from distribution
4%bcond_without kernel # don't build kernel modules
80a94d8f 5%bcond_without userspace # don't build userspace utilities
7ebd2e19 6%bcond_with verbose # verbose build (V=1)
7ebd2e19 7#
28937f42 8%define rel 20
7ebd2e19 9Summary: Bluetooth-alsa Project
cfe0c146 10Summary(pl.UTF-8): Projekt Bluetooth-alsa
7ebd2e19 11Name: btsco
7cf0ed0c 12Version: 0.5
7ebd2e19 13Release: %{rel}
14License: GPL
15Group: Applications/Sound
7cf0ed0c 16Source0: http://dl.sourceforge.net/bluetooth-alsa/%{name}-%{version}.tgz
17# Source0-md5: d9fdd63a9e22ba839a41c8a9b89c2dda
7ebd2e19 18Patch0: %{name}-readme-pl.diff
6ae5c1cc 19Patch1: %{name}-kernel.patch
7ebd2e19 20URL: http://sourceforge.net/projects/bluetooth-alsa/
80a94d8f 21%if %{with kernel}
aed02b42 22%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
80a94d8f
JB
23%endif
24%if %{with userspace}
25BuildRequires: alsa-driver-devel >= 1.0.9-1
26BuildRequires: alsa-lib-devel >= 1.0.9-1
f76a384f
JB
27BuildRequires: autoconf
28BuildRequires: automake
80a94d8f
JB
29BuildRequires: bluez-libs-devel >= 2.21-1
30BuildRequires: libao-devel >= 0.8.6-1
0c774113 31BuildRequires: libtool
1b674bd0 32BuildRequires: rpmbuild(macros) >= 1.379
80a94d8f 33%endif
7ebd2e19 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This project provides a way to use a bluetooth headset with Linux. We
38do this currently by making an alsa kernel driver which uses bluez to
39reach the headset. It works well enough now to get voice-quality audio
40to and from most headsets.
41
f7b96c30
JR
42%description -l pl.UTF-8
43Dzięki temu oprogramowaniu można używać zestawów słuchawkowych
44Bluetooth Headset z Linuksem. Osiągnięto to dzięki zbudowaniu alsowego
45modułu do jądra, który to używa systemu bluez do komunikacji z takim
46zestawem. Współpracuje z większością zestawów, ograniczeniem w
47komunikacji jest często urządzenie USB, które to może mieć
48nieobsługiwane częściowo protokoły, wskazówka: hciconfig hciXXX
49revision. W skrajnym wypadku można próbować użyć innego urządzenia
7ebd2e19 50USB.
51
c954e546 52%package -n kernel%{_alt_kernel}-char-btsco
7ebd2e19 53Summary: Linux ALSA kernel driver for Bluetooth Headset
cfe0c146 54Summary(pl.UTF-8): Sterownik ALSA do jądra Linuksa dla Bluetooth Headset
7ebd2e19 55Release: %{rel}@%{_kernel_ver_str}
56Group: Base/Kernel
1b674bd0 57%{?with_dist_kernel:%requires_releq_kernel}
7ebd2e19 58Requires(post,postun): /sbin/depmod
c954e546 59Requires: kernel%{_alt_kernel}-sound-alsa
7ebd2e19 60
c954e546 61%description -n kernel%{_alt_kernel}-char-btsco
80a94d8f 62Linux ALSA kernel driver for Bluetooth Headset named snd_bt_sco.
7ebd2e19 63
f7b96c30
JR
64%description -n kernel%{_alt_kernel}-char-btsco -l pl.UTF-8
65Sterownik ALSA do jądra Linuksa dla Bluetooth Headset o nazwie
80a94d8f 66snd_bt_sco.
7ebd2e19 67
7ebd2e19 68%prep
69%setup -q
70%patch0 -p1
6ae5c1cc 71%patch1 -p1
7ebd2e19 72
73%build
f76a384f 74%if %{with userspace}
c6a4d97e 75%{__libtoolize}
7ebd2e19 76%{__aclocal}
77%{__autoconf}
f76a384f 78%{__autoheader}
7ebd2e19 79%{__automake}
80%configure
edfb87d1 81%{__make}
80a94d8f 82%endif
7ebd2e19 83
84%if %{with kernel}
9398df1b 85%build_kernel_modules -m snd-bt-sco -C kernel
7ebd2e19 86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
80a94d8f
JB
90
91%if %{with userspace}
92install -d $RPM_BUILD_ROOT%{_bindir}
7ebd2e19 93
94for file in avdtp/avtest sbc/rcplay sbc/sbcenc sbc/sbcinfo a2play btsco2 btsco ; do
95 install $file $RPM_BUILD_ROOT%{_bindir}
96done
80a94d8f 97%endif
7ebd2e19 98
99%if %{with kernel}
9398df1b 100%install_kernel_modules -m kernel/snd-bt-sco -d misc
7ebd2e19 101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
c954e546 106%post -n kernel%{_alt_kernel}-char-btsco
7ebd2e19 107%depmod %{_kernel_ver}
108echo "after install this package, remember add lines like this:"
109echo "alias snd-card-1 snd-bt-sco"
110echo "alias sound-slot-1 snd-bt-sco"
111echo "to %{_sysconfdir}/modprobe.conf"
112
c954e546 113%postun -n kernel%{_alt_kernel}-char-btsco
7ebd2e19 114%depmod %{_kernel_ver}
115
80a94d8f 116%if %{with userspace}
7ebd2e19 117%files
118%defattr(644,root,root,755)
f76a384f 119%doc README README.PL.txt
7ebd2e19 120%attr(755,root,root) %{_bindir}/*
80a94d8f 121%endif
7ebd2e19 122
123%if %{with kernel}
c954e546 124%files -n kernel%{_alt_kernel}-char-btsco
7ebd2e19 125%defattr(644,root,root,755)
126/lib/modules/%{_kernel_ver}/misc/snd-bt-sco.ko.gz
127%endif
This page took 0.091046 seconds and 4 git commands to generate.